Package Details: epiphany-git 43.0+47+g2340606e6-1

Git Clone URL: https://aur.archlinux.org/epiphany-git.git (read-only, click to copy)
Package Base: epiphany-git
Description: A GNOME web browser based on the WebKit rendering engine.
Upstream URL: https://wiki.gnome.org/Apps/Web
Keywords: browser gnome web webkit
Licenses: GPL
Conflicts: epiphany
Provides: epiphany
Replaces: epiphany
Submitter: None
Maintainer: swiftscythe
Last Packager: swiftscythe
Votes: 10
Popularity: 0.39
First Submitted: 2009-05-24 15:59 (UTC)
Last Updated: 2022-10-26 14:45 (UTC)

Latest Comments

1 2 3 Next › Last »

arenm commented on 2022-10-18 18:45 (UTC)

gcr-git provides gcr-4, however it breaks everything that depends on gcr-3. I hope it's possible to resolve that, otherwise this will be in some state of broken for a while :)

swiftscythe commented on 2022-10-18 12:20 (UTC)

@arenm thank you, so far gcr-4 is not available on the AUR or the official repositories, so this won't build… Let me know if I missed something.

arenm commented on 2022-10-18 00:03 (UTC)

This doesn't build since gtk4 support got merged today. Updating the depends array to depends=(webkit2gtk-5.0 libgcr-4-gtk4.so libdazzle libhandy libarchive libportal-gtk4 libadwaita) should fix it. Also namcap warned about files being installed to /usr/libexec which can be fixed by changing the meson command to meson build --prefix=/usr --libexecdir=lib --buildtype=release.

CorvetteCole commented on 2022-07-06 15:13 (UTC)

@swiftscythe you don't have to update -git packages as long as they build the latest commit correctly. Just confirming!

swiftscythe commented on 2022-03-18 00:24 (UTC)

@bittin, does it not build for you anymore? Could you please stop flagging my AUR *-git packages as out of date every time there's a new release? I've been sending you emails about this, and you keep ignoring me. I've emailed you over than 5 times about this!

I thought the whole point of having this *-git packages is that they get updated automatically. If anyone knows if I am supposed to update them whenever there's a release, I will. But I don't think so: as long as it grabs the latest commit and builds fine, the PKGBUILD is serving its purpose.

titaniumtown commented on 2021-11-28 07:54 (UTC)

This package should depend on libhandy-git, not libhandy (I got an error about libhandy version)

electrodeyt commented on 2021-11-26 21:24 (UTC)

The enable_https_option seems to not work

Cloning into 'epiphany'... done. ==> Starting pkgver()... ==> Updated version: epiphany-git 41.0+42+gf9e798b04-1 ==> Sources are ready. ==> Making package: epiphany-git 41.0+42+gf9e798b04-1 (Fri 26 Nov 2021 10:17:06 PM CET) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> WARNING: Using existing $srcdir/ tree ==> Starting pkgver()... ==> Starting build()... The Meson build system Version: 0.60.2 Source dir: /home/alexander/.cache/yay/epiphany-git/src/epiphany Build dir: /home/alexander/.cache/yay/epiphany-git/src/epiphany/build Build type: native build

meson.build:1:0: ERROR: Unknown options: "enable_https_everywhere"

A full log can be found at /home/alexander/.cache/yay/epiphany-git/src/epiphany/build/meson-logs/meson-log.txt ==> ERROR: A failure occurred in build(). Aborting... -> error making: epiphany-git

swiftscythe commented on 2021-09-29 01:54 (UTC)

updated to explicitly depend on webkit2gtk-unstable

adamant.pwn commented on 2021-09-25 15:25 (UTC) (edited on 2021-09-25 15:26 (UTC) by adamant.pwn)

Tried installing, got

Dependency webkit2gtk-4.0 found: NO found 2.32.4 but need: '>= 2.33.2'
Did not find CMake 'cmake'
Found CMake: NO
Run-time dependency webkit2gtk-4.0 found: NO 

meson.build:104:2: ERROR: Invalid version of dependency, need 'webkit2gtk-4.0' ['>= 2.33.2'] found '2.32.4'.

Needed to install cmake and webkit2gtk-unstable.