Package Details: epiphany-git 3.16.1.6.ga966acc-1

Git Clone URL: https://aur.archlinux.org/epiphany-git.git (read-only)
Package Base: epiphany-git
Description: A GNOME web browser based on the WebKit rendering engine.
Upstream URL: http://www.gnome.org/projects/epiphany/
Licenses: GPL
Groups: gnome
Conflicts: epiphany
Provides: epiphany=3.16.1
Replaces: epiphany
Submitter: None
Maintainer: yoseforb
Last Packager: yoseforb
Votes: 4
Popularity: 0.001062
First Submitted: 2009-05-24 15:59
Last Updated: 2015-06-08 15:04

Latest Comments

FallenSnow commented on 2016-04-03 19:32

@archdria doesn't build for me

==> Starting build()...
configure.ac:63: error: macro APPSTREAM_XML is not defined; is a m4 file missing?
/usr/share/aclocal/ax_require_defined.m4:35: AX_REQUIRE_DEFINED is expanded from...
configure.ac:63: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: error: echo failed with exit status: 1

archdria commented on 2016-04-02 09:54

Hi! I've just updated the PKGBUILD to fix the build.
Here's a patch to the PKGBUILD and the PKGBUILD itself:
https://gist.github.com/arrufat/1c4a09731acbe7fcf1d4ecd5d2895d4b

yacuken commented on 2015-08-30 19:32

Latest epiphany require webkit2gtk>=2.9.5
But in repos 2.8.5 only

archdria commented on 2015-08-03 11:12

@neubauten84 you need to add --disable-Werror to the autogen.sh options

neubauten84 commented on 2015-07-13 09:39

Compilation fails:

/usr/include/features.h:328:4: error: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Werror=cpp]
# warning _FORTIFY_SOURCE requires compiling with optimization (-O)

archdria commented on 2015-03-04 14:57

The package depends on libwnck3, otherwise it doesn't start, and yelp-tools is needed to build it.
Also, could you change the source url to "git+https://git.gnome.org/browse/epiphany" so that it works behind an http proxy? Thank you

archdria commented on 2015-03-04 14:48

The package depends on libwnck3, otherwise it doesn't start.
Also, could you change the source url to "git+https://git.gnome.org/browse/epiphany" so that it works behind an http proxy? Thank you

ricardomv commented on 2014-01-14 03:53

this should depend on webkitgtk2-svn becaue it requires webkitgtk2 >= 2.3.4

ricardomv commented on 2014-01-14 03:52

this should depend on webgtk2-svn becaue it requires webkitgtk2 >= 2.3.4

ndowens commented on 2013-08-15 00:49

@Opanos: it is because you don't have git installed

Opanos commented on 2013-07-11 10:32

I get this error

[code]==> Making package: epiphany-git 20130320-1 (Thu Jul 11 13:30:30 EEST 2013)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
==> Extracting sources...
==> Starting build()...
==> Connecting to GIT server....
/tmp/packerbuild-0/epiphany-git/epiphany-git/PKGBUILD: line 33: git: command not found
==> ERROR: A failure occurred in build().
Aborting...
[/code]

yoseforb commented on 2013-03-20 22:08

run:
pacman -S gnome-common # Install gnome-common-3.7.4, with support automake 1.13

peacememories commented on 2013-03-20 21:51

The gnome build system seems to depend on automake <= 1.12 (it can't find automake 1.13)
Also, even with automake 1.9 installed, it gives me the following error: http://pastebin.com/7FfNFf4W