Package Details: epoptes-bzr 0.5.10-1

Git Clone URL: https://aur.archlinux.org/epoptes-bzr.git (read-only, click to copy)
Package Base: epoptes-bzr
Description: An opensource computer lab management and monitoring tool - client side
Upstream URL: https://code.launchpad.net/~epoptes/epoptes/trunk
Licenses: GPL3
Conflicts: epoptes
Provides: epoptes
Submitter: Angel_Caido
Maintainer: None
Last Packager: Angel_Caido
Votes: 0
Popularity: 0.000000
First Submitted: 2014-12-21 14:00 (UTC)
Last Updated: 2016-05-21 17:54 (UTC)

Latest Comments

cytrynek commented on 2018-05-17 15:16 (UTC)

It would be good if you install dependency for epoptes-bzr: python2-pycha-hg, bsdmainutils, xorg-fonts-misc, ssvnc (with: jdk8-openjdk, jre8-openjdk) and then: sudo usermod -a -G epoptes UserName Thanks for this package!!

Draadmachine commented on 2017-12-15 21:27 (UTC) (edited on 2017-12-15 21:42 (UTC) by Draadmachine)

It appears there is something going wrong in the PKGBUILD. It throws the following error:

resolving dependencies... warning: cannot resolve "python2-pycha-hg", a dependency of "epoptes-bzr" warning: cannot resolve "ssvnc", a dependency of "epoptes-bzr" :: The following package cannot be upgraded due to unresolvable dependencies: epoptes-bzr

:: Do you want to skip the above package for this upgrade? [y/N]

These are available in the AUR but apparently they are not recognized. I'll try to look into it.

update: it appears to be a problem with Packer not recognizing the dependencies to be AUR targets. I frankly have no idea how to fix this in the PKGBUILD. Installing the dependencies manually does resolve the error though.

Thanks for providing this package!

Draadmachine commented on 2017-12-15 21:15 (UTC)

@Angel_Caido Any updates? I'd love to deploy Epoptes on a schoolnetwork! :)

Angel_Caido commented on 2016-10-17 11:47 (UTC)

Epoptes has moved from BZR to GIT. I shall be uploading a new PKGBUILD to reflect this change. The package name will change, though. I'll keep you posted.

Angel_Caido commented on 2016-05-21 17:28 (UTC)

Epoptes Package Bumped to 0.5.10.

Angel_Caido commented on 2016-03-03 04:16 (UTC)

PKGBUILD Upgraded to latest version. Tested and working, both Server and Client.

Angel_Caido commented on 2015-10-06 16:53 (UTC) (edited on 2015-10-06 16:54 (UTC) by Angel_Caido)

Epoptes is now split into two packages: "epoptes-client" [which is the Client side] and "epoptes" [this is the server], so you can install them separetly. Thanks again to lbssousa for his support and also for maintaining the package "python2-pycha-hg", a dependency of Epoptes which was lost during the AUR migration.

Angel_Caido commented on 2014-12-22 19:29 (UTC)

Package updated. A few corrections brought to my atention have been made. 1. Epoptes server service file is now 'epoptes-server.service'. 2. Epoptes client's service file is 'epoptes-client.service'. 3. The service files are now located within /usr/lib/systemd/system. 4. The 'epoptes' group, the '/etc/epoptes' folder, and the .service files which are created during the installation will now be removed alongside with the package if you uninstall Epoptes. Please, comment your experience with this package.

Angel_Caido commented on 2014-12-21 16:04 (UTC)

The Epoptes package was originally created and submited by halosghost. I have added some modifications to his/her work to make it run properly, this thanks to the help of Laércio de Sousa [lbssousa, from https://launchpad.net/~lbssousa]. I now own and maintaing the package but credit goes to its original poster. This package installs both applications needed for Epoptes to work: Epoptes Server and Epoptes-client. Please download it, install it, try it, and Enjoy!