Package Details: eprosima-fast-dds-gen 2.3.0-1

Git Clone URL: https://aur.archlinux.org/eprosima-fast-dds-gen.git (read-only, click to copy)
Package Base: eprosima-fast-dds-gen
Description: Fast-DDS IDL code generator tool
Upstream URL: https://github.com/eProsima/Fast-DDS-Gen
Licenses: Apache
Submitter: oysstu
Maintainer: kistlin
Last Packager: kistlin
Votes: 0
Popularity: 0.000000
First Submitted: 2020-10-02 12:55 (UTC)
Last Updated: 2022-12-13 17:33 (UTC)

Dependencies (5)

Required by (0)

Sources (2)

Latest Comments

kistlin commented on 2021-11-27 18:58 (UTC) (edited on 2021-11-28 04:51 (UTC) by kistlin)

While trying to install this package I got error in the build phase.
- gradle of the system was not compatible?
- system Java was on a newer version than the tool was created for

I think suggestions from https://github.com/kermitt2/grobid/issues/817#issuecomment-900565843 are good and they helped me build the package without error.

Here is my diff for version 2.0.0.

diff --git a/PKGBUILD b/PKGBUILD
index 77d7684..d0fc69a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,12 +15,15 @@ sha256sums=('SKIP')
 validpgpkeys=()

 build() {
+    export GRADLE_USER_HOME="${srcdir}/gradle"
+    export JAVA_HOME=/usr/lib/jvm/java-11-openjdk
+    mkdir -p "${srcdir}"/{gradle,m2}
     cd "${srcdir}/Fast-DDS-Gen"
-    gradle assemble
+    ./gradlew --no-daemon assemble
 }

 package() {
     cd "${srcdir}/Fast-DDS-Gen"
     mkdir -p "gradle_home"
-    gradle install -g "${srcdir}/Fast-DDS-Gen/gradle_home" --install_path="${pkgdir}/usr/"
+    ./gradlew --no-daemon install -g "${srcdir}/Fast-DDS-Gen/gradle_home" --install_path="${pkgdir}/usr/"
 }

This would add a dependency to jdk11-openjdk.

oysstu commented on 2020-10-05 07:03 (UTC)

Added, for some reason I thought it was in base-devel