Package Details: epson-inkjet-printer-n10-nx127 1.0.1-10

Git Clone URL: https://aur.archlinux.org/epson-inkjet-printer-n10-nx127.git (read-only, click to copy)
Package Base: epson-inkjet-printer-n10-nx127
Description: Epson printer driver (ME 32, 320, 33, 330 / Stylus N10, N11, NX125, NX127, S22, SX125, T12, T13, T22, T22E, T25, TX120, TX121, TX123, TX125, TX129)
Upstream URL: http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
Licenses: LGPL, custom:Epson Licence Agreement
Submitter: None
Maintainer: Misery
Last Packager: Misery
Votes: 8
Popularity: 0.002650
First Submitted: 2011-01-25 14:37 (UTC)
Last Updated: 2021-02-26 14:57 (UTC)

Latest Comments

1 2 Next › Last »

nhermosilla14 commented on 2018-04-16 04:35 (UTC)

Hi, I just can't get this thing working with an Epson T25 printer. It always says "Filter failed". I tried to recompile with the debugging log activated, nevertheless it doesn't show anything suspicious. Of course I tried to change the permissions too. I could really use some help. Thanks.

Lone_Wolf commented on 2014-01-08 01:43 (UTC)

Latest cups detected an usb-connected epson stylus S22 fine. Like fififox though I had to manually change the permissions using chmod a+rx -R /opt/epson-inkjet-printer-n10-nx127

Fififox commented on 2012-08-14 11:52 (UTC)

My Epson Stylus SX125 worked after: - Putting in /etc/udev/rules.d/10-cups.rules: KERNEL=="lp[0-9]", SYMLINK+="%k", GROUP="lp" (it creates a /dev/lp0 instead of only /dev/usb/lp0, and solves what forced me to use cups-usblp previously: CUPS only detects printers in /dev and not in /dev/usb) - Running: chmod a+rx -R /opt/epson-inkjet-printer-n10-nx127 Maybe you could add the chmod command in the package? Thanks!

xyproto commented on 2012-03-07 00:46 (UTC)

This printer driver is so popular it must be printing ponies.

commented on 2012-01-28 17:34 (UTC)

> I tried changing the permissions of the file to 755 (originally it was 700), but still no luck You have to chmod everything :) sudo chmod -R 755 /opt/epson-inkjet-printer-n10-nx127

Misery commented on 2012-01-20 07:37 (UTC)

You mean you added user "cups" to group "lp"? Well... that is not a driver problem. ;-)

commented on 2012-01-20 02:54 (UTC)

Nevermind, just had to add the printer to the lp group :D

commented on 2012-01-20 01:34 (UTC)

Hi!, I'm trying to install this for my TX125. I've compiled the package successfully but still CUPS won't recognize my printer. Is there anything I need beside this? Thanks!

Misery commented on 2011-12-20 23:44 (UTC)

Thanks for the info.... avasys use a bad permission for this RPM. I will add it to my TODO list. :-)

commented on 2011-12-13 13:55 (UTC)

Ok. I was able to get it to work by chmod'ing a+rx the dirs under /opt/epson-inkjet-printer-n10-nx127. Thanks for this package, btw! :-)