Package Details: epson-inkjet-printer-nx420 1.0.0-8

Git Clone URL: https://aur.archlinux.org/epson-inkjet-printer-nx420.git (read-only)
Package Base: epson-inkjet-printer-nx420
Description: Epson printer driver (ME Office 560W / Stylus NX420, SX420W, TX420W, SX425W)
Upstream URL: http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
Licenses: LGPL, custom:Epson Licence Agreement
Submitter: Misery
Maintainer: Misery
Last Packager: Misery
Votes: 12
Popularity: 0.022223
First Submitted: 2010-10-30 00:39
Last Updated: 2015-07-08 19:08

Latest Comments

Cynary commented on 2016-01-27 22:03

I am having issues with this printer.
I am trying to connect to it over wifi, and the connection is successful, but all jobs fail with filter error, and stay in the queue until I cancel them after that.
From the log, the crash seems to be here:
(/opt/epson-inkjet-printer-nx420/cups/lib/filter/epson_inkjet_printer_filter) crashed on signal 11.
Any suggestions?

Misery commented on 2012-09-04 14:05

Maybe you miss something like this?

https://aur.archlinux.org/packages.php?ID=45755
___
My Epson Stylus SX125 worked after:
- Putting in /etc/udev/rules.d/10-cups.rules: KERNEL=="lp[0-9]", SYMLINK+="%k", GROUP="lp"
(it creates a /dev/lp0 instead of only /dev/usb/lp0, and solves what forced me to use cups-usblp previously: CUPS only detects printers in /dev and not in /dev/usb)
- Running: chmod a+rx -R /opt/epson-inkjet-printer-n10-nx127
___

Misery commented on 2012-09-04 14:02

Well, I don't know. I'm using another printer driver and uploaded this PKGBUILD because it seems to be the same as in all other printer drivers. I don't have this printer and I testet network connection only. If you know how to fix it, I will try to add it to the PKGBUILD.

vf04 commented on 2012-08-16 16:47

It still does not work after i tried the following on a 64-bit Arch:
* Blacklisting the usb_storage module (before that, the printer was recognized as unmountable usb storage)
* Module usblp is loaded on startup and printer is recognized as printer after power on.
* Building and installing this package
* Starting cups
Via web interface, the printer is neither found in installed printers nor in new printers section. Did I miss something/Do I have to change something manually?

Anonymous comment on 2012-01-09 03:40

Works great. Thanks :).

VisualPaul commented on 2011-09-12 15:08

Thanx. It started to work as soon as I restarted cups. it works perfect now. good job. really.

ram commented on 2011-07-07 18:55

Just installed my new Stylus SX420W via WLAN: Works perfect! Thanks for your work.

nicoadamo commented on 2011-03-13 21:35

Man you're a Genius! Just when I was dissapointed that Arch wasn't LSB compliant (and so it wouldn't support many drivers), the solution was built up!

tjbp commented on 2011-03-07 15:50

Nice one, thanks :)

Misery commented on 2011-03-07 15:48

Should be fixed.... avasys added 64 bit libs and I needed to replace my PKGBUILD for this. Now it is possible to have the source package only to get 64 bit! Yeah.... avasys observed my mail. ;-)

All comments