Package Details: epson-inkjet-printer-nx420 1.0.0-9

Git Clone URL: https://aur.archlinux.org/epson-inkjet-printer-nx420.git (read-only)
Package Base: epson-inkjet-printer-nx420
Description: Epson printer driver (ME Office 560W / Stylus NX420, SX420W, TX420W, SX425W)
Upstream URL: http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
Licenses: LGPL, custom:Epson Licence Agreement
Submitter: Misery
Maintainer: Misery
Last Packager: Misery
Votes: 13
Popularity: 0.000000
First Submitted: 2010-10-30 00:39
Last Updated: 2018-05-01 14:53

Latest Comments

« First ‹ Previous 1 2

Misery commented on 2011-03-07 15:48

Should be fixed.... avasys added 64 bit libs and I needed to replace my PKGBUILD for this. Now it is possible to have the source package only to get 64 bit! Yeah.... avasys observed my mail. ;-)

Misery commented on 2011-03-07 15:47

Should be fixed because avasys added 64 bit libs.

thewall commented on 2011-03-03 18:40

I get md5 sum error with epson-inkjet-printer-nx420-1.0.0-1lsb3.2.src.rpm file. Thank you for the good job! Bye

lang2 commented on 2010-11-16 21:24

Very nice!

tjbp commented on 2010-11-06 14:24

Many thanks, that worked perfectly.

Misery commented on 2010-11-06 14:16

You cannot symlink 32bit to 64bit. Please download this:
http://linux.avasys.jp/drivers/lsb/epson-inkjet/stable/RPMS/x86_64/epson-inkjet-printer-nx420-1.0.0-1lsb3.2.x86_64.rpm
Extract the lib64 directory to /opt/epson-inkjet-printer-nx420/ and retry it. AVASYS does not provide 64 bit libs in src package. If this works, I will change the PKGBUILD for 64bit.

tjbp commented on 2010-11-06 13:55

Unfortunately not working properly for me. CUPS reports "/opt/epson-inkjet-printer-nx420/cups/lib/filter/epson_inkjet_printer_filter failed".

I enabled debugging on compile, and this was the output in the tmp file:
[printJob:483] TRACE IN
[load_core_library:164] TRACE IN
[get_ppd_attr:139] PPD Attribute epcgCoreLibrary -> libEpson_Stylus_NX420.so.1.0.0
[load_core_library:181] Failed to dlopen(libEpson_Stylus_NX420.so.1.0.0)->/opt/epson-inkjet-printer-nx420/lib64/libEpson_Stylus_NX420.so.1.0.0: wrong ELF class: ELFCLASS32
[load_core_library:242] TRACE OUT=1
[printJob:526] TRACE OUT=1
[eps_heap_usage_end:42] =============================================================
[eps_heap_usage_end:43] HEAP USAGE : max(0 bytes) leak(0 bytes)
[eps_heap_usage_end:44] =============================================================

I tried symlinking the lib directory to lib64 in case it simply couldn't find the file, but I still get exactly the same debugging report.