Package Details: epson-inkjet-printer-workforce-320-sx218 1.0.0-8

Git Clone URL: https://aur.archlinux.org/epson-inkjet-printer-workforce-320-sx218.git (read-only)
Package Base: epson-inkjet-printer-workforce-320-sx218
Description: Epson printer driver (ME Office 520, 620F / Stylus NX220, SX218, TX220, TX228 / Stylus Office BX305F, BX305FW, TX320F, TX325F / WorkForce 320, 323, 325)
Upstream URL: http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
Licenses: LGPL, custom:Epson Licence Agreement
Submitter: Misery
Maintainer: Misery
Last Packager: Misery
Votes: 12
Popularity: 0.000806
First Submitted: 2011-03-07 15:45
Last Updated: 2015-07-08 19:09

Latest Comments

Scimmia commented on 2013-05-24 13:44

The 'rpmextract' dep is useless, makepkg uses bsdtar/libarchive to extract the rpm, then you're just extracting it again. The rest of the makedepends are part of the base-devel group and specifically should NOT be included in the makedepends.

|| return 1 is useless, the functions in the PKGBUILD are called with set -e , so any errors will already exit.

You don't include the custom license. This is usually legally required. Since the end user is building themselves in this case, it's probably ok, but it should still be included in the final package.

If you use cp, it's best to use cp -a instead of cp -r. This will ensure all permissions and properties stay intact.

Scimmia commented on 2013-05-24 13:41

The 'rpmextract' dep is useless, makepkg uses bsdtar/libarchive to extract the rpm, then you're just extracting it again. The rest of the makedepends are part of the base-devel group and specifically should NOT be included in the makedepends.

|| return 1 is useless, the functions in the PKGBUILD are called with set -e , so any errors will already exit.

You don't include the custom license. This is usually legally required. Since the end user is building themselves in this case, it's probably ok, but it should still be included in the final package.

FredBezies commented on 2013-05-12 16:18

It is a mistake. generic driver was updated, not the full one. Besides this, other tweaking are important.

Sorry for the "spamming" !

Misery commented on 2013-05-12 15:56

What do you mean with "update for epson-inkjet-printer-escpr-1.2.2-1lsb3.2.src.rpm"?!?

FredBezies commented on 2013-05-12 15:52

Could it be possible to update this PKGBUILD for epson-inkjet-printer-escpr-1.2.2-1lsb3.2.src.rpm ?

Some tweaking :

1) remove || return 1
2) remove from makedepends : 'make' 'automake' 'autoconf' => there are in basedevel package.

Thanks !