Package Details: epsxe-plugin-gpu-xgl2 2.9-6

Git Clone URL: https://aur.archlinux.org/epsxe-plugin-gpu-xgl2.git (read-only)
Package Base: epsxe-plugin-gpu-xgl2
Description: Linux port of the OpenGL2 plugin
Upstream URL: http://www.pbernert.com
Licenses: custom
Submitter: None
Maintainer: hav3lock
Last Packager: hav3lock
Votes: 98
Popularity: 0.152048
First Submitted: 2007-05-02 17:09
Last Updated: 2016-02-10 17:44

Latest Comments

justin8 commented on 2016-02-10 10:16

Can you please update this to have the correct dependencies? lib32-glib and lib32-gtk for x86_64 systems.

punkrockguy318 commented on 2015-12-15 03:41

FYI this should depend on lib32-gtk for 64 bit systems. I just created the packages for lib32-glib and lib32-gtk to get this package working

hav3lock commented on 2015-09-10 17:22

@okabekudo, do the core plugins complain about something like `libgpu.so` or `libspu.so` missing? If so, open up epsxe, go to config->video and make sure you have the core plugin select; then click on `Configure'. Nothing should happen. Click `Ok'. Now go to config->sound and do the exact same thing. Epsxe should now work just fine with the core plugins.

okabekudo commented on 2015-09-07 20:53

Yes every plugin = same error. Except the core gpu plugin, but I guess this isn't even configurable?

As for pSX: I know now workaround with pulseaudio. pulseaudio -k doesn't work for me. But started with sudo it works.

hav3lock commented on 2015-09-07 17:47

The only problem with pSX is that it requires you to use alsa, and not pulseaudio.

hav3lock commented on 2015-09-07 17:47

pSX is much better, imo, than PCSXR. Is the error message the same no matter which video plugin you use for epsxe?

okabekudo commented on 2015-09-07 16:15

Oh sorry I read that wrong you meant pSX not PCSXR. Is pSX any better? I am able to play pretty decent on PCSXR but if pSX would be an upgrade then I'll consider it.

okabekudo commented on 2015-09-07 15:35

I seriously don't know if it ever worked for me. It's been a long time since I last played some Ps1 games, and for that I used to boot into Windows 7.
PCSXR works but isn't epsxe a little better? I really want to get the best experience possible on Linux.

Uninstalling epsxe and reinstalling it didn't do the trick. :/

hav3lock commented on 2015-09-07 02:32

Did epsxe ever use to work? Sorry that I haven't been able to help you fix it so far; in the meantime, have you tried using the pSX package? I'm not at all sure why it isn't working for you; it works fine with me. It sounds like something's wrong with your installation of epsxe...possibly.. I dunno, though. Have you tried uninstalling epsxe and re-installing it?

okabekudo commented on 2015-09-05 20:05

Nope doesn't work with the core gpu plugin. Yes mesa and mesa-libgl are installed.

hav3lock commented on 2015-09-05 18:10

Do you have mesa and mesa-libgl installed?

hav3lock commented on 2015-09-05 18:02

And epsxe doesn't work with the core gpu built-in?

okabekudo commented on 2015-09-05 17:33

Yes definitely. :/

hav3lock commented on 2015-09-05 16:40

kk, and you've verified that epsxe's settings have it use the gpu-xgl2 plugin for graphical rendering?

okabekudo commented on 2015-09-05 16:36

This is my output: /opt/epsxe/plugins/libgpuPeteXGL2.so.2.0.9:
/opt/epsxe/plugins/libgpuPeteXGL2.so.2.0.8:

hav3lock commented on 2015-09-05 14:54

And when you run

ldd /opt/epsxe/plugins/libgpuPeteXGL2.so.2.0.{9,8} | grep -vP '.*\(.+\)$'

Only the names of the shard libraries gets printed out?

okabekudo commented on 2015-09-05 12:50

Yes they all show up.

hav3lock commented on 2015-09-05 00:08

And when you run

pacman -Ql | sed -r '/lib(gtk|gdk|glib|gmodule)-1.2.so.0$/!d'

All four shared libraries show up? (namely: libglib-1.2.so.0, libgmodule-1.2.so.0, libgtk-1.2.so.0, and libgdk-1.2.so.0)

okabekudo commented on 2015-09-04 23:35

@hav3lock

Yes the exact same error message. :/

hav3lock commented on 2015-09-04 21:49

@okabekudo; you're still getting the same error message?

okabekudo commented on 2015-09-04 20:52

@have3lock

It's 64bit if you meant that by architecture.

Anyways still doesn't work even after rebooting. :/

okabekudo commented on 2015-09-04 20:44

@hav3lock

It's a 64bit system if you meant this by architecture.

hav3lock commented on 2015-09-04 20:19

@okabekudo, what's your system's architecture?

hav3lock commented on 2015-09-04 20:17

@okabekudo

Yeah, installing gtk from the AUR is the correct version--it's going to take me a minute to be able to get my system setup for debugging this: I had to reinstall not too long ago and so I lost all of my copies of the PSX bios as well as all of my isos. Anyway, try running epsxe again.

okabekudo commented on 2015-09-04 20:08

@hav3lock

How do I install gtk v1.2 ? Isn't it deprecated since long ago? I installed the gtk package from AUR but is this the right one?

hav3lock commented on 2015-09-04 02:25

I dunno, gimme a second; in the meantime, ensure that you have gtk v1.2 installed.

okabekudo commented on 2015-09-04 00:24

error while loading shared libraries: libgtk-1.2.so.0: cannot open shared object file: No such file or directory

How do I fix this ? Searched the whole web,

hav3lock commented on 2014-05-22 05:17

builds just fine for me without any changes. @M4rQu1Nh0S

M4rQu1Nh0S commented on 2014-05-22 00:59

please update our PKGBUILD to resolv problem with glib and gtk:

you need fix the problem with files not found:

libgtk-1.2.so.0
libgmodule-1.2.so.0
libglib-1.2.so.0
libgdk-1.2.so.0

glib and gtk are precated.
gtk2 and glib2 contain updated files but you need fix problem at compilation stage...

hav3lock commented on 2013-07-21 06:44

please update your PKGBUILD to use $srcdir and $pkgdir, thank you. :)

mladoux commented on 2013-01-16 21:23

tested, package builds fine on x86_64 after changing arch to be arch=('any')

Anonymous comment on 2010-10-15 13:16

Package fixed.

Anonymous comment on 2010-07-21 06:56

ty, and might want to fix permissions to match the epsxe package.
warning: directory permissions differ on opt/epsxe/cfg/
filesystem: 775 package: 755
warning: directory permissions differ on opt/epsxe/plugins/
filesystem: 775 package: 755