Package Details: epsxe 2.0.5-23

Git Clone URL: https://aur.archlinux.org/epsxe.git (read-only)
Package Base: epsxe
Description: Enhanced PSX emulator (64-bit)
Upstream URL: http://epsxe.com
Keywords: emulator playstation
Licenses: unknown
Submitter: None
Maintainer: hav3lock
Last Packager: hav3lock
Votes: 218
Popularity: 0.122559
First Submitted: 2007-05-02 16:59
Last Updated: 2017-11-08 06:19

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 12 13 14 ... Next › Last »

hav3lock commented on 2016-05-27 05:42

@ReiDaCocada, it does help! Thanks a bunch!

ReiDaCocada commented on 2016-05-25 05:49

I got it working here without installing libtinfo5, so, I think this dependency is unnecessary.
Just creating a symlink to ncurses and libtinfo is enough:

# ln -s /usr/lib/libncursesw.so.6 /usr/lib/libncurses.so.5
# ln -s /usr/lib/libtinfo.so.6 /usr/lib/libtinfo.so.5

And like rdoursenaud said, launch ePSXe with:

LD_PRELOAD=libcurl.so.3 epsxe

I hope this helps :)

hav3lock commented on 2016-05-24 22:50

I added libtinfo5 to the depends for epsxe and fixed the other depends, but it still is broken, which makes absolutely no sense... :/

hcartiaux commented on 2016-05-23 18:11

* I think all lib32- dependencies are useless for the 64 bits binary
* epsxe depends on libtinfo-5 & ncurses5-compat-libs

I still have these errors:
/opt/epsxe/epsxe: /usr/lib/libncurses.so.5: no version information available (required by /opt/epsxe/epsxe)
/opt/epsxe/epsxe: /usr/lib/libncurses.so.5: no version information available (required by /opt/epsxe/epsxe)
/opt/epsxe/epsxe: /usr/lib/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by /opt/epsxe/epsxe)
/opt/epsxe/epsxe: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/epsxe/epsxe)

hav3lock commented on 2016-05-23 15:50

@everyone, so it seems like epsxe now depends on ncurses.5 instead of libtinfo.5, or something like that, but ncurses-5-compat-libs isn't building...so yeah...

helix commented on 2016-05-23 00:31

The GUI now is GTK3-based, correct the dependencies. Plus they have created a 64-bit version which is now in alpha stage.

hav3lock commented on 2016-05-23 00:21

@rdoursenaud, patch merged, thanks again.

hav3lock commented on 2016-05-23 00:08

@rdoursenaud, kk, thanks, sorry for the delay, I'll patch the PKGBUILD right away.

rdoursenaud commented on 2016-05-20 05:51

Here's a patch you may want to use: https://github.com/rdoursenaud/epsxe-arch

rdoursenaud commented on 2016-05-20 05:31

Package for 2.0.2 won't build/install/run on x86_64.

Archive content path is different (Capitalized ePSXe postfixed with linux, version without dots and _x64).
No subdirectories for plugins, bios…
Docs file seems to not be in the expected format.
Executable name is different (Postfixed with _x64).
No keycodes.lst file.
Should depend on ncurses5-compat-libs, libtinfo-5 and libcurl-compat instead of symlinking incompatible 32 bit libraries.

Then launch with LD_PRELOAD=libcurl.so.3 epsxe (Update epsxe.sh and epsxe.desktop).

I believe all of this also applies to the 32 bit version.

Thanks!