Package Details: espanso 0.7.3-1

Git Clone URL: https://aur.archlinux.org/espanso.git (read-only, click to copy)
Package Base: espanso
Description: Cross-platform Text Expander written in Rust
Upstream URL: https://espanso.org/
Keywords: expand expander rust shortcut text xorg
Licenses: GPL3
Submitter: Scrumplex
Maintainer: Scrumplex
Last Packager: Scrumplex
Votes: 20
Popularity: 0.55
First Submitted: 2019-10-03 16:10
Last Updated: 2020-12-04 08:46

Required by (0)

Sources (1)

Latest Comments

Scrumplex commented on 2020-12-03 11:51

lkrms: After some investigation I don't really see any changes between the dev branch and the latest version, that affects this. In fact the espanso-git package does not even run tests at all, as they failed most of the time anyway. I will open an issue in upstream.

lkrms commented on 2020-12-03 11:12

Just a heads up that as of rust 1.48, this package no longer builds due to multiple tests that fail, all with similar output that includes this (or similar):

attempted to leave type `linked_hash_map::Node<serde_yaml::Value, serde_yaml::Value>` uninitialized, which is invalid

I’m not a rust developer but this appears to correlate with changes referenced in 1.48’s release notes. Given espanso-git builds against rust 1.48, perhaps there’s a dependency on a particular version of a package that could be updated via a patch so this will continue to build?

ludat commented on 2020-02-16 21:05

yeah, sorry, I meant espanso-bin aand yes, it works now :D, thank you

Scrumplex commented on 2020-02-16 20:55

ludat: I suppose you were talking about espanso-bin. I just fixed this issue. Looks like the hash changed? I don't know. Anyways. It should work now.

ludat commented on 2020-02-16 20:48

The sha512sum for espanso-linux-0.5.0.tar.gz fails to run