Package Details: esphome-flasher 1.4.0-1

Git Clone URL: https://aur.archlinux.org/esphome-flasher.git (read-only, click to copy)
Package Base: esphome-flasher
Description: ESP8266/ESP32 firmware flasher GUI for ESPHome
Upstream URL: https://github.com/esphome/esphome-flasher
Licenses: MIT
Conflicts: esphomeflasher
Provides: esphomeflasher
Submitter: ouzu
Maintainer: ghassan
Last Packager: ghassan
Votes: 5
Popularity: 0.000002
First Submitted: 2019-11-22 14:16 (UTC)
Last Updated: 2022-07-28 01:58 (UTC)

Latest Comments

ruahcra commented on 2023-11-11 10:40 (UTC) (edited on 2023-11-11 10:40 (UTC) by ruahcra)

As a workaround try installing https://aur.archlinux.org/packages/esptool3.2 first

alexiri commented on 2023-11-11 10:26 (UTC)

This is apparently still broken.

ruahcra commented on 2023-06-24 00:59 (UTC)

If you check the requirements.txt upstream it specifies esptool=3.2

Browsing the esptool source it seems like detect_chip was moved from the ESPLoader class in newer versions, hence why it doesn't work here.

If someone makes a esptool3.2 package and then changes the dependency here to that, then it should work again.

alexiri commented on 2023-03-11 20:21 (UTC)

This doesn't work for me, I get the error: Unexpected error: type object 'ESPLoader' has no attribute 'detect_chip'

The version from pip works just fine.

jlbribeiro commented on 2022-06-15 02:10 (UTC)

Hey @Ghassan, @ouzu,

Can we bump this package to the latest release? Here's a patch, and thank you!

diff --git a/PKGBUILD b/PKGBUILD
index 34c71d2..3df8bd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
 # Maintainer: ouzu <ouzu att laze dott today>
 pkgname=esphome-flasher
-pkgver=1.3.0
+pkgver=1.4.0
 pkgrel=1
 epoch=
 pkgdesc="Simple GUI tool to flash ESPs over USB"
@@ -10,9 +10,9 @@ license=('MIT')
 depends=("esptool" "python" "python-pillow" "python-requests" "python-wxpython")
 provides=("esphomeflasher")
 conflicts=("esphomeflasher")
-source=("$pkgname-$pkgver.tar.gz::https://github.com/esphome/$pkgname/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/esphome/$pkgname/archive/$pkgver.tar.gz")
 noextract=()
-md5sums=('b61d426c17800a2da581990c2bd08a08')
+md5sums=('4aa6f8d4149a80eba86731b15ea97102')

 build() {
    cd "$pkgname-$pkgver"

f0rdprefect commented on 2021-10-26 19:54 (UTC) (edited on 2021-10-26 20:28 (UTC) by f0rdprefect)

+1 can confirm both the error and the fact that the pip version of the esphomeflasher works without a problem.

murcsl commented on 2021-10-20 09:33 (UTC)

same for me

P31314 commented on 2021-09-28 16:33 (UTC)

I had a problem installing it.. I got an error on flashing a D1 mini: Unexpected error: 'MockEsptoolArgs' object has no attribute 'encrypt_files'

Apparently this does not happen when installing via pip.