Package Details: esplorer 0.2.0_rc6-2

Git Clone URL: https://aur.archlinux.org/esplorer.git (read-only, click to copy)
Package Base: esplorer
Description: Integrated Development Environment (IDE) for ESP8266 developers
Upstream URL: https://esp8266.ru/esplorer
Licenses: GPL2
Submitter: olebowle
Maintainer: olebowle
Last Packager: olebowle
Votes: 23
Popularity: 0.000000
First Submitted: 2015-03-28 22:59 (UTC)
Last Updated: 2020-10-31 18:41 (UTC)

Dependencies (5)

Required by (1)

Sources (1)

Latest Comments

olebowle commented on 2017-08-24 15:45 (UTC)

It should be fixed, please try again.

LukyLX commented on 2017-08-14 04:20 (UTC)

Well, using wget instead of curl by adding the following (and 'wget' to makedepends) to PKGBUILD works for me: DLAGENTS=("https::/usr/bin/wget -r -np -nd -H %u -O %o")

kolorafa commented on 2017-08-13 19:24 (UTC)

I see only 2 reasons - the esp8266 server doesn't responds with the http specs or the http client that pacaur/makepkg uses doesn't. First time: curl: (92) HTTP/2 stream 1 was not closed cleanly: PROTOCOL_ERROR (err 1) Second time: curl: (33) HTTP server doesn't seem to support byte ranges. Cannot resume. The simple solution for now is to download ESPlorer.zip manually using browser and use for example makepkg.

LukyLX commented on 2017-08-05 08:31 (UTC)

makepkg failes at my side with: ==> Retrieving sources... -> Downloading esplorer.zip... % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 99 3401k 99 3399k 0 0 1942k 0 0:00:01 0:00:01 --:--:-- 1942k curl: (92) HTTP/2 stream 1 was not closed cleanly: PROTOCOL_ERROR (err 1) ==> ERROR: Failure while downloading https://esp8266.ru/esplorer-latest/?f=ESPlorer.zip Aborting... ==> Removing installed dependencies... Adding the following (and 'wget' to makedepends) to PKGBUILD works for me: DLAGENTS=("https::/usr/bin/wget -r -np -nd -H %u -O %o")

olebowle commented on 2017-03-12 07:40 (UTC)

I can't reproduce your issue. esplorer.sh is created in prepare() and installed during package(). How do you build the package? Any chance your aur helper doesn't call prepare()?

dack commented on 2017-03-11 21:33 (UTC)

I'm getting this: install: cannot stat 'esplorer.sh': No such file or directory

olebowle commented on 2016-12-17 11:22 (UTC)

Apparently the site switched to https and doesn't hand out the archive using http anymore. The issue should be resolved now.

alex.theoto commented on 2016-12-17 10:54 (UTC) (edited on 2016-12-17 11:11 (UTC) by alex.theoto)

sha256sums error Can't find .png file. PKGBUILD is dead.

olebowle commented on 2016-04-29 20:17 (UTC)

Thx, I adjusted the sha256sum. Still it's kind of strange to see a new checksum for the same release...

etix commented on 2016-04-29 17:05 (UTC)

It seems the checksum changed. The one I got is 1972df51f1397d7c562555c86097d80a4f60f28b46baf0dcf4fca8b44c8ec91a.

olebowle commented on 2015-09-24 20:12 (UTC)

I haven't tried building it from the source code. I agree it would be better. Patches are welcome. :-)

tmladek commented on 2015-09-24 18:59 (UTC)

Wouldn't it be better if the package built esplorer from the sources?