Package Details: esteidpkcs11loader 3.12.0.1063-1

Git Clone URL: https://aur.archlinux.org/esteidpkcs11loader.git (read-only)
Package Base: esteidpkcs11loader
Description: Firefox PKCS#11 module loader
Upstream URL: http://www.id.ee/
Keywords: esteid
Licenses: LGPL
Submitter: kevku
Maintainer: kevku
Last Packager: kevku
Votes: 12
Popularity: 0.150111
First Submitted: 2012-12-12 12:26
Last Updated: 2016-02-02 11:19

Latest Comments

kevku commented on 2013-12-13 16:19

When updating opensc012 to opensc 0.13 you might need to manually remove previous opensc module from firefox to stop it asking from pin2
Firefox > Preferences > Advanced > Certificates > Security Devices > Unload opensc module and restart firefox

kevku commented on 2013-10-22 10:31

When updating opensc012 to opensc 0.13 you need to manually remove previous opensc module from firefox
Firefox > Preferences > Advanced > Certificates > Security Devices > Unload onepin-opensc module and restart firefox

kevku commented on 2013-05-29 13:08

updated.

andy_v commented on 2013-05-29 12:34

Hi, kevku!

After I upgraded firefox to v21.0 I noticed that the pkcs11 module loader could no longer be found in Add-ons Manager -> Extensions. Since firefox-adblock-plus also stopped working immediately after the upgrade and was fixed soon after, I looked into what had actually changed and noticed that files are now located in /usr/lib/firefox/browser/extensions/ instead of /usr/lib/firefox/extensions/ [1].

I created a symlink in the new location and the module loader re-appeared in Add-ons Manager -> Extensions. Could you please look into it? Thank you for the amazing job you've done! (Veelkord, tuhat tänu! :)

[1] https://projects.archlinux.org/svntogit/community.git/commit/trunk?h=packages/firefox-adblock-plus&id=2c4bf9b227d10cf841778e6b97ab3789d80be815

kevku commented on 2013-01-04 10:22

Warning: Packages in the AUR assume the base-devel group is installed, and AUR packages will not list members of this group as dependencies even if the package cannot be built without them. Please ensure this group is installed before complaining about failed builds.

https://wiki.archlinux.org/index.php/AUR#Prerequisites
RTFM

Anonymous comment on 2013-01-04 10:09

Buildi jaoks on vajalik ka `patch`

intgr commented on 2013-01-02 10:42

My bad, opensc 0.13 indeed does not work. (I simply hadn't rebooted for so long, that I still had pcscd running with old libraries loaded).

kevku commented on 2012-12-13 20:22

add opensc to IgnorePkg in pacman.conf to prevent upgrading

kevku commented on 2012-12-13 20:21

well i tried every way, but can’t make the certificate import to firefox work with 0.13. In 0.12.2 both onepin-opensc-pkcs11.so and opensc-pkcs11.so modules work fine.

opensc 0.12.2
http://arm.konnichi.com/2012/12/07/community/os/x86_64/opensc-0.12.2-3-x86_64.pkg.tar.xz
http://arm.konnichi.com/2012/12/07/community/os/i686/opensc-0.12.2-3-i686.pkg.tar.xz

intgr commented on 2012-12-13 19:33

And where can we get opensc 0.12.x?

The community repos have 0.13.0, which works fine with sk-esteid{firefoxplugin,pkcs11loader}-svn 22 here. Why won't it work with this release?

All comments