Package Details: eternallands 1.9.4-1

Git Clone URL: https://aur.archlinux.org/eternallands.git (read-only)
Package Base: eternallands
Description: A free 3D MMORPG game with thousands of on-line players
Upstream URL: http://www.eternal-lands.com/
Licenses: custom
Submitter: None
Maintainer: encelo
Last Packager: encelo
Votes: 50
Popularity: 0.413715
First Submitted: 2005-06-13 14:53
Last Updated: 2015-08-23 16:38

Latest Comments

pjbroad commented on 2015-08-25 21:11

The updated build works really well, thanks for providing it.

encelo commented on 2015-08-23 16:39

Updated to 1.9.4

pjbroad commented on 2015-08-10 01:13

There is a new client release so this PKGBUILD needs to be updated. I have a patch here: http://paste.ubuntu.com/12044960

Note, there is not a simple data file archive available from http://www.eternal-lands.com/ so I have linked to a copy on my own site. I use this archive for the game Ubuntu packages and I used it to build the official Linux static package.

pjbroad commented on 2015-08-10 01:12

There is a new client release so this PKGBUILD needs to be updated. I have a patch here: http://paste.ubuntu.com/12044960/plain/

Note, there is not a simple data file archive available from http://www.eternal-lands.com/ so I have linked to a copy on my own site. I use this archive for the game Ubuntu packages and I used it to build the official Linux static package.

warddr commented on 2013-09-20 14:48

I get this error:
el: io/cal3d_io_wrapper.cpp:224: int CalCoreModel_ELLoadCoreAnimation(CalCoreModel*, const char*, float): Assertion `self' failed.
Aborted (core dumped)

is this only me, or does anyone else also have this problem?

(By the way I first had to install libpng15 from AUR to resolve a libpng15.so.15 does not exist error)
(I'm using 32bit)

encelo commented on 2012-02-17 20:18

Updated to 1.9.3 (using commit d151c3d12c5984b3a2a953153811bf9961573374)
Many thanks to yaakov for his changes.

Anonymous comment on 2012-02-15 22:51

I don't know which particular commit has been used, and it doesn't seem as if they are in a hurry to tag anything (since 1.9.3 is already out and the update is now enforced).

encelo commented on 2012-02-14 22:09

Thank you yaakov, I'm soon going to merge your changes into my PKGBUILD.
Only one matter is now worrying me, there's still no 1.9.3 tag in the git repo.
Should we wait for it or do you know of a particular commit which has been used for 1.9.3 binaries?

Anonymous comment on 2012-02-14 19:17

Flagged today out of date, since the server now enforces version 1.9.3

updated PKGBUILD: http://pastebin.com/fwu18vVX
changes:
- moved to version 1.9.3
- changed git repo from berlios to github (berlios are closing down)
- added to linker flags -lstdc++ -lX11 (ugly hack)

fzerorubigd commented on 2012-01-07 11:15

There is no problem with this package and git, and its not out of date!

Anonymous comment on 2011-10-11 15:44

-> Extracting el_linux_192.zip with bsdtar
==> Removing existing pkg/ directory...
==> Starting build()...
==> Connecting to GIT server....
Cloning into elc...
fatal: unable to connect to git.berlios.de:
git.berlios.de[0: 195.37.77.137]: errno=Connection refused

==> ERROR: A failure occurred in build().
Aborting...
The build failed

encelo commented on 2011-08-11 19:47

I have a Zacate netbook using the latest Catalyst drivers and I don't need that package to support s3tc compression and compile the game.
itsme, could you please add some info about your hardware and drivers?

Someone suggesting the best way to take care of this hardware based conditional dependency?

Anonymous comment on 2011-08-11 14:32

The package has a missing dependency: libtxc_dxtn - https://aur.archlinux.org/packages.php?ID=15571

Without this package, I get an error:
[18:09:07, textures.c: 291] Error: Can't use s3tc compressed texture format, because GL_EXT_texture_compression_s3tc is not supported.

yochai commented on 2011-07-23 18:17

Hey,

After hours of working on it -
After clean install, you need to edit the file el.ini in /usr/share/eternallands and under data_dir make it into data_dir = "/usr/share/eternallands".

encelo commented on 2011-06-23 21:11

- Updated to 1.9.2
- PKGBUILD splitted into build and package functions
- Fetching sources from the GIT repository

(Thanks to Huulivoide for his contribution)

vinilox commented on 2011-06-20 19:54

Huulivoide, I have a nvidia 8600 M GT with the nouveau driver, but under windows, it's work with this graphic card

Huulivoide commented on 2011-06-20 17:20

Here is a up to date PKGBUILKD
http://paste.pocoo.org/show/415517/

I changed cvs to git as git is 3 times smaller :D
Also did some reorganizing of the install clauses

Huulivoide commented on 2011-06-20 14:00

vinilox. What GFX card you have? If ATI do you have open drivers or catalyst?

vinilox commented on 2011-06-19 09:37

I have a very low fps, like 5-9 but under windows with the same hardware, I have 40-50. EL say that it doesn't found the OpenGL textures compression.
Does someone have this problem ? What can I do to solve this ?

encelo commented on 2011-01-07 00:17

Updated to 1.9.1

kalio commented on 2010-10-16 17:23

Replace make.conf in the PKGBUILD with make.defaults and it will compile.

Anonymous comment on 2010-07-20 12:47

it does not compile... it says make.conf cannot be read...

Andrwe commented on 2010-07-08 13:44

I think make.conf was replaced by make.defaults because in elc/make.defaults the platform is set now.

Andrwe commented on 2010-07-08 12:17

I think make.conf was replaced by make.defaults because in elc/make.defaults the platform is set now.

archdria commented on 2010-06-11 15:30

I think I've just solved. Edit /etc/makepkg.conf and comment CFLAGS and CXXFLAGS. Then it will build. After build is complete, uncomment both lines back. Hope it works for you too :)

dWolf commented on 2010-06-11 15:20

The same error again :( I've read somewere how to fix that but can't find it.

archdria commented on 2010-04-05 00:10

I get this error in Arch64:
http://aur.pastebin.com/ys9MFs7T

Thanks in advance :)

encelo commented on 2010-04-04 23:41

Updated to 1.9.0