Package Details: ethereum-genoil-ocl-git .20170701.83cb02125-1

Git Clone URL: https://aur.archlinux.org/ethereum-genoil-ocl-git.git (read-only)
Package Base: ethereum-genoil-ocl-git
Description: Genoil's Ethereum GPU miner, built with OpenCL support
Upstream URL: https://github.com/gemoil/cpp-ethereum
Licenses: GPL
Groups: ethereum
Conflicts: cpp-ethereum, ethereum
Provides: ethminer
Submitter: p4block
Maintainer: None
Last Packager: p4block
Votes: 5
Popularity: 0.127009
First Submitted: 2017-05-27 22:55
Last Updated: 2017-07-01 15:16

Latest Comments

p4block commented on 2017-06-11 13:39

@1llum1n4t3d

By highly likely I meant: Install opencl-amd 16.40 or your PC and/or miner will not work period lol

You can patch ethminer to work on mesa's opencl but it is incredibly slow (8MH/s vs 24MH/s and will crash Xorg)

I don't know why it crashes on opencl-amd > 16.40 but almost everything AMD has now is dependant on the DAL patches anyway, maybe get a kernel with those or just wait. There is no harm in using the outdated opencl-amd package.

1llum1n4t3d commented on 2017-06-10 22:59

Hi I'm using your AUR package ethminer. I have AMD RX470. I have only try for now opencl-mesa v17.1.1 and v17.1.2.

When I run "ethminer -G -M" for benchmark it's being stuck at "Trial 5... 0" and nothing happens. Do you have any solution? Beside installing outdated opencl-amd-16.40? What about opencl-amd-17.10, amdgpu-pro-17.10, amdgpu-pro-opencl-17.10 or amdgpu-pro-installer? So many different packages its a bit confusing. What is the best driver for mining?

[OPENCL]:Found suitable OpenCL device [AMD POLARIS10 (DRM 3.10.0 / 4.11.4-1-hardened, LLVM 4.0.0)] with 4293111808 bytes of GPU memory
Benchmarking on platform: CL
Preparing DAG for block #0
Warming up...
ℹ 00:31:31|openclminer0 set work; seed: #00000000, target: #000000000000
ℹ 00:31:31|openclminer0 Initialising miner...
[OPENCL]:Using platform: Clover
[OPENCL]:Using device: AMD POLARIS10 (DRM 3.10.0 / 4.11.4-1-hardened, LLVM 4.0.0)(OpenCL 1.1 Mesa 17.1.2)
[OPENCL]:input.cl:97:1: error: OpenCL version 1.1 does not support the 'static' storage class specifier
input.cl:114:1: error: OpenCL version 1.1 does not support the 'static' storage class specifier
input.cl:123:1: error: OpenCL version 1.1 does not support the 'static' storage class specifier
input.cl:209:1: error: OpenCL version 1.1 does not support the 'static' storage class specifier
input.cl:240:1: error: OpenCL version 1.1 does not support the 'static' storage class specifier
input.cl:245:1: error: OpenCL version 1.1 does not support the 'static' storage class specifier
input.cl:250:1: error: OpenCL version 1.1 does not support the 'static' storage class specifier
input.cl:380:1: error: OpenCL version 1.1 does not support the 'static' storage class specifier

[OPENCL]:clEnqueueWriteBuffer(-38)
Trial 1... 0
Trial 2... 0
Trial 3... 0
Trial 4... 0
Trial 5... 0



p4block commented on 2017-05-27 22:58

Warning for fellow miners, it's highly likely you will need to use the outdated 16.40 opencl-amd package for the moment. Grab the PKGBUILD in the comments section of that package.

Not doing so may result in an useless miner and/or complete PC freezes.