Package Details: ethminer-git 0.14.0.1.20180216.07f5d714e-1

Git Clone URL: https://aur.archlinux.org/ethminer-git.git (read-only)
Package Base: ethminer-git
Description: Ethereum miner with CUDA and stratum support. chfast's version.
Upstream URL: https://github.com/ethereum-mining/ethminer
Keywords: amd cuda ethereum mining nvidia opencl
Licenses: GPL
Groups: ethereum
Conflicts: cpp-ethereum, ethereum, ethereum-git, ethminer
Provides: ethminer
Submitter: Smasher816
Maintainer: Smasher816
Last Packager: Smasher816
Votes: 7
Popularity: 0.000330
First Submitted: 2017-07-01 03:26
Last Updated: 2018-02-16 08:48

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

mikeccuk2005 commented on 2017-12-13 17:39

I got this python error. Which Python do I need now?? Im really confused

[hunter INTERNAL ] Link script failed: 1, -- Found PythonInterp: /usr/bin/python3 (found suitable version "3.6.3", minimum required is "3") , Link files using Python: /usr/bin/python3 CMake Error at /home/mcham/.hunter/_Base/Download/Hunter/0.19.86/aafb99b/Unpacked/scripts/link-all.cmake:70 (message): Python script failed: /usr/bin/python3 [hunter INTERNAL ] /home/mcham/.hunter/_Base/Download/Hunter/0.19.86/aafb99b/Unpacked/scripts/link-all.py [hunter INTERNAL ] --list [hunter INTERNAL ] /home/mcham/.hunter/_Base/Cellar/f07201ec0ca2c01d9c53acfa4e8fa3273e6aacc0/f07201e/files.list [hunter INTERNAL ] --cellar [hunter INTERNAL ] /home/mcham/.hunter/_Base/Cellar/f07201ec0ca2c01d9c53acfa4e8fa3273e6aacc0/f07201e/raw [hunter INTERNAL ] --dest [hunter INTERNAL ] /home/mcham/.hunter/_Base/aafb99b/c2c6dff/a63b4ed/Install, Illegal instruction, , (may help: https://stackoverflow.com/a/2009505/2288008)

Svenstaro commented on 2017-12-03 04:06

All of the current dependencies aren't needed since you are not using system dependencies as you didn't disable hunter using -DHUNTER_ENABLED_OFF. Either turn that off or remove the dependencies.

Svenstaro commented on 2017-12-02 22:36

This should use gcc6 instead of gcc5 since cuda9.

Akari commented on 2017-11-05 12:10

[hunter ** FATAL ERROR **] Build step failed (dir: /home/akari/.hunter/_Base/aafb99b/77499f4/a63b4ed/Build/jsoncpp
[hunter ** FATAL ERROR **] [Directory:/home/akari/.hunter/_Base/Download/Hunter/0.19.86/aafb99b/Unpacked/cmake/projects/jsoncpp]

------------------------------ WIKI -------------------------------
https://github.com/ruslo/hunter/wiki/error.external.build.failed
-------------------------------------------------------------------

CMake Error at /home/akari/.hunter/_Base/Download/Hunter/0.19.86/aafb99b/Unpacked/cmake/modules/hunter_wiki.cmake:12 (message):
Call Stack (most recent call first):
/home/akari/.hunter/_Base/Download/Hunter/0.19.86/aafb99b/Unpacked/cmake/modules/hunter_fatal_error.cmake:20 (hunter_wiki)
/home/akari/.hunter/_Base/Download/Hunter/0.19.86/aafb99b/Unpacked/cmake/modules/hunter_download.cmake:596 (hunter_fatal_error)
/home/akari/.hunter/_Base/Download/Hunter/0.19.86/aafb99b/Unpacked/cmake/projects/jsoncpp/hunter.cmake:59 (hunter_download)
/home/akari/.hunter/_Base/Download/Hunter/0.19.86/aafb99b/Unpacked/cmake/modules/hunter_add_package.cmake:53 (include)
CMakeLists.txt:122 (hunter_add_package)

Smasher816 commented on 2017-07-17 04:32

I went ahead and merged huiyiqun's change since it appears to also work fine on my end and might help other people with build issues. Thanks.

huiyiqun commented on 2017-07-12 01:27

I noticed that first time I run `makepkg`, `make DESTDIR="$pkgdir" install -C build` in `package` will try to rebuild the project and finally failed, so I replaced it with the content in Makefile in `src/ethminer-git/build` and removing the dependency of `install` target and it works.

There seems a bug in cmake files of `ethminer` project that it cannot be build repeated, or resulted in something like:


Could not find a package configuration file provided by "OpenCL" with any
of the following names:

OpenCLConfig.cmake
opencl-config.cmake

Add the installation prefix of "OpenCL" to CMAKE_PREFIX_PATH or set
"OpenCL_DIR" to a directory containing one of the above files. If "OpenCL"
provides a separate development package or SDK, be sure it has been
installed.

Here is my modified PKGBUILD, you could try it if you are interested:

https://gist.github.com/huiyiqun/b610cff684b9fe4e6a78bd758e6af8a9

ronnylov commented on 2017-07-09 12:43

It worked when running "makepkg -s" a second time. Got the error first run but not second run.

Smasher816 commented on 2017-07-09 04:38

Very strange. I just built the package on two of my machines with no issues, and no changes.

I would be interested to hear what the issue was if either of you get it working, so that way I can update the package accordingly. Do you also have issues with ethminer-ocl-git by p4block?

hubcap0 commented on 2017-07-08 15:51

I got exact the same error as sudokamikaze; jsoncpp was installed.

Smasher816 commented on 2017-07-08 03:47

jsoncpp is a dependency of cmake, so it should have been retrieved when you installed base-devel (a requirement for building anything from the AUR). Anyways, you can try installing it manually and see if that helps.