Package Details: etlegacy-git 2.80.2.776.g356f066bd-1

Git Clone URL: https://aur.archlinux.org/etlegacy-git.git (read-only, click to copy)
Package Base: etlegacy-git
Description: Wolfenstein: Enemy Territory 2.60b compatible client/server (etlegacy engine)
Upstream URL: http://etlegacy.com/
Licenses: GPL3
Conflicts: etlegacy
Provides: etlegacy
Submitter: vorot93
Maintainer: Aciz
Last Packager: Aciz
Votes: 7
Popularity: 0.001006
First Submitted: 2015-08-09 16:19 (UTC)
Last Updated: 2023-11-09 06:09 (UTC)

Latest Comments

1 2 Next › Last »

Aciz commented on 2023-11-09 06:20 (UTC)

@xAsh fixed, sorry was away for a while.

xAsh commented on 2023-09-19 22:12 (UTC) (edited on 2023-09-19 22:21 (UTC) by xAsh)

install: cannot stat 'misc/etlegacy-x86_64.service': No such file or directory
==> ERROR: A failure occurred in package_etlegacy-git().

etlegacy-x86_64.service was renamed to etlegacy.x86_64.service

Aciz commented on 2022-10-23 01:01 (UTC)

Should build fine now.

weltio commented on 2022-02-20 11:30 (UTC)

@The_Loko?

weltio commented on 2022-02-09 14:27 (UTC)

maybe The_Loko could update the PKGBUILD like Spyhawk mentioned on 2021-08-14 18:12 (UTC)

Spyhawk commented on 2021-08-14 18:12 (UTC) (edited on 2021-08-14 18:12 (UTC) by Spyhawk)

Some upstream change that might require some PKGBUILD cleanup:

Adding in cmakeopts():

"-D INSTALL_DEFAULT_SHAREDIR=share"

Removing in package_etlegacy-git() (now done by make install):

# doc
mkdir -p $pkgdir/usr/share/doc/$_gitname
mv $pkgdir/usr/lib/$_gitname/INSTALL.txt $pkgdir/usr/share/doc/$_gitname/
install -m 644 docs/game/anticheat.html $pkgdir/usr/share/doc/$_gitname/

# license
mkdir -p $pkgdir/usr/share/licenses/$_gitname
mv $pkgdir/usr/lib/$_gitname/COPYING.txt $pkgdir/usr/share/licenses/$_gitname/

MartinX3 commented on 2021-04-22 20:10 (UTC)

I can't find it in the app list and need to start it manually in the terminal with "/usr/bin/etl"

PongTea commented on 2020-11-22 16:24 (UTC) (edited on 2020-11-22 16:34 (UTC) by PongTea)

FYI package compiles successfully but there is an issue affecting only 64bit patched clients (above v.2.76).

TL;DR: 64bit patched client need to connect to a patched server.

Details: quoting upstream

[...]in case you will attempt to connect to 2.76 server [with a patched client] and be forced to download the 2.76 paks, you will run into the issue [which is game crash]. There is nothing to do about it, you can instead compile or use 32 bit executable, since the problem only affects 64bit binaries.

And also, quoting upstream

Currently only official and one custom server https://et.trackbase.net/server/45410 supports patched binary.

Awebb commented on 2020-08-31 05:28 (UTC)

Your prepare function messes with $HOME. This shouldn't ever happen.

StormEngineer commented on 2020-07-15 16:27 (UTC) (edited on 2020-07-15 16:27 (UTC) by StormEngineer)

Depends on lua 5.4+ but Arch only has 5.3 ???