Package Details: etlegacy 2.82.0-2

Git Clone URL: https://aur.archlinux.org/etlegacy.git (read-only, click to copy)
Package Base: etlegacy
Description: Wolfenstein: Enemy Territory 2.60b compatible client/server (etlegacy engine)
Upstream URL: http://www.etlegacy.com/
Licenses: custom, GPL3
Conflicts: etlegacy
Provides: etlegacy
Submitter: vorot93
Maintainer: jorgicio
Last Packager: jorgicio
Votes: 21
Popularity: 0.38
First Submitted: 2015-08-17 02:35 (UTC)
Last Updated: 2024-03-08 22:26 (UTC)

Latest Comments

1 2 3 4 Next › Last »

johnnybash commented on 2023-12-08 16:51 (UTC) (edited on 2023-12-08 16:51 (UTC) by johnnybash)

@jorgicio you have to change etlegacy-x86_64.service to etlegacy.x86_64.service in line 81

simona commented on 2023-09-21 22:17 (UTC)

install: cant execute stat of 'misc/etlegacy-x86_64.service': file or directory not exist

simona commented on 2023-09-21 08:47 (UTC)

==> ERROR: download protocol unknown: http
-> error downloading sources: /home/simona/.cache/yay/etlegacy
context: exit status 1

jorgicio commented on 2023-02-09 23:42 (UTC)

'cjson' added as a dependency. Thanks!

wooptoo commented on 2023-02-09 22:29 (UTC)

cjson is also required to build this.

vetu104 commented on 2022-08-31 22:55 (UTC)

At the time of this comment, game needs to be run with environment variable SDL_FRAMEBUFFER_ACCELERATION=false

Otherwise it will crash on launch.

https://github.com/etlegacy/etlegacy/issues/1996

jorgicio commented on 2021-08-18 18:05 (UTC)

Missing dependency added. Please resync and try again. Thanks, @Lucki.

Lucki commented on 2021-08-17 22:42 (UTC)

I get the following error in a clean chroot:

-- Found OpenAL: /usr/lib/libopenal.so (Required is at least version "1.14") 
-- Found Vorbis: /usr/include  
CMake Error at /usr/share/cmake-3.21/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
  Could NOT find Theora (missing: THEORA_LIBRARY THEORA_INCLUDE_DIR)
Call Stack (most recent call first):
  /usr/share/cmake-3.21/Modules/FindPackageHandleStandardArgs.cmake:594 (_FPHSA_FAILURE_MESSAGE)
  cmake/FindTheora.cmake:50 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  cmake/ETLSetupFeatures.cmake:221 (find_package)
  CMakeLists.txt:137 (include)


-- Configuring incomplete, errors occurred!
See also "/build/etlegacy/src/etlegacy-2.77.1/CMakeFiles/CMakeOutput.log".
See also "/build/etlegacy/src/etlegacy-2.77.1/CMakeFiles/CMakeError.log".
==> ERROR: A failure occurred in build().

PongTea commented on 2020-11-22 16:14 (UTC) (edited on 2020-11-22 16:35 (UTC) by PongTea)

etlegacy-git 2.76.810.g164b964c3-1 compiles indeed successfully but there is another issue affecting only 64bit patched clients (above v.2.76).

TL;DR: 64bit patched client need to connect to a patched server.

Details: quoting upstream

[...]in case you will attempt to connect to 2.76 server [with a patched client] and be forced to download the 2.76 paks, you will run into the issue [which is game crash]. There is nothing to do about it, you can instead compile or use 32 bit executable, since the problem only affects 64bit binaries.

And also, quoting upstream

Currently only official and one custom server https://et.trackbase.net/server/45410 supports patched binary.