Package Details: everpad 2.15.8-1

Git Clone URL: https://aur.archlinux.org/everpad.git (read-only)
Package Base: everpad
Description: Evernote client with Unity integration
Upstream URL: https://github.com/nvbn/everpad/
Licenses: GPL
Submitter: ImNtReal
Maintainer: None
Last Packager: chenxiaolong
Votes: 69
Popularity: 0.794686
First Submitted: 2012-12-06 18:08
Last Updated: 2015-06-09 00:14

Latest Comments

axfelix commented on 2016-03-27 00:33

That got to launch again, but I can't get it to sync.

bryanchuckles commented on 2016-03-24 03:28

python2-keyrings-alt is required to start everpad-provider

4.4.5-1-ARCH
GNOME Shell 3.18.4
Everpad version: 2.5
API version: 6
Schema version: 5

axfelix commented on 2016-01-26 19:07

I think this may have broken recently:

[axfelix@nixon ~]$ everpad-provider
Traceback (most recent call last):
File "/usr/bin/everpad-provider", line 9, in <module>
load_entry_point('everpad===2.5dev-r0', 'console_scripts', 'everpad-provider')()
File "/usr/lib/python2.7/site-packages/everpad/provider/daemon.py", line 95, in main
app = ProviderApp(args.verbose, sys.argv)
File "/usr/lib/python2.7/site-packages/everpad/provider/daemon.py", line 34, in __init__
if get_auth_token():
File "/usr/lib/python2.7/site-packages/everpad/provider/tools.py", line 35, in get_auth_token
return get_keyring().get_password('everpad', 'oauth_token')
File "/usr/lib/python2.7/site-packages/keyring/core.py", line 42, in get_password
return _keyring_backend.get_password(service_name, username)
File "/usr/lib/python2.7/site-packages/keyring/backends/fail.py", line 18, in get_password
raise RuntimeError("No recommended backend was available")
RuntimeError: No recommended backend was available

luckyrand commented on 2015-08-27 16:31

qtwebkit should be added to dependency. It works well under gnome-shell with the dependency.

mareke commented on 2015-05-29 07:19

Can't get over from authorise window.

shoko commented on 2015-01-09 00:40

On Manjaro 0.8.11 it misses the python2-shiboken dependency. It doesn't start without.

clerafel commented on 2014-10-08 01:03

no, i work under xfce manjaro

dare023 commented on 2014-10-07 17:57

Does it work under kde now?

clerafel commented on 2014-10-06 15:08

hello, thank you. I did what you recommended. I replaced the "qt4-ubuntu" package for "qt4" package in the PKGBUILD and I could install. I hope there are no problems

clerafel commented on 2014-10-06 14:54

hello, thanks. I did what you recommended, change the qt4-ubuntu package for qt4 and I could install. I hope there are no problems

Aerion commented on 2014-10-03 11:38

qt4-ubuntu is a dependency of sni-qt, and can be installed from the AUR. It takes *forever* to compile though, so I wonder if sni-qt truly needs qt4-ubuntu instead of the standard qt4.

If you have issues installing it, you'll need to raise it in the comments for qt4-ubuntu, not here.

clerafel commented on 2014-10-03 03:43

impossible install qt4-ubuntu

okto commented on 2014-07-17 20:30

Confirm that installing python2-setuptools and python-setuptools makes Everpad work in Unity 7.3.0, my notes seem to sync correctly.

quirocha commented on 2013-11-26 05:01

Misses 2 deps from the deps tree:
python2-setuptools
python-setuptools
which replace python-distribute whose in his turn is dep from python2-oauth2 (lacks update)

It install's and at first run launchs the tray with settings where yougive the authorization, then have to launch again and then the window-interface comes up but no synchronization of any kind !
There isn't also any other options...
Looks like a very incomplete "product" ...

piedro commented on 2013-11-13 19:19

Yes, like dare023 mentions, this doesn't work with KDE at all - only settings are available and nothing else. This is really frustrating - I give this package a shot every 3 month or so but this behaviour is still the same for a looong time ... whatever ... now I have to deinstall all these python packages again ... that is annoying too ...

To save others the effort: DON'T USE THIS WITH KDE! IT IS NOT WORTH THE EFFORT!

thx for reading,
piedroeverpad

dare023 commented on 2013-10-29 15:11

Thank you for answer.
I did like you described, but that is all. I get nothing, no window of some kind, no other options except settings and exit when click on icon. Only if I do everpad --all-notes from console I get window and all I can do is to create notebook, nothing else.
After my previous post I discovered that some dependencies were not installed, but now I just don't know.

gotheric commented on 2013-10-29 12:57

@dare023: I can confirm it is working on KDE.
The first time you run it you should go to "setting and management" page and authorize connection with evernote server.

It has some problems however:
- sometimes it "forget" authorization and you should re-authorize it
- other times it "hangs" while syncing (usually during startup). You should kill all everpad processes ("everpad" and "everpad-provider") and re-run it.
- krunner integration is not working

dare023 commented on 2013-10-27 12:23

Can anybody confirm that this works on KDE?
I installed it, but after connecting to my evernote account, cant get anything else.
When clicking on everpad icon, there are only "setting and management" and "exit" options.
On install there was no errors, nor I get errors when launch it from console.
Any help will do, thank you.

gotheric commented on 2013-10-22 09:53

@wych: this is strange... i have them in /usr/bin ...

wych commented on 2013-10-22 09:50

@gotheric seems everpad,everpad-lens and everpad-provider is not put into /usr/bin,actually I can't find it in the package,there must be something wrong in PKGBUILD file or in the build.

gotheric commented on 2013-10-17 16:31

I also confirm that using python2-sqlalchemy-0.7.9 instead of python2-sqlalchemy works.

Another problem: KDE's krunner integration is not working for me. The "evernote plugin" appears in krunner settings, but notes are not appearing in krunner window when searching them...
Anyone knows how to solve this?

seal20 commented on 2013-10-09 13:59

Confirm the workaround described by aiguofer, everpad is working now. Thanks

aiguofer commented on 2013-08-03 03:25

A workaround for now is install python2-sqlalchemy-0.7.9 as seen in https://github.com/nvbn/everpad/issues/300

I have it working now.

wych commented on 2013-07-30 09:22

I got errors like this:
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/everpad-2.5dev-py2.7.egg/everpad/pad/management.py", line 264, in change_auth
'GET')
File "/usr/lib/python2.7/site-packages/oauth2/__init__.py", line 682, in request
connection_type=connection_type)
File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1570, in request
(response, content) = self._request(conn, authority, uri, request_uri, method, body, headers, redirections, cachekey)
File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1317, in _request
(response, content) = self._conn_request(conn, request_uri, method, body, headers)
File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1252, in _conn_request
conn.connect()
File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1044, in connect
raise SSLHandshakeError(e)
httplib2.SSLHandshakeError: [Errno 1] _ssl.c:504: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

gotheric commented on 2013-07-24 09:37

Lot of issues, cant get to work.

First i got this error:
-----------
Traceback (most recent call last):
File "/usr/bin/everpad", line 9, in <module>
load_entry_point('everpad==2.5dev', 'gui_scripts', 'everpad')()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 343, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2354, in load_entry_point
return ep.load()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2060, in load
entry = __import__(self.module_name, globals(),globals(), ['__name__'])
File "/usr/lib/python2.7/site-packages/everpad/pad/indicator.py", line 3, in <module>
from PySide.QtCore import Slot, QTranslator, QLocale, Signal, QSettings, QT_TRANSLATE_NOOP, QLibraryInfo
ImportError: libshiboken-python2.7.so.1.1: cannot open shared object file: No such file or directory
-------------

Solved by installing python-shiboken and:
-----
cd /usr/lib
ln -s libshiboken-python2.7.so.1.2.0 libshiboken-python2.7.so.1.1
----

After that, i got the same issue as piedro.

aiguofer commented on 2013-07-07 01:08

I'm having the same issue as piedro.

piedro commented on 2013-05-04 10:28

I can't get it to work, there seem to be a lot of python errors:
(it works on kubuntu on my other machine though ...)

Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/everpad/pad/list.py", line 212, in new_notebook
name, status, stack = self._notebook_new_name(self.tr('Create new notebook'), '', oldStack)
File "/usr/lib/python2.7/site-packages/everpad/pad/list.py", line 407, in _notebook_new_name
names = map(lambda nb: Notebook.from_tuple(nb).name, self.app.provider.list_notebooks())
File "/usr/lib/python2.7/site-packages/everpad/tools.py", line 32, in wrapper
return getattr(self.__interface, name)(*args, **kwargs)
File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
return self._proxy_method(*args, **keywords)
File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
**keywords)
File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.sqlalchemy.exc.InvalidRequestError: Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/dbus/service.py", line 707, in _message_cb
retval = candidate_method(self, *args, **keywords)
File "/usr/lib/python2.7/site-packages/everpad/provider/service.py", line 120, in list_notebooks
self.sq(Notebook).filter(Notebook.action != ACTION_DELETE).order_by(Notebook.name))
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/session.py", line 1106, in query
return self._query_cls(entities, self, **kwargs)
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/query.py", line 115, in __init__
self._set_entities(entities)
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/query.py", line 124, in _set_entities
self._set_entity_selectables(self._entities)
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/query.py", line 157, in _set_entity_selectables
ent.setup_entity(*d[entity])
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/query.py", line 2728, in setup_entity
self._with_polymorphic = ext_info.with_polymorphic_mappers
File "/usr/lib/python2.7/site-packages/sqlalchemy/util/langhelpers.py", line 614, in __get__
obj.__dict__[self.__name__] = result = self.fget(obj)
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/mapper.py", line 1426, in _with_polymorphic_mappers
configure_mappers()
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/mapper.py", line 2118, in configure_mappers
raise e
InvalidRequestError: One or more mappers failed to initialize - can't proceed with initialization of other mappers. Original exception was: Can't determine relationship direction for relationship 'Note.conflict_parent' - foreign key columns within the join condition are present in both the parent and the child's mapped tables. Ensure that only those columns referring to a parent column are marked as foreign, either via the foreign() annotation or via the foreign_keys argument.

thx, piedro

ImNtReal commented on 2013-04-29 13:39

@acmzero, it works fine for me in KDE. I think you may need to report that one upstream.

acmzero commented on 2013-04-28 21:33

Not Working in KDE
[XX@xx ~]$ everpad
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/everpad/pad/indicator.py", line 76, in update
20, Note.ORDER_UPDATED_DESC, 1,
File "/usr/lib/python2.7/site-packages/everpad/tools.py", line 32, in wrapper
return getattr(self.__interface, name)(*args, **kwargs)
File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
return self._proxy_method(*args, **keywords)
File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
**keywords)
File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.sqlalchemy.exc.InvalidRequestError: Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/dbus/service.py", line 707, in _message_cb
retval = candidate_method(self, *args, **keywords)
File "/usr/lib/python2.7/site-packages/everpad/provider/service.py", line 101, in find_notes
qs = self.sq(Note).filter(and_(
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/session.py", line 1105, in query
return self._query_cls(entities, self, **kwargs)
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/query.py", line 115, in __init__
self._set_entities(entities)
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/query.py", line 124, in _set_entities
self._set_entity_selectables(self._entities)
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/query.py", line 157, in _set_entity_selectables
ent.setup_entity(*d[entity])
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/query.py", line 2744, in setup_entity
self._with_polymorphic = ext_info.with_polymorphic_mappers
File "/usr/lib/python2.7/site-packages/sqlalchemy/util/langhelpers.py", line 582, in __get__
obj.__dict__[self.__name__] = result = self.fget(obj)
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/mapper.py", line 1425, in _with_polymorphic_mappers
configure_mappers()
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/mapper.py", line 2103, in configure_mappers
raise e
InvalidRequestError: One or more mappers failed to initialize - can't proceed with initialization of other mappers. Original exception was: Can't determine relationship direction for relationship 'Note.conflict_parent' - foreign key columns within the join condition are present in both the parent and the child's mapped tables. Ensure that only those columns referring to a parent column are marked as foreign, either via the foreign() annotation or via the foreign_keys argument.

ImNtReal commented on 2013-04-15 17:25

@bl4ckb1rd see if installing python2-socksipy-branch from AUR makes a difference. If it doesn't, you may need to report that bug upstream. Are you trying to go through a proxy?

Anonymous comment on 2013-04-13 19:39

Hi i have this error:
Traceback (most recent call last):
File "/usr/bin/everpad", line 9, in <module>
load_entry_point('everpad==2.5dev', 'gui_scripts', 'everpad')()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 343, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2309, in load_entry_point
return ep.load()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2015, in load
entry = __import__(self.module_name, globals(),globals(), ['__name__'])
File "/usr/lib/python2.7/site-packages/everpad/pad/indicator.py", line 9, in <module>
from everpad.pad.management import Management
File "/usr/lib/python2.7/site-packages/everpad/pad/management.py", line 21, in <module>
from httplib2.socks import PROXY_TYPE_HTTP
ImportError: No module named socks

wych commented on 2013-03-23 05:03

@ImNtReal It works! You may change depend shiboken to python-shiboken,these two are confilcted

ImNtReal commented on 2013-03-22 15:46

@wych you have shiboken installed, correct? Try installing python-shiboken, and see if it helps.

wych commented on 2013-03-22 14:50

I got this error when running everpad:
"Traceback (most recent call last):
File "/usr/bin/everpad", line 9, in <module>
load_entry_point('everpad==2.5dev', 'gui_scripts', 'everpad')()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 343, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2309, in load_entry_point
return ep.load()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2015, in load
entry = __import__(self.module_name, globals(),globals(), ['__name__'])
File "build/bdist.linux-x86_64/egg/everpad/pad/indicator.py", line 3, in <module>
ImportError: /usr/lib/python2.7/site-packages/PySide/QtCore.so: undefined symbol: _ZN8Shiboken6Object4hashEP7_object
"
what is the problem? How can I make it work?
thx

ImNtReal commented on 2013-03-21 13:27

Sorry it took me a few days to get this updated. Should be good, now.

grindcore commented on 2013-03-21 08:59

Change pkgver to 2.5.6 and sha256sums to
da785dd68fe2f227014c05d1134668b888acbb626923a24cf59b07e995ac1507

wych commented on 2013-03-19 11:46

url not fould

ImNtReal commented on 2013-03-04 21:28

Anyone who has had issues using this, should try the latest update. It's running a bit better for me, now.

Anonymous comment on 2013-03-04 19:22

@py_crash to fix you should edit /usr/lib/python2.7/site-packages/everpad/tools.py and ad a slash before usr in resource_filename

py_crash commented on 2013-03-02 19:59

Package doesn't work for me

$ everpad
Traceback (most recent call last):
File "/usr/bin/everpad", line 9, in <module>
load_entry_point('everpad==2.5dev', 'gui_scripts', 'everpad')()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 343, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2307, in load_entry_point
return ep.load()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2013, in load
entry = __import__(self.module_name, globals(),globals(), ['__name__'])
File "/usr/lib/python2.7/site-packages/everpad/pad/indicator.py", line 8, in <module>
from everpad.pad.editor import Editor
File "/usr/lib/python2.7/site-packages/everpad/pad/editor/__init__.py", line 9, in <module>
from everpad.pad.editor.content import ContentEdit
File "/usr/lib/python2.7/site-packages/everpad/pad/editor/content.py", line 143, in <module>
class ContentEdit(QObject):
File "/usr/lib/python2.7/site-packages/everpad/pad/editor/content.py", line 150, in ContentEdit
_html = open(_editor_path).read()
IOError: [Errno 2] No such file or directory: 'usr/share/everpad/editor.html'

ImNtReal commented on 2013-02-28 13:55

@yoburtu, sure. All you need to do is Flag the package out of date in the future.

Anonymous comment on 2013-02-28 07:55

Everpad 2.5 is out:

http://www.webupd8.org/2013/02/everpad-25-released-with-note-sharing.html

Can you update AUR?.

Best regards.

snock commented on 2013-02-11 15:07

Run everpad from terminal to see errors so. When I try to open or create a note. Always the same.

ock ~ $ everpad
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/everpad/pad/indicator.py", line 154, in create
editor = self.open(note)
File "/usr/lib/python2.7/site-packages/everpad/pad/indicator.py", line 129, in open
editor = Editor(note)
File "/usr/lib/python2.7/site-packages/everpad/pad/editor/__init__.py", line 28, in __init__
self.init_controls()
File "/usr/lib/python2.7/site-packages/everpad/pad/editor/__init__.py", line 53, in init_controls
self.ui.resourceLabel, self.mark_touched,
File "/usr/lib/python2.7/site-packages/everpad/pad/editor/resources.py", line 59, in __init__
self.mime = magic.open(magic.MIME_TYPE)
AttributeError: 'module' object has no attribute 'open'

dare023 commented on 2013-02-11 13:55

Same problem here as mark487.

mokasin commented on 2013-02-10 12:28

To make it work, I needed to manually start 'everpad-provider' first.

snock commented on 2013-02-09 21:38

For a couple of updates, I have the same problem as others

Anonymous comment on 2013-02-06 17:13

I'm having the exact problem as mark487.

ImNtReal commented on 2013-02-05 21:54

Can one of you make a bug report on the github page? I get a different error. It looks like you guys are running into an issue with everpad creating a local datastore, or trying to read from it.

tubal-cain commented on 2013-02-05 21:51

I'm getting the same error as mark487

mark487 commented on 2013-02-05 21:48

I have the same problem as jholbrook. Running Everpad gives me a task bar icon and access to the settings panel. I've successfully authorized. But I have no option to create or list notes. No output from Everpad-provider --verbose.

Exiting Everpad and running 'everpad --create' from the console gives the following error:

~$ everpad --create
Traceback (most recent call last):
File "/usr/bin/everpad", line 9, in <module>
load_entry_point('everpad==2.4dev', 'gui_scripts', 'everpad')()
File "/usr/lib/python2.7/site-packages/everpad/pad/indicator.py", line 296, in main
app.indicator.create()
File "/usr/lib/python2.7/site-packages/everpad/pad/indicator.py", line 152, in create
self.app.provider.create_note(note_struct),
File "/usr/lib/python2.7/site-packages/everpad/tools.py", line 31, in wrapper
return getattr(self.__interface, name)(*args, **kwargs)
File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
return self._proxy_method(*args, **keywords)
File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
**keywords)
File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.sqlalchemy.orm.exc.NoResultFound: Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/dbus/service.py", line 707, in _message_cb
retval = candidate_method(self, *args, **keywords)
File "/usr/lib/python2.7/site-packages/everpad/provider/service.py", line 263, in create_note
dbus_note.give_to_obj(note)
File "/usr/lib/python2.7/site-packages/everpad/basetypes.py", line 53, in give_to_obj
setattr(obj, field[0] + '_dbus', val)
File "/usr/lib/python2.7/site-packages/everpad/provider/models.py", line 89, in notebook_dbus
Notebook.default == True,
File "/usr/lib/python2.7/site-packages/sqlalchemy/orm/query.py", line 2190, in one
raise orm_exc.NoResultFound("No row was found for one()")
NoResultFound: No row was found for one()

ImNtReal commented on 2013-02-04 17:38

@zwl, I thought I had already added python2-regex, but I'm not seeing it in there, so I'll add it now. Thanks.

zwl commented on 2013-02-03 03:51

I also had to install regex. Shouldn't that be added as a dependency?

seal20 commented on 2013-01-24 01:04

Thanks for the package, it is working well on my system. I just had to install python-regex as indicated by jholbrook, before the everpad-provider was crashing complaining "no module regex".
However on exit everpad seg fault but it doesn't seem to pause problem. Also I cannot found howto search for notes in krunner...

Anonymous comment on 2013-01-17 22:25

I had to install python2-unity-singlet from the PKGBUILD here - https://github.com/chenxiaolong/Unity-for-Arch-Extra/blob/master/unity-singlet/PKGBUILD

I still don't understand what else I have to do to actually get into the application. I can load all three programs but the tray icon doesn't give me an option to create anything. I can go into setup and authorize everpad. I can see everpad being authorized in the evernote site.

What am I missing here?

ImNtReal commented on 2013-01-17 21:38

@jholbrook, I suspect that there is actually a problem with the implementation of python2-oauth2, or the way this application is trying to use it, but I can't verify that. If you run everpad-provier --verbose, and then everpad, and authorize it, do you get any output from everpad-provider?

Anonymous comment on 2013-01-17 21:36

I had to install python2-unity-singlet from the PKGBUILD here - https://github.com/chenxiaolong/Unity-for-Arch-Extra/blob/master/unity-singlet/PKGBUILD

I still don't understand what else I have to do to actually get into the application. I can load all three programs but the tray icon doesn't give me an option to create anything. I can go into setup and authorize everpad. I can see everpad being authorized in the evernote site.

What am I missing here?

ImNtReal commented on 2013-01-15 19:17

I believe I need to add python2-unity-singlet as an optdepends because I think it's supposed to work without the -lens. I haven't been able to get mine to authorize correctly, either. I am able to authorize it, but if I close out, and start it back, it will be unauthorized, again. My biggest issue with debugging it at the moment is that I can't start everpad-provider by itself. It throws an error: QWidget: Cannot create a QWidget when no GUI is being used. I'm still trying to figure that one out. everpad-provider seems to run for me when I just start everpad.

Anonymous comment on 2013-01-15 17:44

Installed python2-unity-singlet with the PKGBUILD at https://github.com/chenxiaolong/Unity-for-Arch-Extra/blob/master/unity-singlet/PKGBUILD

Then installed libunity from AUR. I can now start everpad, everpad-lens and everpad-provider with no problem. However, I still can't get into the program itself. I see the everpad icon. When I click on it I get two options "Settings and Management" and "Exit". I can go into the settings and authorize the app which does work (I verified on evernote site).

How do I actually open the GUI?

Anonymous comment on 2013-01-15 06:47

I was confusing myself because I was trying to install everpad from the git repository. I've removed that and installed everpad from AUR. Turns out I was missing python-magic.

Now I can start 'everpad-provider' and 'everpad' with no errors. However, when I run 'everpad-lens' I get the following:

Traceback (most recent call last):
File "/usr/bin/everpad-lens", line 9, in <module>
load_entry_point('everpad==2.3dev', 'console_scripts', 'everpad-lens')()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 343, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2307, in load_entry_point
return ep.load()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2013, in load
entry = __import__(self.module_name, globals(),globals(), ['__name__'])
File "/usr/lib/python2.7/site-packages/everpad-2.3dev-py2.7.egg/everpad/specific/unity/lens.py", line 3, in <module>
from singlet.lens import SingleScopeLens, IconViewCategory, ListViewCategory
ImportError: No module named singlet.lens

Any idea?

Anonymous comment on 2013-01-15 06:23

Okay. I'm a little further along with this. Turns out that we need python-regex which doesn't appear to be available in aur (although there is a package called python2-regex-hg but I'm not sure what that is).

Install

$ yaourt -S python2-pip
# pip2 install regex

Now everpad starts but all I get is an icon in my tray but I can't seem to get the app to open. The tray icon gives me "Settings and Management" and "Exit". I can go in and authorize the app but that's it.



Anonymous comment on 2013-01-15 00:55

Just tried installing and getting the same error as snovik.

I've taken a look at the dependencies mentioned here and I think I have installed what I should:

aur/python-magic 5.10-1 [installed] (23)
community/python2-beautifulsoup3 3.2.1-1 [installed]
extra/python2-dbus 1.1.1-2 [installed]
aur/python2-html2text 3.200.3-3 [installed] (92)
aur/python2-keyring 0.10-1 [installed] (262)
aur/python2-magic 0.4.0-1 [installed] (10)
aur/python2-oauth2 1.5.211-1 [installed] (53)
aur/python2-pyside 1.1.2-2 [installed] (147)
extra/python2-pysqlite 2.6.3-3 [installed]
community/python2-sqlalchemy 0.7.9-1 [installed]
extra/qtwebkit 2.2.2-1 [installed]
aur/shiboken 1.1.2-1 [installed] (97)

Per some comments here I also have this:
aur/python-magic 5.10-1 [installed] (23)

snovik commented on 2013-01-11 17:12

I updated with new dependencies. Still have the same problem

snostorm commented on 2013-01-11 04:50

Ok ia had the same issues as karlinux, I needed after wards to insstal python- magic and python2-keyring, python-magic should be for python3 but it is a pre compiled version for python2 if you look at the pkg it is a bit messy but works. maybe swithch teh dependancy over to that or we need to sort out python2-magic to work.

snostorm commented on 2013-01-11 04:08

snovik, I am working out issues as well do you have python2-keyring installed, that might be part of the problem below. I still have a problem with python2-magic but it should get you over the current hurdle

snovik commented on 2013-01-10 02:34

I have another problem. Is it you or me now? :)

Traceback (most recent call last):
File "/usr/bin/everpad", line 9, in <module>
load_entry_point('everpad==2.3dev', 'gui_scripts', 'everpad')()
File "/usr/lib/python2.7/site-packages/everpad/pad/indicator.py", line 278, in main
app.provider = get_provider(session_bus)
File "/usr/lib/python2.7/site-packages/everpad/tools.py", line 36, in wrapper
return InterfaceWrapper(partial(fnc, *args, **kwrags))
File "/usr/lib/python2.7/site-packages/everpad/tools.py", line 13, in __init__
self.__load()
File "/usr/lib/python2.7/site-packages/everpad/tools.py", line 16, in __load
self.__interface = self.__get()
File "/usr/lib/python2.7/site-packages/everpad/tools.py", line 43, in get_provider
provider = bus.get_object("com.everpad.Provider", '/EverpadProvider')
File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 241, in get_object
follow_name_owner_changes=follow_name_owner_changes)
File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 248, in __init__
self._named_service = conn.activate_name_owner(bus_name)
File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 180, in activate_name_owner
self.start_service_by_name(bus_name)
File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 278, in start_service_by_name
'su', (bus_name, flags)))
File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/bin/everpad-provider exited with status 1

ImNtReal commented on 2013-01-10 01:09

@snovik since pyside changed shiboken to a makedepends instead of depends, I have added it as a dependency of everpad.

ImNtReal commented on 2013-01-10 01:07

@karlinux python2-magic is already a dependency. python-magic (without the 2) should be for Python 3+ which Everpad is not currently compatible.

Anonymous comment on 2013-01-09 23:59

For work I have to install from aur:
pyhon-magic (see https://github.com/nvbn/everpad/issues/160)
python2-keyring

snovik commented on 2013-01-06 21:41

Traceback (most recent call last):
File "/usr/bin/everpad", line 9, in <module>
load_entry_point('everpad==2.3dev', 'gui_scripts', 'everpad')()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 337, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2311, in load_entry_point
return ep.load()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2017, in load
entry = __import__(self.module_name, globals(),globals(), ['__name__'])
File "/usr/lib/python2.7/site-packages/everpad/pad/indicator.py", line 3, in <module>
from PySide.QtCore import Slot, QTranslator, QLocale, Signal, QSettings, QT_TRANSLATE_NOOP
ImportError: libshiboken-python2.7.so.1.1: cannot open shared object file: No such file or directory

Anonymous comment on 2013-01-03 12:19

not work for me .. anyone knows what's the problem?
ERROR:dbus.proxies:Introspect error on :1.62:/EverpadService: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Anonymous comment on 2013-01-02 15:35

@ImNtReal No I hasnt install it

ImNtReal commented on 2012-12-20 14:57

@karlinux do you have python2-distribute installed?

Anonymous comment on 2012-12-20 13:14

File "/usr/bin/everpad", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources

tubal-cain commented on 2012-12-13 22:28

python2-html2text is neccesary for krunner integration to work properly.

tubal-cain commented on 2012-12-13 21:57

add python2-html2text as a dependencie. Without it krunner integration doesn't work.

tubal-cain commented on 2012-12-12 19:09

About krunner integration:
everpad_runner.py is installed in /usr/share/kde4/apps/plasma/runners/everpad/contents/code but other plugins are installed in /usr/share/kde4/services. This breaks krunner integration.

donniezazen commented on 2012-12-12 08:05

Not working for me.

Traceback (most recent call last):
File "/usr/bin/everpad", line 9, in <module>
load_entry_point('everpad==2.3dev', 'gui_scripts', 'everpad')()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 337, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2311, in load_entry_point
return ep.load()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2017, in load
entry = __import__(self.module_name, globals(),globals(), ['__name__'])
File "/usr/lib/python2.7/site-packages/everpad/pad/indicator.py", line 7, in <module>
from everpad.pad.editor import Editor
File "/usr/lib/python2.7/site-packages/everpad/pad/editor.py", line 18, in <module>
from PySide.QtWebKit import QWebPage, QWebSettings
ImportError: No module named QtWebKit

ImNtReal commented on 2012-12-11 20:56

I haven't changed much. Just trying to get all the dependencies in there.

@jpaechnatz, I'll use that URL in the next update.

snock commented on 2012-12-08 14:56

Install python2-m2crypto , Once the key manager kde I wonder if he gave permission worked

jpaechnatz commented on 2012-12-08 07:52

Upstream URL should be: https://github.com/nvbn/everpad ?

snock commented on 2012-12-07 15:49

Install python2-beautifulsoup3

ImNtReal commented on 2012-12-07 15:00

I added beautifulsoup to the deps. Still have some more to work out, but we're getting there.

ImNtReal commented on 2012-12-07 14:44

I added beautifulsoup to the deps. Still have some more to work out, but we're getting there.

snock commented on 2012-12-07 14:24

Install python2-beautifulsoup3

Anonymous comment on 2012-12-07 08:18

I failed to run everpad with the following errors:

> everpad
Traceback (most recent call last):
File "/usr/bin/everpad", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2807, in <module>
working_set.require(__requires__)
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 690, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 588, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: BeautifulSoup

thanks

snock commented on 2012-12-07 02:26

application starts, I enter user & password. But not sync ... and you can not add or see anything. We will continue trying, thanks for the package :)

ImNtReal commented on 2012-12-07 01:47

Sorry about the type-o. I was in a hurry to get this up here. It's looking like it may take some patching to get it working, though.

WonderWoofy commented on 2012-12-07 00:09

You misspelled client in the description.