Package Details: evince2 2.32.0-5

Git Clone URL: https://aur.archlinux.org/evince2.git (read-only, click to copy)
Package Base: evince2
Description: Simply a document viewer. Gtk2 version.
Upstream URL: http://projects.gnome.org/evince/
Licenses: GPL
Provides: evince
Submitter: speps
Maintainer: bidulock
Last Packager: bidulock
Votes: 17
Popularity: 0.000000
First Submitted: 2011-06-30 16:01 (UTC)
Last Updated: 2016-08-09 03:07 (UTC)

Required by (28)

Sources (4)

Latest Comments

settyness commented on 2021-05-18 13:53 (UTC)

The update to djvulibre on the 15th halted system updates with evince2 installed. The same error also occurs when attempting to rebuild evince2:

-> Could not find all required packages:
libdjvu>=3.5.22 (Wanted by: evince2)

ubone commented on 2016-07-12 13:50 (UTC)

Build fails without 'gnome-doc-utils' as eugen-b has already posted. @kpbochenek $ rm -r pkg/ src/ && makepkg -cirs

kpbochenek commented on 2016-03-20 16:26 (UTC)

patching file backend/tiff/tiff2ps.c mv: './evince2-view.pc.in' i './evince2-view.pc.in' to ten sam plik ==> BŁĄD: Wystąpił błąd w build(). Fails to build, it says it is the same file. (I had previously installed evince2-light but I don't think this is related.

eugen-b commented on 2015-07-29 11:54 (UTC)

Add gnome-doc-utils to build dependencies. The lines in build() # rename all to [eE]vince2 to prevent conflicts with evince gtk3 _f=`find . -name "*[eE]vince*"` for _l in $_f; do mv $_l `echo $_l | sed "s|\([eE]\)\(vince2\{0,1\}\)|\1vince2|g"` done sed -i "s|\([eE]\)\(vince2\{0,1\}\)|\1vince2|g" `grep -rl "[eE]vince" .` bring an error that the name evince2 is already there or s.th. like that. I've just commented them and the build worked.

bidulock commented on 2015-06-07 03:25 (UTC)

Look here: https://gist.github.com/bbidulock/5334614d1acc61ae7805 for a PKGBUILD and fixups.patch file that fixes the build errors.

scar commented on 2014-04-18 05:06 (UTC)

Fails to build... tiff2ps.c: In function 'PS_Lvl2page': tiff2ps.c:1131:4: error: format '%u' expects argument of type 'unsigned int', but argument 3 has type 'tsize_t' [-Werror=format=] chunk_size, tiled_image ? "tiles" : "strips"); ^ cc1: some warnings being treated as errors Makefile:566: recipe for target 'tiff2ps.lo' failed make[3]: *** [tiff2ps.lo] Error 1 make[3]: Leaving directory '/tmp/yaourt-tmp-mate/aur-evince2/src/evince-2.32.0/backend/tiff' Makefile:480: recipe for target 'all-recursive' failed make[2]: *** [all-recursive] Error 1 make[2]: Leaving directory '/tmp/yaourt-tmp-mate/aur-evince2/src/evince-2.32.0/backend' Makefile:658: recipe for target 'all-recursive' failed make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory '/tmp/yaourt-tmp-mate/aur-evince2/src/evince-2.32.0' Makefile:543: recipe for target 'all' failed make: *** [all] Error 2

PhotonX commented on 2013-06-29 15:02 (UTC)

Package doesn't build, seems to require automake <1.14: checking for automake >= 1.10... testing automake-1.13... not found. testing automake-1.12... not found. testing automake-1.11... not found. testing automake-1.10... not found. ***Error***: You must have automake >= 1.10 installed to build evince2. Download the appropriate package for from your distribution or get the source tarball at http://ftp.gnu.org/pub/gnu/automake/automake-1.10.tar.gz but $ yaourt automake 1 core/automake 1.14-1 (base-devel) [installed] A GNU tool for automatically creating Makefiles

PhotonX commented on 2011-10-31 18:02 (UTC)

Please include following patch: http://dl.dropbox.com/u/1507406/panmode.patch The patch adds grab&drag mode (useful for tablets). It is by Stephen Sugden from here: http://www.mail-archive.com/evince-list@gnome.org/msg01577.html I just made it work with the current release of Evince 2.32.0.