Package Details: evolution-git 3.43.1.r052.ge7a2a728bd-1

Git Clone URL: https://aur.archlinux.org/evolution-git.git (read-only, click to copy)
Package Base: evolution-git
Description: Manage your email, contacts and schedule - git version
Upstream URL: https://wiki.gnome.org/Apps/Evolution
Licenses: GPL
Conflicts: evolution, evolution-bogofilter, evolution-spamassassin
Provides: evolution, evolution-bogofilter, evolution-spamassassin
Replaces: evolution, evolution-bogofilter, evolution-spamassassin
Submitter: yoseforb
Maintainer: silvio
Last Packager: silvio
Votes: 4
Popularity: 0.000000
First Submitted: 2013-03-21 15:16 (UTC)
Last Updated: 2022-02-09 12:22 (UTC)

Latest Comments

Baerbeisser commented on 2021-05-18 20:33 (UTC) (edited on 2021-05-18 20:37 (UTC) by Baerbeisser)

If you add cmake and ninja as makedepends, the build comes to the point where it fails with:


--   Package dependency requirement 'camel-1.2 >= 3.41.1' could not be satisfied.
Package 'camel-1.2' has version '3.40.1', required version is '>= 3.41.1'
--   Package dependency requirement 'libebook-1.2 >= 3.41.1' could not be satisfied.
Package 'libebook-1.2' has version '3.40.1', required version is '>= 3.41.1'
--   Package dependency requirement 'libecal-2.0 >= 3.41.1' could not be satisfied.
Package 'libecal-2.0' has version '3.40.1', required version is '>= 3.41.1'
--   Package dependency requirement 'libedataserver-1.2 >= 3.41.1' could not be satisfied.
Package 'libedataserver-1.2' has version '3.40.1', required version is '>= 3.41.1'
--   Package dependency requirement 'libedataserverui-1.2 >= 3.41.1' could not be satisfied.
Package 'libedataserverui-1.2' has version '3.40.1', required version is '>= 3.41.1'
--   Package dependency requirement 'libebackend-1.2 >= 3.41.1' could not be satisfied.
Package 'libebackend-1.2' has version '3.40.1', required version is '>= 3.41.1'
CMake Error at /usr/share/cmake-3.20/Modules/FindPkgConfig.cmake:556 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake-3.20/Modules/FindPkgConfig.cmake:778 (_pkg_check_modules_internal)
  CMakeLists.txt:271 (pkg_check_modules)

Following a previus comment, replacing evolution-data-server with evolution-data-server-git (which is missing cmake and ninja too), the evolution-data-server-git fails with:


CMake Error at cmake/modules/FindPhonenumber.cmake:72 (message):
  libphonenumber cannot be used.  Use -DWITH_PHONENUMBER=PATH to specify the
  library prefix, or -DWITH_PHONENUMBER=OFF to disable it.

So replacing '-DWITH_PHONENUMBER=ON' with OFF in evolution-data-server-git, both build fine.

@maintainer: you can remove packages from makedepends, if they are in depends too.

NovaViper commented on 2020-08-20 05:26 (UTC) (edited on 2020-08-20 05:26 (UTC) by NovaViper)

I try to build this on Manjaro but I get this error

Building evolution-git...
==> Making package: evolution-git 3.37.90.r010.gd40f313563-1 (Thu 20 Aug 2020 12:22:23 AM CDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating evolution git repo...
Fetching origin
==> Validating source files with sha256sums...
    evolution ... Skipped
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Creating working copy of evolution git repo...
Cloning into 'evolution'...
done.
==> Starting pkgver()...
==> Removing existing $pkgdir/ directory...
==> Starting build()...
CMake Error: CMake was unable to find a build program corresponding to "Ninja".  CMAKE_MAKE_PROGRAM is not set.  You probably need to select a different build tool.
CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage
-- Configuring incomplete, errors occurred!
See also "/var/tmp/pamac-build-novaviper/evolution-git/src/evolution/build/CMakeFiles/CMakeOutput.log".
==> ERROR: A failure occurred in build().
    Aborting...

silvio commented on 2018-11-10 08:46 (UTC)

@Bakasura: Have you found a problem? I don't get the point what you want ...

Bakasura commented on 2018-11-09 23:15 (UTC) (edited on 2018-11-09 23:15 (UTC) by Bakasura)

Note: This will not compile if you not have the evolution-data-server-git version (make fails for old libraries)

rafaelff commented on 2018-08-31 14:11 (UTC) (edited on 2018-08-31 14:16 (UTC) by rafaelff)

"replaces" should not be used in this PKGBUILD. See: https://wiki.archlinux.org/index.php/PKGBUILD#replaces

Also both 'evolution-bogofilter' and 'evolution-spamassassin' are set as replaces/provides/conflicts, but they are also in 'optdepends'. This does not seem to be valid. Maybe you should remove them from 'optdepends' as this package already provides them?

silvio commented on 2018-07-20 07:24 (UTC)

Have take over this package

djres commented on 2018-06-27 08:23 (UTC)

error: target not found: pkgconfig>=0.14.0

tmoore commented on 2015-06-01 14:36 (UTC)

Package ready to go. The maintainer of evolution-data-server-git updated his PKGBUILD to 3.17.2.r11, so this will compile against it.

tmoore commented on 2015-05-29 16:54 (UTC)

Thanks.. Updated depends

rumpelsepp commented on 2015-05-29 16:28 (UTC)

Missing makedeps: * gnome-common * gtk-doc

tmoore commented on 2015-05-29 14:06 (UTC)

Please test and let me know of any issues. Right now there is an existing issue where the application icon isn't registering in the tray/menu etc. Not sure why. Also, until I can get a hold of evolution-data-server-git, you won't be able to use this yet.

bladesuk1 commented on 2014-11-03 16:57 (UTC)

i get this error: checking for AUTOAR... no configure: error: gnome-autoar or gnome-autoar-gtk not found (or version < 0.1) If you want to disable support for automatic archives handling, please append --disable-autoar to configure. depends also appears to be missing libcryptui, and there's an unrecognised compiler option: configure: WARNING: unrecognized options: --with-krb5

deraffe commented on 2013-10-30 07:36 (UTC)

Worked for me for 3.11.1.27.gbc0d5d4 after some modifications: depends=('gnome-desktop' 'evolution-data-server-git' 'gtkhtml4' 'libcanberra' 'libpst' 'libytnef' 'desktop-file-utils' 'hicolor-icon-theme' 'dconf' 'gnome-shell') makedepends=('intltool' 'itstool' 'docbook-xsl' 'networkmanager' 'gnome-common-git' 'gtk-doc' 'yelp-tools')

kris7t commented on 2013-08-19 16:13 (UTC)

Please add yelp-tools, bogofilter and highlight to makedepends and --disable-spamassassin to the configure command (it may be possible to add spamassassin to makedepends instead, but on my machine, ./configure could not find it event after its installation).