Package Details: exaile 3.4.5-1

Git Clone URL: https://aur.archlinux.org/exaile.git (read-only)
Package Base: exaile
Description: A full-featured Amarok-style media player for GTK+
Upstream URL: http://www.exaile.org
Licenses: GPL2
Submitter: xyproto
Maintainer: Xorg
Last Packager: Xorg
Votes: 132
Popularity: 1.293355
First Submitted: 2011-12-14 17:02
Last Updated: 2016-05-08 09:28

Dependencies (25)

Required by (0)

Sources (1)

Latest Comments

Xorg commented on 2015-01-08 11:03

I've modified package python2-mmkeys, now you can use plugin XKeys (since python2-mmkeys-1.6.2.1-2).
You can add it as optionnal dependency if you wish.
Thanks.

GreenRaccoon23 commented on 2014-10-15 14:56

Lol no way. I was updating this the same time you were tomkwok.

tomkwok commented on 2014-10-15 14:50

Updated to 3.4.0.2

tomkwok commented on 2014-10-15 14:50

Updated to 3.4.0.1

tomkwok commented on 2014-10-15 14:50

Updated to 3.4.0.1

butangmucat commented on 2014-09-19 22:05

The latest version is 3.4.0.1, a patch version, I guess
https://pastebin.anthonos.org/view/8d22394a

abihf commented on 2014-09-02 17:09

exaile 3.4.0 PKGBUILD : http://pastebin.com/QdX41EuG

abihf commented on 2014-09-02 16:58

#! /bin/bash
# Maintainer: Jorge Barroso <jorge.barroso.11 at gmail dot com>
# Contributor: Roman Kyrylych <Roman.Kyrylych@gmail.com>
# Contributor: Benjamin Wild <benwild@gmx.de>
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
# Contributor: Joshua Stiefer <facedelajunk@gmail.com>

pkgname=exaile
pkgver=3.4.0
pkgrel=1
pkgdesc="A full-featured Amarok-style media player for GTK+"
arch=('any')
url="http://www.exaile.org"
license=('GPL')
depends=('python2'
'gstreamer0.10-python'
'gstreamer0.10-good-plugins'
'gstreamer0.10-base-plugins'
'mutagen'
'python2-dbus'
'pygtk>=2.10'
'librsvg')
makedepends=('make' 'help2man')
optdepends=('pycddb: CD metadata retrieval'
'python2-bsddb: music collection support'
'gstreamer0.10-bad-plugins: support for more formats'
'gstreamer0.10-ugly-plugins: support for more formats'
'gstreamer0.10-ffmpeg: support for more formats'
'python2-beautifulsoup3: lyricwiki plugin'
'python2-notify: notifyosd plugin'
'notify-osd: notifyosd plugin'
'webkitgtk2: contextinfo plugin'
'pywebkitgtk: contextinfo plugin'
'python2-pillow: Python Imaging Library (PIL) fork. Python2 version'
'streamripper: streamripper plugin'
'moodbar: moodbar plugin')
source=(https://github.com/exaile-dev/exaile/archive/${pkgver}.${pkgrel}.tar.gz)
install=$pkgname.install
sha512sums=('2a3d94fb2d725fdb4c9a78ddb523444bef04f72824b8481264e2a65d556b199078b97265d0b9eb7df4fa8a1d7f6b30e1fe97875e7e48cdfb086338d88dfa4908')
build() {
cd "${srcdir}/${pkgname}-${pkgver}.${pkgrel}"

make PREFIX=/usr
}

package() {
cd "${srcdir}/${pkgname}-${pkgver}.${pkgrel}"
make PREFIX=/usr DESTDIR="${pkgdir}" install

# fix for clicking files with spaces in names from nautilus
sed -i "s#%u#%f#" "${pkgdir}/usr/share/applications/exaile.desktop"
sed -i "s|Exec=$pkgdir/*|Exec=/|" "${pkgdir}/usr/share/dbus-1/services/org.exaile.Exaile.service"
}

Chazza commented on 2014-06-01 18:08

Ignore the comment I made about gnome-python-extras and libgtkhtml. I've done some testing and they don't seem to be required. I think the wiki may be wrong.

Chazza commented on 2014-06-01 16:18

Could gnome-python-extras and libgtkhtml be listed as optdeps? See here: https://wiki.archlinux.org/index.php/Exaile#Enabling_cover_art.2C_lyrics.2C_and_guitar_tablature

Chazza commented on 2014-04-22 14:23

The package python2-imaging (which is listed as an optdep) no longer exists. It should be changed to python2-pillow which provides both python-imaging and python2-imaging.

Tellendil commented on 2014-03-07 09:42

Oups, sorry, I miscklicked and flagged the pacakage out of date, which is not the case, my appologies

Chazza commented on 2013-12-16 17:39

This package is out of date. As of 26 Oct 2013 Exaile is at version 3.3.2

http://www.exaile.org/

Anonymous comment on 2013-07-19 23:09

The comment from 2012-09-14 is still relevant, despite the package having been updated since then. Without gstreamer0.10-base-plugins you will get:

** Message: pygobject_register_sinkfunc is deprecated (GstObject)

on the terminal, and then

Playback error encountered: playsink0

in the application. (Hopefully this info will help with the Google.)

beitme commented on 2013-05-30 14:31

The xkeys plugin cannot be enabled. Says mmkeys.so is missing. I installed the package "python2-mmkeys." Still doesn't work.

beitme commented on 2013-05-30 14:18

The source file http://sacredchao.net/~piman/software/mmkeys-1.tar.gz is no longer available.

Det commented on 2013-03-16 11:08

Why isn't 'python2-beautifulsoup3' an optional dependency for the "Lyrics Wiki" plugin?

Jristz commented on 2013-03-16 02:03

dbus-python not exist as dependenci <- packer

grawity commented on 2013-01-05 16:51

makepkg warns that "$pkgdir/usr/share/dbus-1/services/org.exaile.Exaile.service" is referencing files in my $pkgdir:

Exec=/home/grawity/pkg/aur/exaile/pkg/exaile/usr/bin/exaile

Needs a sed -i "s|Exec=$pkgdir/*|Exec=/|"

Anonymous comment on 2013-01-04 18:11

Unlisted dependency, help2man.

atommixz commented on 2012-09-14 10:33

This is don't install 'gstreamer0.10-base-plugins' by default. And mp3 don't plaing. And 'gstreamer0.10-base-plugins' not in Optional Dependens

atommixz commented on 2012-09-14 10:31

This is don't install 'gstreamer0.10-base-plugins' by default. And mp3 don't plaing.

lynix commented on 2012-05-06 09:09

Broken for me since some recent upgrade, too:

Traceback (most recent call last):
File "/usr/lib/exaile/exaile.py", line 62, in <module>
main()
File "/usr/lib/exaile/exaile.py", line 57, in main
from xl import main
File "/usr/lib/exaile/xl/main.py", line 40, in <module>
from xl import common, xdg, event
File "/usr/lib/exaile/xl/event.py", line 49, in <module>
from new import instancemethod
ImportError: cannot import name instancemethod

Anonymous comment on 2012-01-19 12:39

Hi,
I installed Exaile from the AUR and i couldn't execute it.

The traceback is this:

Traceback (most recent call last):
File "/usr/local/lib/exaile/exaile.py", line 62, in <module>
main()
File "/usr/local/lib/exaile/exaile.py", line 57, in main
from xl import main
File "/usr/local/lib/exaile/xl/main.py", line 464
""" %__version__
^
SyntaxError: invalid syntax

Any help? please!!!!
Thanks.

Anonymous comment on 2011-12-18 17:23

My favorite music player in Linux.

xyproto commented on 2011-12-14 17:16

Moved from [community] in connection with the Christmas Cleanup https://wiki.archlinux.org/index.php/Christmas_Cleanup.

al3hex commented on 2011-11-03 10:02

Obsolete. Replaced by 'python2-mmkeys': https://aur.archlinux.org/packages.php?ID=53693