Package Details: exfat-linux-dkms 5.8_1-1

Git Clone URL: https://aur.archlinux.org/exfat-linux-dkms.git (read-only, click to copy)
Package Base: exfat-linux-dkms
Description: This exFAT filesystem module for Linux kernel is based on sdFAT drivers by Samsung, which is used with their smartphone lineups.
Upstream URL: https://github.com/arter97/exfat-linux/
Licenses: GPL2
Conflicts: exfat, exfat-git
Submitter: rdnvndr
Maintainer: rdnvndr
Last Packager: rdnvndr
Votes: 3
Popularity: 0.002289
First Submitted: 2019-09-15 10:41
Last Updated: 2020-07-04 05:12

Latest Comments

csolisr commented on 2020-11-12 17:33

Warning, this module is no longer building on kernels 5.7 and above, as it already includes a native exFAT module.

applebloom commented on 2020-08-21 16:44

After an upgrade building this module now fails:

DKMS make.log for exfat-5.8-1 for kernel 5.8.1-arch1-1 (x86_64)
pią, 21 sie 2020, 18:33:27 CEST
make -C /usr/lib/modules/5.8.1-arch1-1/build M=/var/lib/dkms/exfat-5.8/1/build modules
make[1]: Wejście do katalogu '/usr/lib/modules/5.8.1-arch1-1/build'
  CC [M]  /var/lib/dkms/exfat-5.8/1/build/inode.o
/var/lib/dkms/exfat-5.8/1/build/inode.c: In function ‘exfat_readpages’:
/var/lib/dkms/exfat-5.8/1/build/inode.c:367:9: error: implicit declaration of function ‘mpage_readpages’; did you mean ‘mpage_readpage’? [-Werror=implicit-function-declaration]
  367 |  return mpage_readpages(mapping, pages, nr_pages, exfat_get_block);
      |         ^~~~~~~~~~~~~~~
      |         mpage_readpage
cc1: some warnings being treated as errors
make[2]: *** [scripts/Makefile.build:281: /var/lib/dkms/exfat-5.8/1/build/inode.o] Błąd 1
make[1]: *** [Makefile:1756: /var/lib/dkms/exfat-5.8/1/build] Błąd 2
make[1]: Opuszczenie katalogu '/usr/lib/modules/5.8.1-arch1-1/build'
make: *** [Makefile:24: all] Błąd 2

Reported upstream.

YamashitaRen commented on 2019-09-18 08:53

Hello, your PKGBUILD has an issue. It has a "29.b83fe7e0-1" version number but creates a package with "29.b83fe7e-1" as version number.

jpegxguy commented on 2019-09-17 21:24

This should probably have exfat-utils-nofuse as a dependency