Package Details: exo-git 1:0.11.1.r1771.e1357f8-1

Git Clone URL: (read-only)
Package Base: exo-git
Description: Extensions to Xfce originally developed by os-cillation.
Upstream URL:
Keywords: build desktop exo gtk2 gtk3 xfce xfce4
Licenses: GPL2, LGPL2.1
Groups: xfce4-git
Conflicts: exo
Provides: exo=$pkgver
Submitter: None
Maintainer: GordonGR
Last Packager: GordonGR
Votes: 25
Popularity: 0.768895
First Submitted: 2009-09-26 08:36
Last Updated: 2016-09-20 13:50

Required by (16)

Sources (1)

Latest Comments

Jristz commented on 2016-09-07 05:32

you should check those deps, now exo is gtk3 migrated and there are some non trivial changes I think

GordonGR commented on 2016-07-31 17:10

You should add gtk3 to the dependencies, exo is now ported to gtk3. I don't know if more changes are required.

Diego commented on 2013-06-14 22:36

NOW IT WORKS... feedback please

Diego commented on 2013-06-14 22:35


Diego commented on 2013-06-14 22:11

Try now

justin8 commented on 2013-06-14 13:37

I keep getting permission denied errors unless I build as root. I curl'd the file to /tmp, tar zxvf, then makepkg in the resulting folder, and permissions error creating file.

Diego commented on 2013-04-17 11:44


Berseker commented on 2013-04-14 17:48

sorry but i do not have time anymore for mantaing actively any package. feel free to adopt it

Jristz commented on 2013-04-13 11:22

Using a PKGBUILD without a package() function is deprecated.

and reffuce to package, please update t pacman 4.1 complain

darthpenguin commented on 2013-03-27 23:04

I am getting this error when building the pakage. Any thoughts?

Unknown encoding 'CHARSET' at /usr/bin/intltool-merge line 419.
make[4]: *** [aterm.desktop] Error 255
make[4]: Leaving directory `/home/jeffrey/Downloads/exo-git/src/exo/exo-helper/helpers'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/jeffrey/Downloads/exo-git/src/exo/exo-helper'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/jeffrey/Downloads/exo-git/src/exo/exo-helper'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/jeffrey/Downloads/exo-git/src/exo'
make: *** [all] Error 2
==> ERROR: A failure occurred in build().

luolimao commented on 2013-01-26 14:22

Thanks for the notice about the thunar-git patches =]
Also, I noticed when building it that exo-git requires xfce4-dev-tools-git as a makedep. Does it really need the git version? This package (and all the other XFCE4-related git packages I maintain) all compile fine with the one in [extra].

Berseker commented on 2013-01-26 12:25

updated - thanks TheWaffleGuy for the suggestions

TheWaffleGuy commented on 2013-01-26 00:46


I'm not able to compile this package as it is right now. I had to make the following changes: add --disable-debug to the line and add libxfce4ui to depends. I also recommend removing --enable-notifications --enable-python from the line as these options doesn't exist, also removing the "|| return 1" from the end of all lines that have them (ending lines like this isn't necessary anymore).

Berseker commented on 2012-11-06 18:49

updated, but please note that I'm not able to compile the package lately.
I've temporarly switched to thunar-devel and its dependencies

Anonymous comment on 2012-11-06 00:40

please add provides=('exo'), otherwise it conflicts with a lot of stuff in xfce4

Berseker commented on 2012-03-25 08:52

updated, erased hal dependency

Jristz commented on 2012-03-20 03:31

you are sure that exo-git need 'Hal the deprecated daemon' for build?

Berseker commented on 2011-12-18 09:20

updated at today

Berseker commented on 2011-07-29 05:40

this package is orphan since november 2010, please abandon it

Berseker commented on 2010-11-26 19:40

here is a working PKGBUILD

to the mantainer: if you do not have time to update the package from time to time, please orphan the package. everyone has a real life, but if you take charge of mantaining a package, then at least once a month you have to check the updates and eventually update the PKGBUILD.

Stebalien commented on 2010-10-19 20:48

1. You need to add 'export PYTHON="/usr/bin/python2"' to the PKGBUILD.

2. I still don't understand your reasoning. The new exo doesn't use hal at all.
From the NEWS file:
- Drop all HAL related code. Exo-hal is not used by thunar-volman
anymore now it is ported to udev, udisks is a non-hal replacement
for exo-mount.

Anonymous comment on 2010-10-16 07:03

Yes there are some software that need old version of "exo". You will use either older version with these softwares or the new one with e.g. Thunar/GIO.

Stebalien commented on 2010-09-19 15:31

This no longer depends on hal.

Anonymous comment on 2010-07-19 06:55

I have the same problem as misc, none of the plugins builds

misc commented on 2010-07-03 07:49

Unfortunately installing this version makes other thunar-related packages refuse to build:

thunar-media-tags-plugin-git will say:

"checking for exo-0.3 >= not found
*** The required package exo-0.3 was not found on your system.
*** Please install exo-0.3 (atleast version"

FSX commented on 2010-04-28 16:41

I can't seem to build this. I get