Package Details: experiment 0.9.0-3

Git Clone URL: https://aur.archlinux.org/experiment.git (read-only)
Package Base: experiment
Description: A tool for running concurrent multi-configuration experiments
Upstream URL: https://github.com/jonhoo/experiment
Licenses: MIT
Submitter: Jonhoo
Maintainer: Jonhoo
Last Packager: Jonhoo
Votes: 1
Popularity: 0.000000
First Submitted: 2015-02-23 17:43
Last Updated: 2016-05-06 17:04

Latest Comments

Jonhoo commented on 2015-05-08 15:15

FWIW, running `pacgem commander rugged ruby-progressbar colorize` fixes all the problems (except that pacgem doesn't install ruby-progressbar as ruby-ruby-progressbar the way it should).

Jonhoo commented on 2015-05-08 03:06

I incorporated some of your fixes now. Thanks!

I think the highline issue is actually slightly different. The cause of this is that the AUR commander package depends on highline, but commander 4.2 (which the AUR package installs) depends on highline 1.6, whereas the AUR highline is 1.7.. Not sure this is something that can be fixed until commander is updated. I've flagged it out-of-date now. None of the experiment dependencies are strict on minor levels, only majors.

Jonhoo commented on 2015-05-08 03:01

I incorporated some of your fixes now. Thanks!

The highline dependency is not mine, but commander's. 1.7.1 should satisfy ~> 1.6.11 though..?

atweiden commented on 2015-05-07 23:20

When I installed using your PKGBUILD, no runtime dependencies were installed with it, so I made this one declaring the additional deps ruby-colorize, ruby-rugged etc: http://ix.io/imX

When using globally installed ruby gems, there are some conflicts with the gems declared in the gemspec, e.g.

Could not find 'highline' (~> 1.6.11) - did find: [highline-1.7.1] (Gem::LoadError)

Can the versions be updated or loosened?