Package Details: exult-git 6891.176935e-1

Git Clone URL: https://aur.archlinux.org/exult-git.git (read-only, click to copy)
Package Base: exult-git
Description: A recreation of the Ultima 7 engine
Upstream URL: http://exult.sourceforge.net/
Licenses: GPL2
Conflicts: exult, exult-cvs, exult-svn
Provides: exult
Replaces: exult-cvs, exult-svn
Submitter: stativ
Maintainer: stativ
Last Packager: stativ
Votes: 14
Popularity: 0.000000
First Submitted: 2016-10-18 20:28 (UTC)
Last Updated: 2016-10-18 20:28 (UTC)

Latest Comments

randomnobody commented on 2020-08-18 18:43 (UTC)

Exult 1.6+ now uses SDL2

snarfies commented on 2016-09-18 13:23 (UTC)

make[2]: *** [Makefile:507: scale_xbr.lo] Error 1 make[2]: Leaving directory '/home/erik/yaourt/yaourt-tmp-erik/aur-exult-svn/src/exult/imagewin' make[1]: *** [Makefile:855: all-recursive] Error 1 make[1]: Leaving directory '/home/erik/yaourt/yaourt-tmp-erik/aur-exult-svn/src/exult' make: *** [Makefile:661: all] Error 2

stativ commented on 2013-06-24 16:32 (UTC)

Nordlicht: I've filled a bug report with upstream: https://sourceforge.net/p/exult/patches/105/ For now you can try the patch from the bug report.

Nordlicht commented on 2013-06-21 17:41 (UTC)

pngio.cc: In function 'int Import_png8(const char*, int, int&, int&, int&, int&, int&, unsigned char*&, unsigned char*&, int&)': pngio.cc:152:38: error: 'memmove' was not declared in this scope 3 * pal_size - 3 * (i + 1)); ^ pngio.cc: In function 'int Export_png8(const char*, int, int, int, int, int, int, unsigned char*, unsigned char*, int, bool)': pngio.cc:222:39: error: 'memset' was not declared in this scope memset(&trans[0], 255, sizeof(trans)); make[3]: *** [pngio.lo] Error 1 Build aborts with this error.

stativ commented on 2013-04-15 14:48 (UTC)

The reason is that I didn't have time to port it to the new pacman.

gyscos commented on 2013-04-15 12:57 (UTC)

I have a question : why specify the version to checkout with PKGVER (currently 7106), and not automatically use the latest available ? Also, pacman now provides better svn support : https://wiki.archlinux.org/index.php/Arch_CVS_%26_SVN_PKGBUILD_guidelines Should I propose a new PKGBUILD ?

stativ commented on 2010-08-15 08:29 (UTC)

It works fine here with gcc 4.5.1-1.

commented on 2010-08-10 22:00 (UTC)

I try to compile this using gcc 4.5.0 and get this erros: http://aur.pastebin.com/tTrztksW seeking on google I found this thread http://gcc.gnu.org/bugzilla/show_bug.cgi?id=43882 So using http://aur.archlinux.org/packages.php?ID=26807 to get gcc-4.3. Before of ./configure I set and export CC=gcc-4.3 CXX=g++-4.3, after that every thing is the same ./configure, make, make install :-)