Package Details: f3d 1.2.1-3

Git Clone URL: https://aur.archlinux.org/f3d.git (read-only, click to copy)
Package Base: f3d
Description: A fast and minimalist 3D viewer
Upstream URL: https://github.com/f3d-app/f3d
Licenses: BSD
Submitter: Meak
Maintainer: Meak (GloW)
Last Packager: GloW
Votes: 7
Popularity: 0.21
First Submitted: 2019-12-05 10:17 (UTC)
Last Updated: 2022-03-24 20:31 (UTC)

Latest Comments

GloW commented on 2022-03-24 20:32 (UTC)

@tapajos: Done but this is an issue with the VTK package I think

tapajos commented on 2022-03-24 12:43 (UTC)

fmt should be in depends rather than makedepends. Otherwise, it yields:

f3d: error while loading shared libraries: libfmt.so.8: cannot open shared object file: No such file or directory

GloW commented on 2022-03-06 20:44 (UTC)

@vicinzu: This is an assimp issue : https://github.com/conda-forge/assimp-feedstock/issues/14

You work around is perfectly reasonnable, we could add it to F3D directly but this is already fixed by upstream and should come in arch soon I hope.

vicinzu commented on 2022-02-24 14:30 (UTC) (edited on 2022-02-24 14:51 (UTC) by vicinzu)

I have problems with building f3d, perhaps someone has an idea. Here the interesting part of the log:


[ 81%] Building CXX object src/CMakeFiles/libf3d.dir/Config.cxx.o [ 84%] Building CXX object src/CMakeFiles/libf3d.dir/vtkF3DOCCTReader.cxx.o make[2]: *** No rule to make target '/usr/lib/librt.so', needed by 'src/libf3d.so'. Stop. make[2]: *** Waiting for unfinished jobs.... [ 87%] Building CXX object src/CMakeFiles/libf3d.dir/vtkF3DAssimpImporter.cxx.o make[1]: *** [CMakeFiles/Makefile2:158: src/CMakeFiles/libf3d.dir/all] Error 2 make: *** [Makefile:156: all] Error 2 ==> ERROR: A failure occurred in build(). Aborting...


Workaround consist of manually creating a symbolic link to the library with so-number: ln -s /usr/lib/librt.so.1 /usr/lib/librt.so

PS. Sorry i edited it several times, but was not able to display a correct code block. :-(

GloW commented on 2021-12-17 18:34 (UTC)

Updated, thanks for the report.

Jules commented on 2021-12-15 17:35 (UTC)

Hello, I had to manually install fmt with sudo pacman -Syu fmt in order to successfully install this package. Could you please tag it in the dependencies. Many thanks