Package Details: famistudio 4.2.1-2

Git Clone URL: https://aur.archlinux.org/famistudio.git (read-only, click to copy)
Package Base: famistudio
Description: A very simple music editor for the Nintendo Entertainment System or Famicom
Upstream URL: https://famistudio.org/
Licenses: MIT
Conflicts: famistudio-bin
Submitter: mcgrew
Maintainer: mcgrew
Last Packager: mcgrew
Votes: 1
Popularity: 0.000429
First Submitted: 2021-01-07 02:41 (UTC)
Last Updated: 2024-05-26 19:26 (UTC)

Latest Comments

mcgrew commented on 2023-07-14 03:02 (UTC)

BEFORE YOU FLAG AS OUT-OF-DATE:

I am aware that 4.1.0 has been released, but there is some incompatibility with librtmidi on Arch. The dev is looking into it and the package will be updated once that is resolved.

mcgrew commented on 2021-07-23 14:07 (UTC) (edited on 2021-07-23 14:11 (UTC) by mcgrew)

This is a problem with the Arch mono-msbuild package, documented here: https://bugs.archlinux.org/task/71007?project=5

The only solution for now is to revert mono-msbuild and mono-msbuild-sdkresolver to 16.8 or older. I don't know when or if this will be fixed.

The other option is to install famistudio-bin instead.

tiko commented on 2021-07-23 04:59 (UTC)

i got an error when build... how to fix it ?

"/home/tiko/.cache/yay/famistudio/src/FamiStudio-3.0.2/FamiStudio.Linux.sln" (default target) (1:2) -> "/home/tiko/.cache/yay/famistudio/src/FamiStudio-3.0.2/FamiStudio/FamiStudio.Linux.csproj" (default target) (2:6) -> (ResolveAssemblyReferences target) -> /usr/lib/mono/msbuild/Current/bin/Microsoft.Common.CurrentVersion.targets(2218,5): error MSB3248: Parameter "AssemblyFiles" has invalid value "/usr/lib/mono/4.6.1-api/mscorlib.dll". Could not load file or assembly 'System.Reflection.Metadata, Version=5.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. [/home/tiko/.cache/yay/famistudio/src/FamiStudio-3.0.2/FamiStudio/FamiStudio.Linux.csproj]