Package Details: fancytasks 1.1.5-1

Git Clone URL: https://aur.archlinux.org/fancytasks.git (read-only, click to copy)
Package Base: fancytasks
Description: More modern taskbar-style window switcher displaying icons and text, with some improvments and color. Serves as a replacement for the Icon-Only and Task Manager plasmoids KDE ships with.
Upstream URL: https://github.com/alexankitty/FancyTasks
Licenses: GPL
Provides: fancytasks
Submitter: Alexankitty
Maintainer: Alexankitty
Last Packager: Alexankitty
Votes: 6
Popularity: 0.083899
First Submitted: 2022-10-27 10:57 (UTC)
Last Updated: 2023-09-12 08:14 (UTC)

Latest Comments

1 2 Next › Last »

Alexankitty commented on 2023-09-13 14:02 (UTC)

Very weird considering the srcinfo and pkginfo don't have hyphens in them. Though normally when using makepkg I don't use -sc.

matahina commented on 2023-09-13 03:37 (UTC)

I can update package now with 1.1.5-1 named "1.1.5.r3.g188515e-1"

matahina commented on 2023-09-10 13:25 (UTC)

Still got the hyphen error in parsing package. It won't update.

Alexankitty commented on 2023-09-05 16:15 (UTC)

Removed the hyphen.

SadSoulEater commented on 2023-09-02 16:09 (UTC)

makepkg -sc
==> ERROR: pkgver is not allowed to contain colons, forward slashes, hyphens or whitespace.

Alexankitty commented on 2023-09-01 17:54 (UTC)

Should be fixed now.

Alexankitty commented on 2023-09-01 17:46 (UTC)

My bad, I'll get that fixed.

xinayder commented on 2023-09-01 08:02 (UTC) (edited on 2023-09-01 08:06 (UTC) by xinayder)

I tried to install it just now and I get the following error:

==> Starting pkgver()...
==> Updated version: fancytasks 1.1.4.r1.gf05a4cd-1
==> Sources are ready.
==> Making package: fancytasks 1.1.4.r1.gf05a4cd-1 (Fri 01 Sep 2023 10:01:12)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting pkgver()...
==> Entering fakeroot environment...
==> Starting package()...
cp: cannot stat 'FancyTasks/FancyTasks.png': No such file or directory
==> ERROR: A failure occurred in package().
    Aborting...
 -> error making: fancytasks-exit status 4
 -> Failed to install the following packages. Manual intervention is required:
fancytasks - exit status 4

EDIT: seems like the path to the icon is incorrect, it should be FancyTasks/package/FancyTasks.png

Alexankitty commented on 2023-09-01 05:26 (UTC)

So... I may have made a mistake and forgot I stuck everything in a package folder and never updated the package build accordingly... Everything should be fixed now though, sorry!

Alexankitty commented on 2023-09-01 04:38 (UTC)

I wasn't able to replicate the issue on line 556, but I did adjust the states a bit to hopefully make it more stable. In the mean time, try removing and re-adding the plasmoid to reset the settings. I will be bumping the version to 1.1.4