Package Details: fasm 1.71.51-1

Git Clone URL: https://aur.archlinux.org/fasm.git (read-only)
Package Base: fasm
Description: Fast and efficient self-assembling x86 assembler for DOS, Windows and Linux operating systems
Upstream URL: http://www.flatassembler.net/
Keywords: assembler fasm
Licenses: custom
Submitter: shaurz
Maintainer: triforce
Last Packager: triforce
Votes: 53
Popularity: 0.222322
First Submitted: 2005-12-22 10:33
Last Updated: 2016-04-13 18:20

Required by (7)

Sources (1)

Latest Comments

anthraxx commented on 2014-10-22 00:03

please update the package, version 1.71.22 was released and 1.71.23 is already available as testing

stevenhoneyman commented on 2014-08-22 19:48

md5 doesn't verify

test0 commented on 2014-01-30 11:31

fasm-1.71.17.tgz's md5sum is a58513deb66de164b92553970be06f23 now.

Anonymous comment on 2012-09-29 14:44

==> Validating source files with md5sums...
fasm-1.71.03.tgz ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build fasm.

lowfatcomputing commented on 2012-09-15 12:56

saiko-chriskun, you need to install multilib-devel.

You can let it replace gcc, gcc-libs etc with gcc-multilib and gcc-libs-multilib etc.

saiko-chriskun commented on 2012-05-19 16:17

==> Starting build()...
flat assembler version 1.70.01 (16384 kilobytes memory)
4 passes, 4844 bytes.
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.0/libgcc.a when searching for -lgcc
/usr/bin/ld: cannot find -lgcc
collect2: error: ld returned 1 exit status
==> ERROR: A failure occurred in build().
Aborting..

thundercat commented on 2012-04-14 20:26

I updated again md5sum. Thanks

walkindude commented on 2012-04-14 19:16

md5sum of http://flatassembler.net/fasm-1.69.51.tgz is 4e4272d6e22b7a58be93d53751165469

walkindude commented on 2012-04-14 19:16

md5sum of http://flatassembler.net/fasm-1.69.51.tgz is 4e4272d6e22b7a58be93d53751165469

walkindude commented on 2012-04-14 19:16

md5sum of http://flatassembler.net/fasm-1.69.51.tgz

walkindude commented on 2012-04-14 19:15

md5sum of http://flatassembler.net/fasm-1.69.51.tgz

walkindude commented on 2012-04-14 19:15

md5sum of http://flatassembler.net/fasm-1.69.50.tgz is 4e4272d6e22b7a58be93d53751165469

dot commented on 2012-03-26 22:07

looks like md5sum of http://flatassembler.net/fasm-1.69.50.tgz has changed and is now 6ee905e09f35670963b47da5291238b9 rather than 6e0ec9f311085d147692acfe52577bf2 (I was able to install on another machine just a couple of hours ago). Please update.

thundercat commented on 2012-03-17 08:13

I don't know, I have a 32 bit system

grai commented on 2012-03-17 04:26

Thanks. Should the x86-64 version depend on gcc-multilibs now? (I've never used a 64-bit system, so I'm not sure how it works.)

dot commented on 2012-03-17 01:34

can't install on i686 anymore: after successful build it shows an error:

loading packages...
error: failed to prepare transaction (package architecture is not valid)
:: package fasm-1.69.44-3-x86_64 does not have a valid architecture

mrbit commented on 2012-03-16 20:12

ok, thanks

mrbit commented on 2012-03-16 18:37

flat assembler version 1.69.44 (16384 kilobytes memory)
4 passes, 4811 bytes.
/usr/bin/ld: i386 architecture of input file `listing.o' is incompatible with i386:x86-64 output
collect2: ld returned 1 exit status
==> ERRORE:

grai commented on 2012-03-16 17:07

I think it would be nice if the tools were installed too:

local s
for s in listing prepsrc symbols; do
./fasm tools/libc/$s.asm $s.o
gcc -o $s $s.o
install -D $s $pkgdir/usr/bin/fasm-$s
done

darkprof commented on 2011-04-21 06:00

L'erreur de la segmentation

Anonymous comment on 2010-12-03 17:33

md5sum is wrong :)

dkorzhevin commented on 2010-10-14 07:41

Please, update package to version 1.69.25

lowfatcomputing commented on 2010-09-21 22:43

Can you update the pkgver field to 1.69.24

Thanks,
Andreas