Package Details: fatrat 1.2.0_beta2-3

Git Clone URL: https://aur.archlinux.org/fatrat.git (read-only)
Package Base: fatrat
Description: Qt Download/Upload Manager
Upstream URL: http://fatrat.dolezel.info
Licenses: custom: GPL2 + complement
Submitter: pmattern
Maintainer: pmattern
Last Packager: pmattern
Votes: 10
Popularity: 0.018628
First Submitted: 2015-08-14 16:52
Last Updated: 2016-11-26 18:26

Dependencies (2)

Required by (0)

Sources (2)

Latest Comments

pmattern commented on 2015-08-25 21:01

> QT_QCOLLECTIONGENERATOR_EXECUTABLE was introduced in 2.8.0.
Ah, I see. Wasn't aware of that.
> Thanks for patching!
You're welcome. Thanks for the heads-up!

vdemin commented on 2015-08-25 08:01

QT_QCOLLECTIONGENERATOR_EXECUTABLE was introduced in 2.8.0. But you are right, this version bump does not matter on Archlinux. Thanks for patching!

vdemin commented on 2015-08-25 07:59

QT_QCOLLECTIONGENERATOR_EXECUTABLE was introduced in 2.8.0. But you are right, this version bump does not matter on Archlinux.

pmattern commented on 2015-08-24 16:19

Confirmed, both problem and solution by your patch.
(No clue why I didn't stumble upon this before submitting the package in the first place. Most likely qt5-tools happened to be installed with qtchooser pointing to Qt 5 which is providing the same version of Qt Collection Generator as Qt 4.)
Left the CMake version as set by upstream, though: tool doesn't seem to be involved in this problem and 2.8.0 isn't the actual version on Arch anyway. If I'm missing something here, let me know.

vdemin commented on 2015-08-23 23:46

The build is broken:
...
qcollectiongenerator: could not exec '/usr/lib/qt/bin/qcollectiongenerator': No such file or directory
...
CMake Error at cmake_install.cmake:122 (file):
file INSTALL cannot find
"/home/vdemin/abs/fatrat/src/fatrat-1.2.0_beta2/doc/fatrat.qhc".

Since I have installed qt4, qcollectiongenerator is located at /usr/lib/qt4/bin/. Please add this little patch that fix detection of the qcollectiongenerator tool:
http://pastebin.com/ELLGS0eF

vdemin commented on 2015-08-23 23:30

The build is broken:
...
qcollectiongenerator: could not exec '/usr/lib/qt/bin/qcollectiongenerator': No such file or directory
...
CMake Error at cmake_install.cmake:122 (file):
file INSTALL cannot find
"/home/vdemin/abs/fatrat/src/fatrat-1.2.0_beta2/doc/fatrat.qhc".

Since I have installed qt4, qcollectiongenerator located at /usr/lib/qt4/bin/. Please add this little patch that fix detection of the qcollectiongenerator tool:
http://pastebin.com/ELLGS0eF