Package Details: faust 2.5.10-2

Git Clone URL: https://aur.archlinux.org/faust.git (read-only)
Package Base: faust
Description: A functional programming language for realtime audio signal processing.
Upstream URL: http://faust.grame.fr/
Licenses: GPL
Conflicts: faust
Provides: faust
Submitter: aggraef
Maintainer: aggraef
Last Packager: aggraef
Votes: 10
Popularity: 5.342721
First Submitted: 2016-05-01 19:27
Last Updated: 2018-01-19 01:35

Latest Comments

aggraef commented on 2018-01-17 03:54

@dvzrv: This should be ready now (I also updated faust-git and submitted a delete request for faust2-git). I'd suggest that you wait for the 2.5.16 release, though, which is imminent (at which point I can remove the temporary llvm-501-fix.patch). But you can also take over right now if you prefer.

Would you also be willing to take over the faust-git package in the AUR? I have way too many packages to maintain myself right now, so I'd be really glad if you did. :) It shouldn't be too much extra work either, since the two PKGBUILDs are more or less the same.

aggraef commented on 2018-01-10 08:09

@dvzrv: Yes, let's do that. I'll delete this package and rename faust2-git to faust-git, while you go about getting faust (built from the latest release at https://github.com/grame-cncm/faust/releases, 2.5.10 at the time of this writing) into the official repositories. Do you have an ETA for that? I can hopefully work on getting my AUR packages sorted out this weekend.

dvzrv commented on 2018-01-09 17:55

@aggraef: Just a general question: Why not move to faust as package name then and drop/merge faust2*?

We really don't need another jack-like schism. ;-)