Package Details: fblog 2.3.0-2

Git Clone URL: https://aur.archlinux.org/fblog.git (read-only, click to copy)
Package Base: fblog
Description: command-line JSON Log viewer
Upstream URL: https://github.com/brocode/fblog
Keywords: command-line command-line-tool json log viewer
Licenses: custom:WTFPL
Submitter: bomgar
Maintainer: bomgar (mriehl)
Last Packager: bomgar
Votes: 4
Popularity: 0.000000
First Submitted: 2018-01-19 15:10
Last Updated: 2020-11-03 12:34

Required by (0)

Sources (1)

Latest Comments

bomgar commented on 2020-10-30 12:58

Done. Thank you.

orhun commented on 2020-10-30 12:54

You should build the package from source. -bin packages install the pre-compiled binaries. See: https://aur.archlinux.org/packages/fblog-bin/

Your PKGBUILD should be something like:

pkgname=fblog
pkgver=2.3.0
pkgrel=1
pkgdesc="Small command-line JSON log viewer"
arch=('x86_64')
url="https://github.com/brocode/fblog"
license=('custom:WTFPL')
makedepends=('cargo')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha512sums=('SKIP') // add checksums

build() {
  cd "$pkgname-$pkgver"
  cargo build --release --locked --all-features
}

check() {
  cd "$pkgname-$pkgver"
  cargo test --release --locked
}

package() {
  cd "$pkgname-$pkgver"
  install -Dm 755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
  install -Dm 644 README.org -t "$pkgdir/usr/share/doc/$pkgname"
  install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}

bomgar commented on 2020-02-25 07:30

Sorry the v1.4.0 instead of 1.4.0 happened because the release process I use changed. I will fix this.

daniel_chesters commented on 2020-02-25 07:24

Why v1.4.0 instead of 1.4.0 for the newer version ?