Package Details: fbpanel-svn 515-5

Git Clone URL: https://aur.archlinux.org/fbpanel-svn.git (read-only)
Package Base: fbpanel-svn
Description: NetWM compliant desktop panel
Upstream URL: http://fbpanel.sourceforge.net/
Licenses: GPL
Conflicts: fbpanel
Provides: fbpanel
Submitter: Calimero
Maintainer: Calimero
Last Packager: Calimero
Votes: 4
Popularity: 0.000286
First Submitted: 2010-09-27 14:33
Last Updated: 2015-06-08 13:14

Latest Comments

Calimero commented on 2015-07-28 21:24

bidulock: look two comments ahead.

bidulock commented on 2015-07-21 04:35

Why is the PKGBUILD locked to revision 515? Revsion 521 is available, just remove the patch and it builds.

bidulock commented on 2015-01-07 11:39

Correction: you need --mandir=/usr/share/man/man1 to get the manual page in the correct place.

Calimero commented on 2014-08-29 22:07

Yes, I'm checking out r515 on purpose, as you noticed. Any revision between 516 and 521 breaks the localization.
I tried adding the files by hand in install() and it didn't work, so since there is no new feature in 521, I forced the revision to 515.
You can define the desired revision manually in the PKGBUILD, or simply remove ”#revision=515” in the source array. You won't notice the breakage if you have an English locale.
Of course the bugs are reported, but I'm afraid this is going to take years to get fixed. (it's already been 3 years)

bidulock commented on 2014-08-29 04:21

you also need --mandir=/usr/share/man --libexecdir=/usr/lib

bidulock commented on 2014-08-29 04:17

svn is at rev 521 but you are checking out 515.

Calimero commented on 2013-04-26 07:06

Well, it just let out a small warning but still worked. Done anyway.
Also I tried to use the new standard ('svn+https://fbpanel.svn…') for development PKGBUILDs and it didn't work, so for the moment I'm doing it by hand.

bidulock commented on 2013-04-11 13:01

PKGBUILD must be split into build() and package() to build with makepkg 4.1

Anonymous comment on 2012-12-30 10:29

The patch already exists : "Add sysfs support to battery plugin"
http://sourceforge.net/tracker/?func=detail&aid=3420992&group_id=66031&atid=513127

It would be nice if it were automatically applied through the PKGBUILD.

Calimero commented on 2012-05-18 07:18

Come on, I found that in about 7 seconds, starting off from the value of url= in the PKGBUILD!
Please submit a patch on the bugtracker's 'Patches' section: http://sourceforge.net/tracker/?atid=513127&group_id=66031&func=browse

Anonymous comment on 2012-05-18 04:02

hey i'm trying to get my battery to work with fbpanel but the battery plugin looks for /proc/acpi but its changed now to /sys/class/power_supply

i dont know how to submit a change so could someone change this plugin for me?

Thanks!

Arch for life!

Josh

Anonymous comment on 2012-04-26 11:41

modify PKGBUILD as belove:

export LDFLAGS="$LDFLAGS -Wl,--as-needed -lm -lX11"
..
..
./configure --prefix=/usr --libexecdir=/usr/lib
..

Bye

swanson commented on 2012-04-02 20:52

If you do 'make' these are the errors;
/usr/bin/ld: misc.o: undefined reference to symbol 'XGetTextProperty'
/usr/bin/ld: note: 'XGetTextProperty' is defined in DSO /usr/lib/libX11.so.6 so try adding it to the linker command line

swanson commented on 2012-04-02 20:38

Won't compile with:
type2 -I/usr/include/libpng15 -fPIC -DPLUGIN -c -o mem2.o mem2.c
make[2]: Leaving directory `/home/mrmedia/source/fbpanel_aur/src/fbpanel-trunk-build/plugins/battery'
cc mem2.o -o mem2.so -Wl,--hash-style=gnu -Wl,--as-needed -lglib-2.0 -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 -lglib-2.0 -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 -lglib-2.0 -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 -shared
make[2]: Leaving directory `/home/mrmedia/source/fbpanel_aur/src/fbpanel-trunk-build/plugins/mem2'
make[1]: Leaving directory `/home/mrmedia/source/fbpanel_aur/src/fbpanel-trunk-build/plugins'
==> ERROR: A failure occurred in build().


I'm suspect it's with the LDFLAGS.