Package Details: fbthrift-git 2017.01.30.00.r15.g340f6393-1

Git Clone URL: https://aur.archlinux.org/fbthrift-git.git (read-only)
Package Base: fbthrift-git
Description: Facebook branch of Apache Thrift, including a new C++ server.
Upstream URL: https://github.com/facebook/fbthrift
Licenses: Apache
Conflicts: fbthrift, thrift
Provides: fbthrift, thrift
Replaces: fbthrift
Submitter: ppwwyyxx
Maintainer: ppwwyyxx
Last Packager: ppwwyyxx
Votes: 0
Popularity: 0.000000
First Submitted: 2016-05-01 06:48
Last Updated: 2017-02-22 05:43

Dependencies (11)

Required by (8)

Sources (1)

Latest Comments

ppwwyyxx commented on 2017-02-22 05:44

@m3thodic Looks right! Thanks! I've updated the package.

m3thodic commented on 2017-02-21 22:41

@ppwwyyxx Have to modify the PY_PREFIX variable to use the absolute path for /usr, referencing $pkgdir will actually install the python files into the root of where the package was built:

17:39:17 linuxdev ~ $ pacman -Ql fbthrift-git | grep yaourt-tmp | tail -1
fbthrift-git /var/tmp/yaourt-tmp-user/aur-fbthrift-git/pkg/fbthrift-git/usr/lib/python2.7/site-packages/thrift_py-0.9.0-py2.7.egg-info/top_level.txt
17:39:21 linuxdev ~ $ pacman -Ql fbthrift-git | grep yaourt-tmp | wc -l
37

I modified the PKGBUILD file with the following change:
#PY_PREFIX="$pkgdir/usr" PYTHON=/usr/bin/python2 ./configure --prefix=/usr
PY_PREFIX="/usr" PYTHON=/usr/bin/python2 ./configure --prefix=/usr

17:40:41 linuxdev ~/AUR/fbthrift-git $ pacman -Qlp fbthrift-git-2017.01.30.00.r36.g9fd749e3-1-x86_64.pkg.tar.xz | grep site-package | tail -1
fbthrift-git /usr/lib/python2.7/site-packages/thrift_py-0.9.0-py2.7.egg-info/top_level.txt

Thanks!

ppwwyyxx commented on 2017-02-08 05:15

Thanks! Updated the dependencies.

zsrkmyn commented on 2017-02-08 04:35

Tt seems that `mstch` is missing as a depdends.