Package Details: festival-patched-hts 2.4-4

Git Clone URL: https://aur.archlinux.org/festival-patched-hts.git (read-only)
Package Base: festival-patched-hts
Description: A general multi-lingual speech synthesis system. With HTS compatibility and GCC 4.7 patches to support HTS 2.1 voices.
Upstream URL: http://www.cstr.ed.ac.uk/projects/festival/
Licenses: GPL, custom, BSD
Conflicts: festival
Provides: festival
Submitter: Janhouse
Maintainer: netcrusher
Last Packager: netcrusher
Votes: 7
Popularity: 0.214178
First Submitted: 2013-03-26 15:16
Last Updated: 2016-03-10 17:35

Required by (17)

Sources (13)

Latest Comments

delueks commented on 2016-08-28 15:56

Hello,
This doesn't work for me, it segfaults on "(SayText anytext)". Here is a backtrace:
Core was generated by `festival'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0 0x00007f14325bd91f in EST_Item::EST_Item(EST_Relation*, EST_Item*) ()
from /usr/lib/libestbase.so.2.4.1
(gdb) bt
#0 0x00007f14325bd91f in EST_Item::EST_Item(EST_Relation*, EST_Item*) ()
from /usr/lib/libestbase.so.2.4.1
#1 0x00007f14325c325d in EST_Relation::append(EST_Item*) () from /usr/lib/libestbase.so.2.4.1
#2 0x00007f1432cf9f0d in add_token(EST_Utterance*, EST_Token&) () from /usr/lib/libFestival.so.2.4.0
#3 0x00007f1432cf8cd3 in FT_Text_Utt(obj*) () from /usr/lib/libFestival.so.2.4.0
#4 0x00007f14329bd727 in leval(obj*, obj*) () from /usr/lib/libestools.so.2.4.1
#5 0x00007f14329bf69d in ?? () from /usr/lib/libestools.so.2.4.1
#6 0x00007f14329bd8a9 in leval(obj*, obj*) () from /usr/lib/libestools.so.2.4.1
#7 0x00007f14329bf69d in ?? () from /usr/lib/libestools.so.2.4.1
#8 0x00007f14329bd8a9 in leval(obj*, obj*) () from /usr/lib/libestools.so.2.4.1
#9 0x00007f14329bdfe9 in leval_args(obj*, obj*) () from /usr/lib/libestools.so.2.4.1
#10 0x00007f14329bd8e9 in leval(obj*, obj*) () from /usr/lib/libestools.so.2.4.1
#11 0x00007f14329bdcf2 in ?? () from /usr/lib/libestools.so.2.4.1
#12 0x00007f14329bded6 in repl_driver(long, long, repl_hooks*) () from /usr/lib/libestools.so.2.4.1
#13 0x00007f14329c5533 in siod_repl(int) () from /usr/lib/libestools.so.2.4.1
#14 0x0000000000402793 in ?? ()
#15 0x00000000004016d9 in ?? ()
#16 0x00007f1431243291 in __libc_start_main () from /usr/lib/libc.so.6
#17 0x000000000040173a in ?? ()

netcrusher commented on 2016-03-10 17:36

Hi xavier83,

Thanks for the suggestion! I added the Pulseaudio patch with some modifications, but did not test it extensively - so use at your own risk.

xavier83 commented on 2016-03-03 11:49

Hi,
Can you include the following patch too? It includes support for pulseaudio. Thanks

https://bugzilla.redhat.com/show_bug.cgi?id=471047

netcrusher commented on 2016-01-08 19:17

I took over this page during the move to the new AUR.

Xyne commented on 2013-09-19 11:55

This package appears to both conflict and provide "festival-english". Please add these entries to the PKGBUILD.