Package Details: ffmpeg-compat-55 2.3.6-4

Git Clone URL: https://aur.archlinux.org/ffmpeg-compat-55.git (read-only, click to copy)
Package Base: ffmpeg-compat-55
Description: Compatibility package for ffmpeg to provide versions 55 of libavcodec, libavdevice and libavformat, not anymore provided by the ffmpeg package
Upstream URL: http://ffmpeg.org/
Licenses: GPL
Provides: libavcodec.so, libavdevice.so, libavformat.so
Submitter: muflone
Maintainer: muflone
Last Packager: muflone
Votes: 24
Popularity: 0.000202
First Submitted: 2014-10-04 21:33 (UTC)
Last Updated: 2022-06-18 15:04 (UTC)

Required by (73)

Sources (2)

Latest Comments

MarsSeed commented on 2022-03-25 11:05 (UTC) (edited on 2022-03-25 11:05 (UTC) by MarsSeed)

Please kindly add options=('!lto') to PKGBUILD. Linking fails if LTO is enabled.

muflone commented on 2019-08-04 10:27 (UTC) (edited on 2019-08-04 10:27 (UTC) by muflone)

@tuxertech

the keyserver is working fine here. please check your internet connection.

$ gpg -v --search-keys B4322F04D67658D8
gpg: data source: <http://192.146.137.98:11371>
(1) FFmpeg release signing key <ffmpeg-devel@ffmpeg.org>
      2048 bit RSA key B4322F04D67658D8, created: 2011-04-26
Keys 1-1 of 1 for "B4322F04D67658D8".  Enter number(s), N)ext, or Q)uit > q

tuxertech commented on 2019-03-31 01:42 (UTC) (edited on 2019-03-31 01:44 (UTC) by tuxertech)

==> Retrieving sources...

-> Found ffmpeg-2.3.6.tar.bz2

-> Found ffmpeg-2.3.6.tar.bz2.asc

-> Found libvpx_VP8E_UPD_ENTROPY.patch

==> Validating source files with sha256sums...

ffmpeg-2.3.6.tar.bz2 ... Passed

ffmpeg-2.3.6.tar.bz2.asc ... Skipped

libvpx_VP8E_UPD_ENTROPY.patch ... Passed

==> Verifying source file signatures with gpg...

ffmpeg-2.3.6.tar.bz2 ... FAILED (unknown public key B4322F04D67658D8)

==> ERROR: One or more PGP signatures could not be verified!

==> ERROR: Makepkg was unable to build ffmpeg-compat-55.

and then...

gpg -v --search-keys B4322F04D67658D8

gpg: error searching keyserver: Server indicated a failure

gpg: keyserver search failed: Server indicated a failure

muflone commented on 2019-03-02 14:25 (UTC)

Package updated by dropping the libx264 dependency, sorry but I was unable to fix the x264 issues.

Any help is appreciated.

ector commented on 2019-02-25 22:12 (UTC)

same errors =ef622

0e4ef622 commented on 2018-09-13 23:47 (UTC)

I'm getting the same error as @remus

remus commented on 2018-09-04 09:25 (UTC) (edited on 2018-09-04 09:27 (UTC) by remus)

Build fails currently for me, with the following error:

CC  libavcodec/libx264.o
libavcodec/libx264.c: In function ‘X264_frame’:
libavcodec/libx264.c:170:9: error: ‘x264_bit_depth’ undeclared (first use in this function); did you mean ‘x264_picture_t’?
[…]
make: *** [common.mak:49: libavcodec/libx264.o] Error 1
==> ERROR: A failure occurred in build().
Aborting...

muflone commented on 2016-11-05 15:06 (UTC)

You had a bad trustdb, now the signature works fine.

ector commented on 2016-11-05 13:22 (UTC)

carry the report of the verification key keith /tmp/yaourt-tmp-keith/aur-libavutil-52 $ gpg --verify ffmpeg-2.3.6.tar.bz2.asc gpg: assuming signed data in 'ffmpeg-2.3.6.tar.bz2' gpg: Signature made mar 06 gen 2015 20:01:19 CET gpg: using RSA key B4322F04D67658D8 gpg: Good signature from "FFmpeg release signing key <ffmpeg-devel@ffmpeg.org>" [sconosciuto] gpg: ATTENZIONE: questa chiave non è certificata con una firma fidata! gpg: Non ci sono indicazioni che la firma appartenga al proprietario. Impronta digitale della chiave primaria: FCF9 86EA 15E6 E293 A564 4F10 B432 2F04 D676 58D8 good day

ector commented on 2016-11-05 13:19 (UTC)

many thank @muflone i have this error on the trutsdb : keith /tmp/yaourt-tmp-keith/aur-libavutil-52 $ gpg --verify ffmpeg-2.3.6.tar.bz2.asc gpg: assuming signed data in 'ffmpeg-2.3.6.tar.bz2' gpg: Signature made mar 06 gen 2015 20:01:19 CET gpg: using RSA key B4322F04D67658D8 gpg: lookup_hashtable failed: Errore di sistema sconosciuto gpg: trustdb: searching trust record failed: Errore di sistema sconosciuto gpg: Error: The trustdb is corrupted. gpg: You may try to re-create the trustdb using the commands: gpg: cd ~/.gnupg gpg: gpg --export-ownertrust > otrust.tmp gpg: rm trustdb.gpg gpg: gpg --import-ownertrust < otrust.tmp gpg: If that does not work, please consult the manual was enough to give the commands in the terminal and yaourt has libavutil-52 installed and ffmpeg-compat-55 carry over the installation of ffmpeg-compat-55 Pacchetti (1) ffmpeg-compat-55-2.3.6-1 Dimensione totale dei pacchetti da installare: 11,25 MiB :: Vuoi procedere con l'installazione? [S/n] s (1/1) verifica delle chiavi presenti nel portachiavi [##################################] 100% (1/1) verifica dell'integrità dei pacchetti [##################################] 100% (1/1) caricamento dei file dei pacchetti [##################################] 100% (1/1) controllo dei conflitti in corso [##################################] 100% (1/1) controllo dello spazio disponibile sul disco [##################################] 100% :: Elaborazione delle modifiche al pacchetto... (1/1) installazione in corso di ffmpeg-compat-55 [##################################] 100% keith ~ $ thank for the support best regards

muflone commented on 2016-11-04 23:11 (UTC)

check your downloaded file by with gpg --verify ffmpeg-1.2.12.tar.bz2.asc if it reports errors about broken trustdb follow the indications.

ector commented on 2016-11-02 17:32 (UTC)

nothing to do,even without sudo not modifcation the key, same thing for: libavutil-52 here is the error: ==> Validazione di source file con sha256sums... ffmpeg-2.3.6.tar.bz2 ... Verificato ffmpeg-2.3.6.tar.bz2.asc ... Ignorato ==> Validazione delle firme dei sorgenti con gpg in corso... ffmpeg-2.3.6.tar.bz2 ... NON RIUSCITO ==> ERRORE: Una o più firme PGP non possono essere verificate! ==> ERRORE: Makepkg non è riuscito a compilare libavutil-52. ==> Riavviare la compilazione di libavutil-52 [s/N] Here, the key modifcation: keith ~ $ gpg --keyserver pgp.mit.edu --recv-keys FCF986EA15E6E293A5644F10B4322F04D67658D8 gpg: key B4322F04D67658D8: "FFmpeg release signing key <ffmpeg-devel@ffmpeg.org>" not changed gpg: Numero totale esaminato: 1 gpg: non modificate: 1 best regards ector

muflone commented on 2016-10-31 21:48 (UTC)

@ector remove sudo from the previous command. The user that builds the package is yours, not root.

ector commented on 2016-10-31 08:59 (UTC)

thanks x the mouflon answer, but does not change the keys, I am installing ffmpeg-compat on kde-antergos, maybe it is not compatible with antegos ?? I get this response when I give the command keys: keith ~ $ sudo gpg --keyserver pgp.mit.edu --recv-keys FCF986EA15E6E293A5644F10B4322F04D67658D8 [sudo] password di keith: gpg: key B4322F04D67658D8: "FFmpeg release signing key <ffmpeg-devel@ffmpeg.org>" not changed gpg: Numero totale esaminato: 1 gpg: non modificate: 1 keith ~ $ ffmpeg-compat thank

muflone commented on 2016-10-29 15:18 (UTC)

@ector you need to import the gpg key gpg --keyserver pgp.mit.edu --recv-keys FCF986EA15E6E293A5644F10B4322F04D67658D8

ector commented on 2016-10-28 11:19 (UTC)

salve, when I install ffmpeg-compat I have this error: 100 473 100 473 0 0 1495 0 --:--:-- --:--:-- --:--:-- 1496 ==> Validazione di source file con sha256sums... ffmpeg-2.3.6.tar.bz2 ... Verificato ffmpeg-2.3.6.tar.bz2.asc ... Ignorato ==> Validazione delle firme dei sorgenti con gpg in corso... ffmpeg-2.3.6.tar.bz2 ... NON RIUSCITO ==> ERRORE: Una o più firme PGP non possono essere verificate! ==> ERRORE: Makepkg non è riuscito a compilare libavutil-52. ==> Riavviare la compilazione di libavutil-52 [s/N] ==> ----------------------------------------------- ==>

muflone commented on 2016-10-18 00:06 (UTC)

@felis the package ffmpeg2.8 in extra repository already contains libavformat.so.56, libavdevice.so.56 and libavcodec.so.56

commented on 2016-09-29 16:39 (UTC)

Seems like the main package has moved to 57. Can you make a package for version 56?

muflone commented on 2016-02-07 00:55 (UTC)

Isn't the 56 version the same for the ffmpeg package?

EndlessEden commented on 2016-01-04 22:05 (UTC)

can we get the same for 56. for those of us running trunk versions of ffmpeg.

muflone commented on 2014-11-05 18:17 (UTC)

Ok, I got it. Such encoder is provided by the libcrystalhd 20100703-3 from the AUR. Please remove such package or build this package in a clean environment.

muflone commented on 2014-11-05 18:07 (UTC)

@LeetShiva The difference between your build process and mine is that you're trying to build the h264_crystalhd codec which I haven't and I don't know where you're picking it from. Maybe the ffmpeg build process detects that in your system but the build process for this encoder is broken. You should build the package in a clean chroot (extra-x86_64-build) or explain to me how to enable such encoder which is not provided by any package dependencies.

muflone commented on 2014-11-05 17:45 (UTC)

@LeetShiva I cannot reproduce your issue, neither in i686 nor in x86_64. What kernel version are you using?

LeetShiva commented on 2014-10-19 22:52 (UTC)

This aur package fails to build on my machine. This is the output I get with errors http://pastebin.com/7fTeff4z May you please fix this or tell me how to fix this myself.