Package Details: ffmpeg-full-git 4.3.r95713.g0e49560806-1

Git Clone URL: https://aur.archlinux.org/ffmpeg-full-git.git (read-only)
Package Base: ffmpeg-full-git
Description: Complete solution to record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac; git version)
Upstream URL: https://www.ffmpeg.org/
Keywords: audio codec convert cuda cuvid decklink encoder fdk-aac fdkaac ffmpeg ffmpeg-git hwaccel intel-svt libnpp media nvenc qsv quicksync vaapi video
Licenses: custom: nonfree and unredistributable
Conflicts: ffmpeg
Provides: ffmpeg, ffmpeg-full, ffmpeg-git, libavcodec.so, libavdevice.so, libavfilter.so, libavformat.so, libavresample.so, libavutil.so, libpostproc.so, libswresample.so, libswscale.so
Submitter: dbermond
Maintainer: dbermond
Last Packager: dbermond
Votes: 11
Popularity: 0.86
First Submitted: 2015-12-27 19:22
Last Updated: 2019-11-11 20:56

Dependencies (107)

Required by (943)

Sources (6)

Latest Comments

1 2 3 4 5 6 Next › Last »

dbermond commented on 2019-11-11 20:57

@troyBORG Fixed.

troyBORG commented on 2019-11-11 04:03

==> Validating source files with sha256sums...

ffmpeg ... Skipped

ffmpeg-full-git-add-svt-hevc-1.4.1.patch ... Passed

ffmpeg-full-git-add-svt-hevc-docs-1.4.1.patch ... Passed

ffmpeg-full-git-add-svt-av1-0.6.0.patch ... Passed

ffmpeg-full-git-add-svt-vp9-gce24589.patch ... Passed

LICENSE ... Passed

==> Removing existing $srcdir/ directory...

==> Extracting sources...

-> Creating working copy of ffmpeg git repo...

Cloning into 'ffmpeg'...

done.

==> Starting prepare()...

error: patch failed: doc/general.texi:243

error: doc/general.texi: patch does not apply

==> ERROR: A failure occurred in prepare().

Aborting...

Error making: ffmpeg-full-git

dbermond commented on 2019-08-30 12:51

@troyBORG Package is building fine with the latest dav1d 0.4.0-1 from the official repositories.

Do you have a non-updated system? If so, please make sure to have an updated system (by executing 'pacman -Syu') before building any AUR package.

troyBORG commented on 2019-08-30 05:35

ERROR: dav1d >= 0.4.0 not found using pkg-config

How do I fix this?

==> Starting build()... -> Running ffmpeg configure script... ERROR: dav1d >= 0.4.0 not found using pkg-config

If you think configure made a mistake, make sure you are using the latest version from Git. If the latest version fails, report the problem to the ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net. Include the log file "ffbuild/config.log" produced by configure as this will help solve the problem. ==> ERROR: A failure occurred in build(). Aborting...

dbermond commented on 2019-05-21 15:59

@ggrub This error is not from the ffmpeg building process. Please redirect it to the correct package.

ggrub commented on 2019-05-21 08:13

! LaTeX Error: File `newunicodechar.sty' not found.

dbermond commented on 2019-04-02 23:40

@Fog This is already fixed.

Fog commented on 2019-04-02 21:33

I've encountered that issue too and just removed that option from pkgbuild.

dbermond commented on 2019-03-23 18:19

@filthyAUR Fixed in the latest package update.

filthyAUR commented on 2019-03-20 20:17

==> Starting build()...
  -> Running ffmpeg configure script...
Unknown option "--enable-libndi_newtek".
See ./configure --help for available options.
==> ERROR: A failure occurred in build().
    Aborting...
Error making: ffmpeg-full-git

Caused by: https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/4b32f8b3ebfa011fcc5991bcaa97c3f5b61b49ad libndi_newtek was removed. PKGBUILD should remove that argument to ./configure.