Package Details: ffmpeg-libfdk_aac 2:7.0-3

Git Clone URL: https://aur.archlinux.org/ffmpeg-libfdk_aac.git (read-only, click to copy)
Package Base: ffmpeg-libfdk_aac
Description: Complete solution to record, convert and stream audio and video (Same as official package except with libfdk-aac support)
Upstream URL: https://ffmpeg.org
Licenses: custom:libfdk-aac, GPL-3.0-only
Conflicts: ffmpeg
Provides: ffmpeg, libavcodec.so, libavdevice.so, libavfilter.so, libavformat.so, libavutil.so, libpostproc.so, libswresample.so, libswscale.so
Submitter: korrode
Maintainer: zotan
Last Packager: zotan
Votes: 65
Popularity: 1.36
First Submitted: 2013-07-12 10:24 (UTC)
Last Updated: 2024-05-21 10:22 (UTC)

Required by (1856)

Sources (2)

Latest Comments

1 2 3 4 5 6 .. 18 Next › Last »

jonhoo commented on 2024-05-25 10:19 (UTC)

Just tried both builds, and can confirm that --enable-vaapi and --enable-vdpau make no difference to the build! Weee, no more patched PKGBUILD for me :)

zotan commented on 2024-05-25 09:51 (UTC)

Hmm, that's strange. In any case, the PKGBUILD of this package is identical to upstream except for the metadata and the one extra build flag for ffmpeg, so either it's broken in both or in neither ^^

jonhoo commented on 2024-05-25 09:50 (UTC)

Yeah, I agree with that as a goal too. It's a good question.. Looking at https://wiki.archlinux.org/title/FFmpeg#Hardware_video_acceleration, it says

Note: VA-API is generally enabled by ffmpeg's autodetect feature during build time, as long as it detects the respective headers and libraries included in libva, which should be a dependency of the FFmpeg package.

So maybe I'm just wrong that the explicit enable flag is needed 🤔

zotan commented on 2024-05-25 09:36 (UTC)

Hmm, my idea was to keep this identical to upstream except for the libfdk_aac encoder, to reduce maintenance burden and to make merging upstream changes as easy as possible. Do we know why the official package doesn't have these enabled?

jonhoo commented on 2024-05-25 09:32 (UTC)

Ah, no worries, I've done the same myself in the past!

By the way, thoughts on enabling vaapi and vdpau for the build? Currently keep a clone of this package just to add those 😅

zotan commented on 2024-05-25 09:28 (UTC)

@jonhoo, apologies, I was a bit over-eager with merging changes from extra/ffmpeg, will resolve itself when it gets moved from extra-staging to extra.

jonhoo commented on 2024-05-25 09:24 (UTC)

With an otherwise fully up-to-date system, this now fails to install (not build) with:

:: installing ffmpeg-libfdk_aac (2:7.0-3) breaks dependency 'libavcodec.so=60-64' required by mpv
:: installing ffmpeg-libfdk_aac (2:7.0-3) breaks dependency 'libavdevice.so=60-64' required by mpv
:: installing ffmpeg-libfdk_aac (2:7.0-3) breaks dependency 'libavfilter.so=9-64' required by mpv
:: installing ffmpeg-libfdk_aac (2:7.0-3) breaks dependency 'libavformat.so=60-64' required by mpv
:: installing ffmpeg-libfdk_aac (2:7.0-3) breaks dependency 'libavutil.so=58-64' required by mpv
:: installing ffmpeg-libfdk_aac (2:7.0-3) breaks dependency 'libswresample.so=4-64' required by mpv
:: installing ffmpeg-libfdk_aac (2:7.0-3) breaks dependency 'libswscale.so=7-64' required by mpv

zotan commented on 2024-04-24 15:56 (UTC)

I verified that the cherry-picks fix the build with ffnvcodec-headers 12.2.72.0 & updated the package. Thanks for reporting this!

zotan commented on 2024-04-24 15:47 (UTC)

@jesusaur one moment. @evilscientress these are already in this package though, unless I'm missing something?

evilscientress commented on 2024-04-24 14:36 (UTC)

Also check out the other cherry-picks in the main ffmpeg package. https://gitlab.archlinux.org/archlinux/packaging/packages/ffmpeg/-/blob/169a765abd4a55ae622dbcc3f7051b15c472a65d/PKGBUILD#L128-142