Package Details: ffmpeg-mmal 2:4.4-4

Git Clone URL: https://aur.archlinux.org/ffmpeg-mmal.git (read-only, click to copy)
Package Base: ffmpeg-mmal
Description: ffmpeg built with MMAL hardware acceleration support for Raspberry Pi
Upstream URL: https://ffmpeg.org/
Licenses: GPL3
Conflicts: ffmpeg
Provides: ffmpeg, libavcodec.so, libavdevice.so, libavfilter.so, libavformat.so, libavutil.so, libpostproc.so, libswresample.so, libswscale.so
Submitter: fmang
Maintainer: fmang
Last Packager: fmang
Votes: 12
Popularity: 0.65
First Submitted: 2016-09-14 09:46
Last Updated: 2021-06-26 14:18

Dependencies (59)

Required by (1000)

Sources (2)

Pinned Comments

fmang commented on 2020-06-12 11:24

General comment for users that get this x265 error when upgrading their system:

installing x265 (3.4-1) breaks dependency 'libx265.so=188-32' required by ffmpeg-mmal

Long story short, the simple solution is to remove ffmpeg-mmal, upgrade the system, then rebuild ffmpeg-mmal again.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

nini commented on 2017-05-30 17:38

I couldn't upgrade my system anymore because of issues with ffmpeg-mmal and x265, so I removed both and installed to the newest version of x265, which, when trying to install ffmpeg-mmal again, still resulted in the same error:

warning: cannot resolve "libx265.so=110-32", a dependency of "ffmpeg-mmal"
error: failed to prepare transaction (could not satisfy dependencies)

I have changed the PKGBUILD, so ffmpeg-mmal depends on x265, not libx265.so – now it works. Not sure if that's a sustainable solution though.

fmang commented on 2017-02-19 08:29

Updated to 3.2.4.

fmang commented on 2016-12-24 21:21

@joao I double checked and built the package, and the signature checked. Please make sure your system certificates are up to date.

joao commented on 2016-12-21 19:25

2 new errors:

==> Verifying source file signatures with gpg...
ffmpeg-3.2.2.tar.xz ... FAILED (error during signature verification)
==> ERROR: One or more PGP signatures could not be verified!

Tip for users:
to skip pgp checks (POTENTIALLY UNSAFE) pass --skippgpcheck to mkpkg.
if you use yaourt:

yaourt --m-arg "--skippgpcheck" mpv-rpi

will install mpv-rpi without checking validity of the downloaded files. at your own risk!


2nd Error: Build will fail unable to find pod2man

/bin/sh: pod2man: command not found
make: *** [doc/Makefile:119: doc/ffmpeg.1] Error 127
==> ERROR: A failure occurred in build().


Tip for users:
Probably an issue with perl.
remedy by appending /usr/bin/core_perl (or location of perl binaries) to your PATH.
For example: export PATH="/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/bin/core_perl"

fmang commented on 2016-12-20 22:00

Updated, along with mpv-rpi. Thanks for reporting.

Haven't had time to test the build, but since I've just imported the modifications for the upstream package, it should be alright.

fmang commented on 2016-12-20 08:38

The sha256 should not differ unless the ffmpeg team made a new release using the same version number, for some reason.

Anyway, there's probably a newer version by now. Will try to update this evening.

joao commented on 2016-12-19 23:26

==> ERROR: Integrity checks (sha256) differ in size from the source array.

PKGBUILD out of date?

fmang commented on 2016-09-14 11:41

mpv links to libmmal_core.so (and more) at runtime, which is how I found the name of the needed package (pacman -Qo).

That raspberrypi-firmware-tools dependency clearly makes the package Raspberry Pi-exclusive, and this is annoying. I wished it could be built on other platforms, even if there would have been no point in running it. Here, it cannot even build… I'll update the arch array later.

sekret commented on 2016-09-14 11:22

Ok, I think you're right, I'm sure it's not just a make-dependency, but a real dependency. Just like vlc-omx, which I have here on my system (I have no AUR package for it because it doesn't seem to work...)

I'll wait for it to finish compiling and give feedback if there's anything that doesn't work.

sekret commented on 2016-09-14 11:18

Ok nevermind, I added raspberrypi-firmware-tools to the makedepends, now it builds fine. I think you should add this! Or are there other platforms, which can make use of mmal and which aren't Raspberrys? In that case ... difficult!

About the arch array, are you sure there are i686 and x86_64 platforms which can make use of mmal?