Package Details: ffmpeg-yt-dlp-bin latest-1

Git Clone URL: https://aur.archlinux.org/ffmpeg-yt-dlp-bin.git (read-only, click to copy)
Package Base: ffmpeg-yt-dlp-bin
Description: FFmpeg Builds for yt-dlp
Upstream URL: https://github.com/yt-dlp/FFmpeg-Builds
Licenses: GPL
Conflicts: ffmpeg
Provides: ffmpeg
Submitter: alanaktion
Maintainer: alanaktion
Last Packager: alanaktion
Votes: 0
Popularity: 0.000000
First Submitted: 2022-03-23 04:23 (UTC)
Last Updated: 2022-03-23 04:23 (UTC)

Dependencies (0)

Required by (1493)

Sources (1)

Latest Comments

alanaktion commented on 2022-05-16 15:24 (UTC)

@MarsSeed I wasn't sure how best to name it as it doesn't build from source, but is not deterministic. I found other similar packages that worked as this one does though, which is why I submitted it like this. I can change to a -git package that builds from source, but since the upstream provides binary releases I chose to offer those in this package.

This package is useful for specific yt-dlp (package in Arch community repository) use cases, and is the recommended ffmpeg build from that package's developers. It includes fixes in ffmpeg 5.1 which is not yet up-to-date in Arch's Extra repository, but more importantly it includes useful patches not yet present in any upstream ffmpeg release.

I would expect this package to become less useful as ffmpeg is updated, but does solve certain issues with yt-dlp right now.

MarsSeed commented on 2022-05-14 16:00 (UTC)

Hi. I think this is not a proper package, as it is not deterministic.

The source should either be fixed, or this package should be created as a VCS package and renamed accordingly.

Btw, what is the reason for having this package in AUR? Is it really needed here?