Package Details: fgx-qt5 2.15.3-1

Git Clone URL: https://aur.archlinux.org/fgx-qt5.git (read-only)
Package Base: fgx-qt5
Description: Cross platform launcher for FlightGear, based on Qt5
Upstream URL: http://fgx.freeflightsim.org/
Licenses: GPL
Conflicts: fgx, fgx-git
Provides: fgx
Replaces: fgx, fgx-git
Submitter: tomaszc
Maintainer: tomaszc
Last Packager: tomaszc
Votes: 2
Popularity: 0.000775
First Submitted: 2016-05-10 05:16
Last Updated: 2016-09-20 20:51

Latest Comments

PhotonX commented on 2017-04-12 16:24

I get the following error:

==> Building and installing package
==> Making package: fgx-qt5 2.15.3-1 (Wed Apr 12 18:23:03 CEST 2017)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Cloning fgx git repo...
Cloning into bare repository '/tmp/yaourt-tmp-photon/aur-fgx-qt5/fgx'...
remote: Counting objects: 10821, done.
remote: Total 10821 (delta 0), reused 0 (delta 0), pack-reused 10821
Receiving objects: 100% (10821/10821), 10.43 MiB | 1.29 MiB/s, done.
Resolving deltas: 100% (5947/5947), done.
==> Validating source files with sha512sums...
fgx ... Skipped
==> Extracting sources...
-> Creating working copy of fgx git repo...
Cloning into 'fgx'...
done.
fatal: Cannot update paths and switch to branch 'makepkg' at the same time.
Did you intend to checkout 'origin/next-qt5' which can not be resolved as commit?
==> ERROR: Failure while creating working copy of fgx git repo
Aborting...
==> ERROR: Makepkg was unable to build fgx-qt5.

tomaszc commented on 2016-09-20 20:56

Thank you for feedback.
I added qt5-webkit to depends.

TehCraw commented on 2016-09-16 23:26

This package also requires qt5-webkit in order to build without errors.