Package Details: fim 0.6-3

Git Clone URL: https://aur.archlinux.org/fim.git (read-only, click to copy)
Package Base: fim
Description: FIM (Fbi IMproved) is a highly customizable and scriptable image viewer.
Upstream URL: https://www.nongnu.org/fbi-improved/
Licenses: GPL2
Conflicts: fim-svn
Submitter: Dragonlord
Maintainer: meanjollies
Last Packager: meanjollies
Votes: 26
Popularity: 0.59
First Submitted: 2008-02-27 17:02
Last Updated: 2020-07-23 05:21

Latest Comments

« First ‹ Previous 1 2 3 4 5

hav3lock commented on 2013-04-24 19:02

I don't really know how to answer your questions, since I don't know anything about PSF fonts or what the differences between PSF v1 and PSF v2 are. I have a feeling that this may be more of an internal fim-based problem than anything else. I'll try snooping through the source code and see if I can find anything there.

hav3lock commented on 2013-04-24 19:00

I get the same thing; I'm using Lat2-Terminus16 for my console font.

I'm not sure how to fix it either, otherwise I would have posted a comment on how to solve the problem. :/

menta commented on 2013-04-24 13:17

Hi,

Which font are you using fim with? For me 'fim image.png' reports:
can't use font /usr/share/kbd/consolefonts/lat1-16.psfu.gz: first two magic bytes (0x72 0xb5) conform to PSF version 2, which is unsupported.
font "(null)" is not available
The only PSF version 1 font I found on my system is /usr/share/kbd/consolefonts/LatGrkCyr-8x16.psfu.gz.

Is there a way to use PSF version 2 fonts or could you advise other PSF version 1 fonts?

Thanks in advance!

hav3lock commented on 2013-04-20 18:41

adopted and updated.

TrialnError commented on 2012-12-05 20:51

Updated PKGBuild to latest beta release

But an error occurs:

DebugConsole.cpp: in element function »int fim::MiniConsole::add(const char*)«:
DebugConsole.cpp:122:24: Error: invalid conversion of »const char*« to »char*« [-fpermissive]

BoySka commented on 2010-03-30 12:28

It seems that flex & bison are too old. How could you compile this?

BoySka commented on 2010-03-30 10:37

Missing dependencies: bison and flex
even with these, I can't compile (POSIX_PATH_MAX not defined in this scope)