Package Details: firefox-esr-gtk2 52.4.0-1

Git Clone URL: https://aur.archlinux.org/firefox-esr-gtk2.git (read-only)
Package Base: firefox-esr-gtk2
Description: Standalone web browser from mozilla.org, Extended Support Release
Upstream URL: https://www.mozilla.org/en-US/firefox/organizations/
Keywords: browser gecko web
Licenses: GPL, MPL, LGPL
Conflicts: firefox
Provides: firefox=52.4.0
Replaces: firefox-gtk2
Submitter: Case_Of
Maintainer: Case_Of (bidulock)
Last Packager: Case_Of
Votes: 46
Popularity: 0.460467
First Submitted: 2017-04-21 23:12
Last Updated: 2017-09-29 16:54

Dependencies (32)

Required by (211)

Sources (9)

Latest Comments

Techman35 commented on 2017-10-05 00:45

Case_of plis upload the update T.T

Case_Of commented on 2017-10-04 11:39

@bidulock: Hi, I'm having connection issues currently, I will be able to investigate on it next week.

bidulock commented on 2017-10-04 09:07

Won't build. I get:

==> Retrieving sources...
-> Found firefox-52.4.0esr.source.tar.xz
-> Found firefox.desktop
-> Found firefox-symbolic.svg
-> Found 0001-Bug-54395-remove-hardcoded-flag-lcrmf.patch
-> Found firefox-install-dir.patch
-> Found fix-wifi-scanner.diff
-> Found glibc-2.26-fix.diff
-> Found rust-i686.patch
-> Found make_SystemResourceMonitor.stop_more_resilient_to_errors.patch
==> WARNING: Skipping all source file integrity checks.
==> Extracting sources...
-> Extracting firefox-52.4.0esr.source.tar.xz with bsdtar
==> Starting prepare()...
patching file config/baseconfig.mk
Hunk #1 succeeded at 4 with fuzz 2.
patching file netwerk/wifi/nsWifiScannerDBus.cpp
patching file old-configure.in
patching file security/manager/ssl/moz.build
patching file linux/dump_writer_common/ucontext_reader.cc
patching file linux/dump_writer_common/ucontext_reader.h
patching file linux/handler/exception_handler.cc
patching file linux/handler/exception_handler.h
patching file linux/microdump_writer/microdump_writer.cc
patching file linux/minidump_writer/minidump_writer.cc
patching file build/moz.configure/rust.configure
Hunk #1 succeeded at 105 (offset 24 lines).
patching file testing/mozbase/mozsystemmonitor/mozsystemmonitor/resourcemonitor.py
==> Starting build()...
Your tree has not been configured yet. Please run |mach build| with no arguments.
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Build failed, check /u8/aur/64/brian/build

Alad commented on 2017-09-28 21:04

Regarding gcc63: note that this package was merged into gcc6.

eerie commented on 2017-08-26 10:54

I have gcc (GCC) 7.1.1 20170630 installed.
Since gcc63 is needed to build firefox-esr-gtk2, I'm trying to install it, but the build fails:
[..]
ranlib: $HOME/COWER_PACKAGES/firefox-esr-gtk2_Aug_2017/gcc63/src/gcc-4ca53f06ff7d346ef8021a23108f23a5406a0417/gcc-build/./gcc/libgcc_s.so.1: version `GCC_7.0.0' not found (required by /usr/lib/libLLVM-4.0.so)
make[4]: *** [Makefile:1126: install-leaf] Segmentation fault (core dumped)
make[4]: Leaving directory '$HOME/COWER_PACKAGES/firefox-esr-gtk2_Aug_2017/gcc63/src/gcc-4ca53f06ff7d346ef8021a23108f23a5406a0417/gcc-build/i686-pc-linux-gnu/libgcc'
make[3]: *** [Makefile:113: all] Error 2
make[3]: Leaving directory '$HOME/COWER_PACKAGES/firefox-esr-gtk2_Aug_2017/gcc63/src/gcc-4ca53f06ff7d346ef8021a23108f23a5406a0417/gcc-build/i686-pc-linux-gnu/libgcc'
make[2]: *** [Makefile:18054: all-stage1-target-libgcc] Error 2
make[2]: Leaving directory '$HOME/COWER_PACKAGES/firefox-esr-gtk2_Aug_2017/gcc63/src/gcc-4ca53f06ff7d346ef8021a23108f23a5406a0417/gcc-build'
make[1]: *** [Makefile:25049: stage1-bubble] Error 2
make[1]: Leaving directory '$HOME/COWER_PACKAGES/firefox-esr-gtk2_Aug_2017/gcc63/src/gcc-4ca53f06ff7d346ef8021a23108f23a5406a0417/gcc-build'
make: *** [Makefile:916: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

Case_Of commented on 2017-08-06 19:18

@Techman35: You should consider a PKGBUILD looking like this one http://ix.io/yVK

Techman35 commented on 2017-07-09 15:33

@Case_Of can you create a package for firefox-i18n-es-es cuz the comunity version require install firefox

[techman@techman-pc ~]$ sudo pacman -S firefox-i18n-es-es
resolving dependencies...
looking for conflicting packages...
:: firefox and firefox-esr-gtk2 are in conflict. Remove firefox-esr-gtk2? [y/N]

drankinatty commented on 2017-07-08 18:42

Thank goodness someone continued gtk+2 builds of firefox esr. gtk+3 is still just awkward looking. Kudos...

Case_Of commented on 2017-05-18 11:09

I know where is the problem with python. If pip is installed, build fail.
Uninstall pip while building.

Techman35 commented on 2017-05-12 17:32

@Case_Of Thank youuuuu, you are wonderful :D

All comments