Package Details: firefox-esr-i18n-pt-pt 115.3.1-1

Git Clone URL: https://aur.archlinux.org/firefox-esr.git (read-only, click to copy)
Package Base: firefox-esr
Description: Standalone web browser from mozilla.org, Extended Support Release
Upstream URL: https://www.mozilla.org/en-US/firefox/enterprise/
Keywords: browser gecko web
Licenses: GPL, MPL, LGPL
Submitter: figue
Maintainer: dudemanguy
Last Packager: dudemanguy
Votes: 46
Popularity: 0.29
First Submitted: 2015-05-28 23:15 (UTC)
Last Updated: 2023-09-28 22:25 (UTC)

Dependencies (37)

Required by (0)

Sources (100)

Latest Comments

1 2 3 4 5 6 .. 20 Next › Last »

bittin commented on 2023-03-14 15:55 (UTC)

perfect, thanks for maintaing this i took care of the -bin package

dudemanguy commented on 2023-03-14 15:09 (UTC)

@bittin: It compiled without any issues on my machine.

bittin commented on 2023-03-14 13:00 (UTC)

Getting compilation errors when trying to compile gkrust :(

bittin commented on 2023-03-14 12:04 (UTC)

got a new computer so helping out with compiling this one this time as i am curious how long time it takes ;) :)

bittin commented on 2023-02-15 23:10 (UTC)

nice to see someone taking over and updating this package

bittin commented on 2023-01-16 01:36 (UTC)

Sent an orphan request as jonathon died in cancer rip :(

and i don't feel like compiling updates for this package anymore as i don't have time nor the hardware maybe AndyRTR or someone else wants to take it over to compile 102.6.0 and 102.7.0 and future updates

AndyRTR commented on 2022-11-14 21:09 (UTC)

Please also update the checksums.

bittin commented on 2022-11-14 19:38 (UTC)

Compiling 102.5esr atm, will be up later today

jonathon commented on 2022-09-07 13:05 (UTC) (edited on 2022-09-07 15:14 (UTC) by jonathon)

It looks like the same issue hit firefox-nightly; I'm testing a build now and will push an update if it works.

Edit: Pushed an update, no pkgrel bump as no rebuild needed (if you have it already you don't need to compile it again).

sp1d3rmxn commented on 2022-09-07 12:48 (UTC) (edited on 2022-09-07 12:51 (UTC) by sp1d3rmxn)

@jonathon have the latest but still getting error.. noticed that this occurs after changing the line:

export MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=system

to

export MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=none

when I leave it at system the error it produces is:

zstandard                           0.18.0       /usr/lib/python3.10/site-packages
WARNING: You are using pip version 21.2.3; however, version 22.2.2 is available.
You should consider upgrading via the '/tmp/tmpkjcdwfsp/bin/python -m pip install --upgrade pip' command.
psutil<=5.8.0,>=5.4.2: Installed with unexpected version "5.9.1"
Traceback (most recent call last):
  File "/build/firefox-esr/src/firefox-102.2.0/./mach", line 96, in <module>
    main(sys.argv[1:])
  File "/build/firefox-esr/src/firefox-102.2.0/./mach", line 88, in main
    mach = check_and_get_mach(os.path.dirname(os.path.realpath(__file__)))
  File "/build/firefox-esr/src/firefox-102.2.0/./mach", line 35, in check_and_get_mach
    return load_mach(dir_path, mach_path)
  File "/build/firefox-esr/src/firefox-102.2.0/./mach", line 21, in load_mach
    return mach_initialize.initialize(dir_path)
  File "/build/firefox-esr/src/firefox-102.2.0/build/mach_initialize.py", line 153, in initialize
    _activate_python_environment(
  File "/build/firefox-esr/src/firefox-102.2.0/build/mach_initialize.py", line 99, in _activate_python_environment
    mach_environment.activate()
  File "/build/firefox-esr/src/firefox-102.2.0/python/mach/mach/site.py", line 359, in activate
    self.ensure()
  File "/build/firefox-esr/src/firefox-102.2.0/python/mach/mach/site.py", line 337, in ensure
result = self._up_to_date()
  File "/build/firefox-esr/src/firefox-102.2.0/python/mach/mach/site.py", line 322, in _up_to_date
    _assert_pip_check(
  File "/build/firefox-esr/src/firefox-102.2.0/python/mach/mach/site.py", line 1107, in _assert_pip_check
    raise Exception(
Exception: The "mach" site is not compatible with the installed system Python packages.
==> ERROR: A failure occurred in build().
    Aborting...

Otherwise I get the error I initially posted about however zstd is clearly installed... Thoughts?