Package Details: firefox-esr-privacy 60.1.0-1

Git Clone URL: https://aur.archlinux.org/firefox-esr-privacy.git (read-only)
Package Base: firefox-esr-privacy
Description: Standalone web browser from mozilla.org
Upstream URL: https://www.mozilla.org/firefox/
Keywords: browser gecko privacy web
Licenses: GPL, MPL, LGPL
Conflicts: firefox
Provides: firefox
Submitter: Wilco
Maintainer: Wilco
Last Packager: Wilco
Votes: 12
Popularity: 0.000003
First Submitted: 2016-03-09 08:55
Last Updated: 2018-07-30 07:16

Required by (216)

Sources (11)

Latest Comments

« First ‹ Previous 1 2 3 4

Klyachkivsky commented on 2016-05-02 07:05

How do I add my language to compile . My language = uk . Thanks .

Wilco commented on 2016-04-27 08:52

Update to FF 45.1, added provides = firefox

@Klyachkivsky: can you try to remove this line from the mozconfig file and compile? If it works correctly (i.e. youtube h264) with ffmpeg installed as runtime dependency, it might be worth removing this line.

ac_add_options --enable-gstreamer=1.0

Klyachkivsky commented on 2016-04-20 15:02

No , thanks . Is it possible to add ffmpeg ? Gstreamer is not needed .

Wilco commented on 2016-04-19 08:08

@Klyachkivsky: install gstreamer before compiling. I can add this dependency in the PKGBUILD when the next update comes.

Klyachkivsky commented on 2016-04-17 14:55

configure:22735: checking for alsa
configure:22742: checking MOZ_ALSA_CFLAGS
configure:22747: checking MOZ_ALSA_LIBS
configure:22990: checking for gstreamer-1.0 >= 1.0
gstreamer-app-1.0
gstreamer-plugins-base-1.0
configure: error: gstreamer and gstreamer-plugins-base development packages are needed to build gstreamer backend. Install them or disable gstreamer support with --disable-gstreamer
*** Fix above errors and then restart with\
"make -f client.mk build"

Wilco commented on 2016-04-13 13:35

Update to FF 45.0.2 New feature: enable tracking protection by default

Wilco commented on 2016-04-04 20:20

@alium: this package (incorreclty) lists GTK3 as a dependency but it still uses GTK2, which is the default with FF 45. So a rebuilt shouldn't be necessary

alium commented on 2016-04-04 06:06

@wilco: with new gtk 3.20, you will need to add two patches - see https://projects.archlinux.org/svntogit/packages.git/log/trunk?h=packages/firefox

Wilco commented on 2016-03-15 09:43

@alium: thanks, added.

Updated package to FF 45 ESR

alium commented on 2016-03-12 13:43

need add:
conflicts=('firefox')