Package Details: firefox-esr 78.8.0-1

Git Clone URL: https://aur.archlinux.org/firefox-esr.git (read-only, click to copy)
Package Base: firefox-esr
Description: Standalone web browser from mozilla.org, Extended Support Release
Upstream URL: https://www.mozilla.org/en-US/firefox/organizations/
Keywords: browser gecko web
Licenses: GPL, MPL, LGPL
Conflicts: firefox
Provides: firefox=78.8.0
Submitter: figue
Maintainer: figue (figuepluto, jfigueras)
Last Packager: figue
Votes: 38
Popularity: 0.029203
First Submitted: 2015-05-28 23:15
Last Updated: 2021-02-23 08:34

Dependencies (33)

Required by (125)

Sources (6)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

sp1d3rmxn commented on 2021-02-17 15:27

Kinda weird problem wondering if anyone else is getting this:

Traceback (most recent call last):
  File "build/pgo/profileserver.py", line 80, in <module>
httpd.start(block=False)
  File "/home/upgrade/firefox-esr/src/firefox-78.7.1/testing/mozbase/mozhttpd/mozhttpd/mozhttpd.py", line 269, in start
    self.httpd = EasyServer((self.host, self.port), self.handler_class)
  File "/usr/lib64/python2.7/SocketServer.py", line 420, in __init__
    self.server_bind()
  File "/usr/lib64/python2.7/BaseHTTPServer.py", line 108, in server_bind
    SocketServer.TCPServer.server_bind(self)
  File "/usr/lib64/python2.7/SocketServer.py", line 434, in server_bind
    self.socket.bind(self.server_address)
  File "/usr/lib64/python2.7/socket.py", line 228, in meth
    return getattr(self._sock,name)(*args)
socket.error: [Errno 98] Address already in use

I cannot figure out what it is trying to bind to that may already be in use because there is nothing running. Looking at the source I see the port set to "0" which according to the docs this is default. Any ideas?

figue commented on 2021-02-14 02:08

@sp1d3rmxn thanks. Patch added.

sp1d3rmxn commented on 2021-02-13 15:40

New release new bugs.. @figue if you please could add this patch:

reported: https://bugzilla.mozilla.org/show_bug.cgi?id=1692363

patch just uplifted 2days ago to ESR but available for 2 months for their other versions: https://bugzilla.mozilla.org/show_bug.cgi?id=1684261

figue commented on 2021-01-06 09:43

Yep... Updated. Thanks.

AndyRTR commented on 2021-01-06 08:50

It's there: https://archive.mozilla.org/pub/firefox/releases/78.6.1esr/

figue commented on 2021-01-05 22:20

@bittin 78.6.1esr is out? Can't found in official FTP.

figue commented on 2020-12-12 17:08

@sp1d3rmxn Thanks for the advice. See ea05890161bc

sp1d3rmxn commented on 2020-12-12 02:03

@figue

The same patch for icecat https://aur.archlinux.org/packages/icecat/#comment-779101 is going to be needed for this PKGBUILD to please. The only diff between them being "patch -Np1 -i ../../../rust_1.48.patch" needs to be "patch -Np1 -i ../rust_1.48.patch" as you may already know.

figue commented on 2020-11-16 22:52

@AndyRTR I'm building in a laptop with 16GB RAM with a W10 virtual machine running and it works for me. All patches are always welcome. I've cloned this package to my personal github, so pull requests will be accepted.

https://github.com/figue/firefox-esr

AndyRTR commented on 2020-11-16 21:03

I guess somewhere around 78.3.0 the memory requirement while linking toolkit/library/build/libxul.so had a huge jump. Now my 16gb are no more sufficient and the system starts heavy swapping. Maybe we can reduce this. heftig made some suggestions to turn off pgo, lto and use bfd linker with its memory saving flags but with paying in code quality. maybe via an optional switch in the PKGBUILD.