Package Details: firefox-esr60 60.9.0-1

Git Clone URL: https://aur.archlinux.org/firefox-esr60.git (read-only, click to copy)
Package Base: firefox-esr60
Description: Standalone web browser from mozilla.org, Extended Support Release 60.x
Upstream URL: https://www.mozilla.org/en-US/firefox/organizations/
Licenses: GPL, MPL, LGPL
Conflicts: firefox
Provides: firefox
Submitter: figue
Maintainer: figue (figuepluto, jfigueras)
Last Packager: figuepluto
Votes: 0
Popularity: 0.000000
First Submitted: 2019-07-08 22:50
Last Updated: 2019-09-02 19:22

Dependencies (30)

Required by (193)

Sources (7)

Latest Comments

sp1d3rmxn commented on 2019-11-16 11:13

Fucking thing doesn't build at all. What is "extended" about this "support" when the shit can't compile? Fuck this is so annoying:

9:12.85 error[E0506]: cannot assign to self.input.cached_token because it is borrowed 9:12.85 --> /build/firefox-esr60/src/firefox-60.9.0/third_party/rust/cssparser/src/parser.rs:572:17 9:12.85 | 9:12.85 547 | pub fn next_including_whitespace_and_comments(&mut self) -> Result<&Token<'i>, BasicParseError<'i>> { 9:12.85 | - let's call the lifetime of this reference '1 9:12.85 ... 9:12.85 560 | Some(ref cached_token) 9:12.85 | ---------------- borrow of self.input.cached_token occurs here 9:12.85 ... 9:12.85 572 | self.input.cached_token = Some(CachedToken { 9:12.85 | ^^^^^^^^^^^^^^^^^^^^^^^ assignment to borrowed self.input.cached_token occurs here 9:12.85 ... 9:12.85 584 | Ok(token) 9:12.85 | --------- returning this value requires that self.input.cached_token.0 is borrowed for '1 9:12.85 9:13.55 error: aborting due to previous error 9:13.55 9:13.55 For more information about this error, try rustc --explain E0506. 9:13.60 error: could not compile cssparser. 9:13.60 warning: build failed, waiting for other jobs to finish... 9:17.46 libsecurity_pkix_test_gtest.a.desc 9:18.85 libpkixtestutil.a.desc 9:24.18 libsecurity_apps.a.desc 9:34.44 libfreetype.a.desc 9:35.50 libsecurity_certverifier_tests_gtest.a.desc 9:37.27 libxpt.a 9:37.75 libxpt.a.desc 9:50.04 libxpcom_string.a.desc 9:53.36 libxpcomglue.a 10:14.66 error: build failed 10:14.66 make[4]: [/build/firefox-esr60/src/firefox-60.9.0/config/rules.mk:979: force-cargo-library-build] Error 101 10:14.66 make[3]: [/build/firefox-esr60/src/firefox-60.9.0/config/recurse.mk:73: toolkit/library/rust/target] Error 2 10:14.66 make[3]: Waiting for unfinished jobs.... 10:46.95 libjs_src.a.desc 10:47.08 make[2]: [/build/firefox-esr60/src/firefox-60.9.0/config/recurse.mk:33: compile] Error 2 10:47.08 make[1]: [/build/firefox-esr60/src/firefox-60.9.0/config/rules.mk:442: default] Error 2 10:47.08 make: [client.mk:169: build] Error 2 10:47.11 74 compiler warnings present. 10:47.14 Notification center failed: Install notify-send (usually part of the libnotify package) to get a notification when the build finishes. ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Build failed

So this and the regular firefox-esr don't build, so much cool.

figue commented on 2019-09-02 19:22

Thanks @AndyRTR Can you try if all is ok?