Package Details: firefox-extension-arch-search 1.0.1-1

Git Clone URL: https://aur.archlinux.org/firefox-extension-arch-search.git (read-only, click to copy)
Package Base: firefox-extension-arch-search
Description: A set of Web Extensions that adds ArchLinux (bug tracker, forum, packages, wiki, AUR) as a search engine to the Firefox browser.
Upstream URL: https://github.com/noraj/firefox-extension-arch-search
Keywords: firefox
Licenses: MIT
Groups: firefox-addons
Replaces: arch-firefox-search, arch-firefox3-search
Submitter: noraj
Maintainer: noraj
Last Packager: noraj
Votes: 14
Popularity: 1.59
First Submitted: 2020-10-12 21:21
Last Updated: 2020-10-12 21:21

Pinned Comments

noraj commented on 2020-10-12 21:35

new package available: https://aur.archlinux.org/packages/firefox-extension-arch-search It replaces this one.

Latest Comments

1 2 Next › Last »

noraj commented on 2020-10-12 21:35

new package available: https://aur.archlinux.org/packages/firefox-extension-arch-search It replaces this one.

noraj commented on 2020-10-11 18:05

@json I created the Web Extensions https://github.com/noraj/firefox-extension-arch-search, I just need to wait for the xpi to be approved by Mozilla and I'll be able to submit the new PKGBUILD.

PS: new extensions can't be installed if not signed (.xpi) by Mozilla else (with .zip) the install doesn't survive the browser reboot.

json commented on 2020-10-10 20:34

https://github.com/sangsatori/firefox-aur-search might serve as a good starting point. I opened a feature request for supporting the other sites in that web-extension. But feel free to tackle the issue yourself :)

noraj commented on 2020-10-10 19:49

@json Thanks for the info, that feature downgrade sucks. It's much more work to create an extension for any search page. I'll write a web-extension to replace the opensearch XML one.

json commented on 2020-10-10 11:06

If https://bugzilla.mozilla.org/show_bug.cgi?id=1649971 is any indication, the feature to define and ship search engines via XML has been removed.

keksbg commented on 2020-09-09 19:42

Doesn't appear to support the standard firefox-developer-edition package but it supports firefox-developer-edition-firefox-symlink-latest. As for if it works I have got no idea. EDIT: nevermind, i guess whoever manages the package group should update that

noraj commented on 2020-08-23 13:37

I confirm it's not showing up on Firefox 79.0

holyArch commented on 2020-07-30 16:36

They don't show up in Firefox 79.

homocomputeris commented on 2020-07-22 11:05

They don't appear in 78.0.2.

pdc commented on 2020-07-01 20:48

They're back in version 78.0.1-1.